Copy/Paste to Word on Mac

Page 1 of 2 (27 items) 1 2 Next >
This post has 26 Replies | 4 Followers

Posts 14
Bill Ball | Forum Activity | Posted: Fri, Feb 20 2015 1:52 PM

Running current Logos and Mac 10.10 (Yosemite) and Parallels (running Win 8.1).

  1. I have MS Office installed on both the Mac and Windows sides
  2. I'm using Logos on the Mac side
  3. When I use Copy Verses to PowerPoint, it does as expected—opens PPT on Mac side and pastes the scripture.
  4. However, when I use Copy Verses to Word, it loads Parallels, and then Word for Windows...which I do NOT want. (BTW, doesn't paste the verses in either)

Tech support was unable to help. Anyone have an idea how to get Logos to use PPT for Mac instead?

Thanks.

Posts 27554
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, Feb 20 2015 2:04 PM

I don't use parallels... my <guess> is that you have .docx files associated with word for windows (within OS X)... or that parallels has taken over control of that file type from within parallels itself. I don't think the issue is related to Logos... but I could be wrong. 

OSX & iOS | Logs |  Install

Posts 14
Bill Ball | Forum Activity | Replied: Fri, Feb 20 2015 2:18 PM

When Parallels was installed (Dec.) it did set the default .docx and .pptx files to open with the Parallels/Windows version of their Office products. However, I immediately reset those defaults to the Mac Office products and everything works fine when opening up (double-clicking) a document directly; i.e., it opens Word and Powerpoint for Mac. Logos is the only program that hiccups here, and just on Word, not Powerpoint.

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Fri, Feb 20 2015 2:32 PM

Bill, there is an alternative way of pasting Bible verses in Mac that may function as a workaround for you:

Logos has a "Replace with Passage" service that allows you to select a reference in your word processor and then press a keyboard shortcut. Then the reference is replaced with the passage using whatever template you have active in the Copy Bible Verses panel.

To use it, open up the System Preferences on your Mac, and click on the "Keyboard" preferences. Find the "Replace With Passage" service under "Shortcuts." Make sure it is checked and note the shortcut (you can change it if you want).

Now, in your word processor, type a reference, like matt 1:20-23, select it, and press the keyboard shortcut Shift-Command E. It should replace the reference with the passage.

If it doesn't work, it's usually because the reference has a character that it shouldn't, like a period, e.g., matt 1:20-23.

I know this doesn't fix the issue, but I'd thought I'd throw it out there as an alternative.

Posts 14
Bill Ball | Forum Activity | Replied: Fri, Feb 20 2015 3:48 PM

Thanks, very cool! Can't figure out how to avoid the red, underlined, left-edge "|" on the paste (even when selecting destination formatting).

Finally fixed the problem though (in case anyone else runs up against this issue). I reconfigured Office in Windows, removing Word. Checked Logos, and it worked fine. Then reversed the process, adding Word back in (Windows) and tested Logos again and voila, works fine. Just wish I knew what was happening behind the scenes to understand what actually effected the change. Oh well, back to work. Thanks again.

Posts 113
Samuel | Forum Activity | Replied: Wed, Feb 25 2015 7:02 AM

For some reason, Replace with Passage still does not format the verse correctly (at least on Mac). In my case, I use superscript verse numbers which works fine if I use Copy Bible Verses and paste into Word. However, if I use Replace with Passage the verse numbers are not superscribe, they are regular font. I really wish they would fix this. Every time I've asked about it, I never get a clear answer, I usually get questions about Word on Windows...

Posts 2695
Kevin A. Purcell | Forum Activity | Replied: Wed, Feb 25 2015 3:00 PM

Bill Ball:
Can't figure out how to avoid the red, underlined, left-edge "|" on the paste (even when selecting destination formatting).

This is using Word's Review tools where it is inserting the text and wants you to either accept or reject the change. However, there's a quick way to set up a keyboard shortcut to do this quickly. Just follow the tip at this address.

http://apple.stackexchange.com/questions/52063/word-2011-keyboard-shortcuts-for-accepting-rejecting-a-tracked-change-and-movin

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 6:28 AM

Integ:

THANK YOU! I did not know this keyboard shortcut existed. I will be doing so. 

John

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 10:16 AM

Does anyone know why this would not work on Apple's Pages 5.5.2? It works on Text edit. 

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Feb 26 2015 10:23 AM

It works for me in Pages 5.5.2 on Yosemite 10.2. Have you tried restarting your computer? Sometimes the services menu needs a reboot to get things on it.

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 12:48 PM

Integ,

Yes, I restarted several times. It will work in Textedit, but, not in Pages. I can press the ⌘ J and get the copy dialog up from Logos. I've switched the key combination, still nothing. 

This is odd.

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Feb 26 2015 1:00 PM

Your problem (possibly) is that cmd-j is already used by Pages (it's jump to selection). Pick another shortcut combination and you should be good.

EDIT: just noticed that Textedit also has cmd-j as a shortcut, but it's still worth a try to change it to something else.

You can also click on the from the services menu to see if it works...if it does, it's a shortcut key issue and you should try a different shortcut combination.

EDIT AGAIN: personally, I use Ctrl-Option-Cmd-B (for Bible). I know it sounds like a lot, but it's really easy to mash those three keys down on the left side of my keyboard, and I've never had a conflict with another shortcut key.

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Feb 26 2015 1:11 PM

BTW: Are you using "Replace with Passage" or "Copy Bible Verses" as a service? I use the former, I've had trouble with the latter one.

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 2:31 PM

I am using replace with passage. I've restarted several times. All of those to no avail.

There is a screen cast at the link below. 

https://www.dropbox.com/s/q9bvqb7hc8szr38/ScreenCast%20of%20failed%20Command%20E%20Pasting%20issue.mov?dl=0

Click here to play this video

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Feb 26 2015 2:44 PM

Thanks for being patient John—my browser says I am missing a plugin, so I can't watch your video.

But can you verify if clicking "replace with passage" from the Pages service menu works?

(Don't pay any attention to my shortcut combination—it's part of a setup I have with Launchbar)

If it works by clicking on it, then change your shortcut to something else as I mentioned in a previous post.

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 2:53 PM

Hmm, services doesn't show up in Pages.

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Feb 26 2015 2:56 PM

Be sure you have a verse reference selected, without any extra characters. It won't show up otherwise. Try the reference I did in my screenshot.

EDIT: Just got your movie to work and can see that is what you were doing. Hmm...let me think.

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 3:00 PM

These are the services. If I use another Word Process (TextEdit) they key combo works.

Posts 1555
Forum MVP
Levi Durfey | Forum Activity | Replied: Thu, Feb 26 2015 3:05 PM

Okay, John, here's the deal. I think I got it. Shift-Command E does not work as a shortcut in Pages. I just tried it and it didn't work.

Try something like Ctrl-Option-Command B (or E). 

The service will not appear in the menu unless a reference is selected in Pages.

We're almost there, I can feel it!

Posts 22
John O'Malley | Forum Activity | Replied: Thu, Feb 26 2015 3:16 PM

Very Interesting development. I highlighted the text, pressed the key combo. Nothing. I checked in the services menu. It is there. If I click on it it pastes. If I just press it it doesnt. 

Page 1 of 2 (27 items) 1 2 Next > | RSS