Prepare Library - infinite loop

Page 1 of 1 (10 items)
This post has 9 Replies | 1 Follower

Posts 139
Noel Fitzpatrick | Forum Activity | Posted: Fri, Mar 13 2015 1:19 PM

When I open Verbum (Logos 6), by clicking the icon in the taskbar, after some time I see "Preparing your library.  This may take some time".  This seems to be lasting longer that I would expect.

I  have set  "Turn off display" to never, and  "Put computer to sleep" also to never.

Please advise.  Thanks.

Posts 26510
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Mar 13 2015 1:29 PM

Does this occur after a download of resources or every time you start Verbum?  What operating system?

The computer settings won't affect it, but we will need to see some logs to diagnose the problem. Be sure to permanently enable logging and upload the compressed log files folder as per the article.

Dave
===

Windows 10 & Android 8

Posts 139
Noel Fitzpatrick | Forum Activity | Replied: Fri, Mar 13 2015 2:30 PM

Dave Hooton,

many thanks.

This has happened only once.  Recently I asked for a free resource (St Patrick).  I use windows 8.1.

I will let the computer run overnight and see does the problem resolve itself, if not tomorrow I will try to get logs, as you suggest.

Posts 139
Noel Fitzpatrick | Forum Activity | Replied: Sat, Mar 14 2015 8:51 AM

Thank you so much for your advice.

I am not sure what I should do, but I have tried to follow instructions and now have a zipped file: 'This PC' -> Documents -> Verbum Log Files -> VerbumError-2.  Now how do I upload? 

Here is a paste version.  I do not know if this is correct.

If all of this does not help, should I start again with simpler instructions?

Thanks for help and regrets for problems.

NoelFitz.

/*** Deleted pasted log file ***/

Posts 24516
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Mar 14 2015 8:58 AM

Noel Fitzpatrick:
Now how do I upload? 

Please don't paste logs in a reply but rather attach them to a reply using the paperclip icon

Posts 139
Noel Fitzpatrick | Forum Activity | Replied: Sat, Mar 14 2015 9:02 AM

Ooops, sorry.  I will try to use the paper clip. I hope this is OK.

I sincerely regret my error.  I hope it has not been too inconvenient, and that my problem can be resolved

2678.VerbumError-2.zip

Posts 24516
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Mar 14 2015 9:05 AM

Noel Fitzpatrick:
Ooops, sorry.  I will try to use the paper clip. I hope this is OK.

That's great - thanks

Noel Fitzpatrick:
I sincerely regret my error.  I hope it has not been too inconvenient

No problem - its just that they are difficult to read / analyse in a post!

Noel Fitzpatrick:
and that my problem can be resolved

Is there also an indexer log file? If so, please upload it.

Posts 26510
Forum MVP
Dave Hooton | Forum Activity | Replied: Sat, Mar 14 2015 9:34 PM

Graham Criddle:
Is there also an indexer log file? If so, please upload it.

The Verbum.log indicated that the indexer was already running, so you will have to wait until the next time you see the message Preparing your Library, then wait until it finishes and then upload the log files folder again.

Dave
===

Windows 10 & Android 8

Posts 139
Noel Fitzpatrick | Forum Activity | Replied: Sun, Mar 15 2015 1:53 AM

Thanks for interest and help.

There was no indexer file, and the "Preparing your Library" process continues indefinitely,  that is the problem.

Posts 26510
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Mar 15 2015 2:15 PM

Noel Fitzpatrick:
There was no indexer file, and the "Preparing your Library" process continues indefinitely,  that is the problem.

Enable logging as described, then restart your computer and Logos. This should ensure there is an Indexer log. Upload the log files folder after one hour of Preparing... If necessary, you can kill the Indexer process (LogosIndexer.exe) in Task Manager.

Dave
===

Windows 10 & Android 8

Page 1 of 1 (10 items) | RSS