[ACK] Broken? Library "Save as Collection" feature

Page 1 of 1 (12 items)
This post has 11 Replies | 1 Follower

Posts 147
Pete De Bonte | Forum Activity | Posted: Sat, Jun 6 2015 9:51 AM

Is Faithlife aware that the "Save as Collection" feature is broken?

Motive & Workaround: I wanted to use this feature to create a collection of my entire library before merging with the Logos Cloud Premium resources.  For that, dragging items to the collection one-by-one was impractical, so I ended up tagging my entire library instead.

I agree w/Morris Proctor that "Save as Collection" sounds like a helpful feature, so I wonder: could it be fixed easily?
Thanks,
-Pete

Posts 12106
Forum MVP
NB.Mick | Forum Activity | Replied: Sat, Jun 6 2015 10:07 AM

I can confirm this feature (along with Save as Bibliography) does work when the library is open in a floating window or a tab, but not in the drop-down library - Win 7 32bit here.

Since I'm running beta, I'll cross-post in the beta forum.

Running Logos 9 latest (beta) version on Win 10

Posts 12106
Forum MVP
NB.Mick | Forum Activity | Replied: Sat, Jun 6 2015 10:19 AM

Pete De Bonte:
could it be fixed easily?

Seems like a program bug. If it's easy to fix, they may include this into 6.4 which is out in about a month or so. Watch this thread or the one in the beta forum https://community.logos.com/forums/t/105948.aspx for answers by Faithlife.

Until then, just use the library in a separate tab or a floating window.

Running Logos 9 latest (beta) version on Win 10

Posts 147
Pete De Bonte | Forum Activity | Replied: Sat, Jun 6 2015 10:22 AM

NB.Mick:
Until then, just use the library in a separate tab or a floating window.

Perhaps I buried it in the too-much-detail of my original post, but
it doesn't work for even in a separate tab or floating window.

If I do have the library open in a separate tab or window, I see the collection appear momentarily, and then it disappears and selects my first collection (named "Dictionaries") is selected, even if that wasn't the one that I had selected before attempting the Save as Collection. If I look at the list of collections, a new collection has not been created.  I even tried creating an empty collection first, to possibly receive the Save as Collection result (it didn't help)

Posts 12106
Forum MVP
NB.Mick | Forum Activity | Replied: Sat, Jun 6 2015 10:28 AM

Pete De Bonte:

NB.Mick:
Until then, just use the library in a separate tab or a floating window.

Perhaps I buried it in the too-much-detail of my original post, but
it doesn't work for me at all, (even in a separate tab or floating window).

Oh sorry, I overlooked that in your OP.

The developers will probably need more info to tackle that.

Can you create a "diagnostic log" by starting Logos with the Ctrl-key down, opening your library in a tab or window and then selecting some books from your library and trying to save as Collection? (By the way: does save as Bibliography work for you there?). Then upload the logos.log file here with the paperclip icon - see https://wiki.logos.com/diagnostic_logging for details.   

Running Logos 9 latest (beta) version on Win 10

Posts 147
Pete De Bonte | Forum Activity | Replied: Sun, Jun 7 2015 3:00 PM

NB.Mick:
The developers will probably need more info to tackle that. Can you create a "diagnostic log"…

I believe I can do better, as I finally succeeded.  For me, Save as Collection:

  • SUCCEEDS: when "Library" is the only open panel.
  • FAILS: if a "Collections" panel is opened before clicking "Save as Collection" in the Library panel.
    (As described in my previous post, I see the new collection for a split-second, but then it switches to my "Dictionaries" collection and the new collection is not saved)

Can you reproduce that particular "Save as Collections" failure in L6.4 beta?

NB.Mick:
does save as Bibliography work for you there

Good question: Save as Bibliography, in contrast, works for me even if I have a Bibliography panel open already; however, it also opens a new panel for every operation instead of trying to reuse a currently open panel (which is what Save as Collection tries to do when it fails for me)

Posts 12106
Forum MVP
NB.Mick | Forum Activity | Replied: Sun, Jun 7 2015 3:42 PM

Pete De Bonte:
if a "Collections" panel is opened before clicking "Save as Collection" in the Library panel.
(As described in my previous post, I see the new collection for a split-second, but then it switches to my "Dictionaries" collection and the new collection is not saved)

I see the same - with my "#encyclopediae" collection - when the collections panel was open and think this is a separate bug from the one before. 

Running Logos 9 latest (beta) version on Win 10

Posts 262
LogosEmployee
Steve Workman | Forum Activity | Replied: Tue, Jun 9 2015 5:01 PM

I am able to replicate this and have filed a ticket to look into a resolution.

Posts 147
Pete De Bonte | Forum Activity | Replied: Tue, Jun 9 2015 7:26 PM

Steve Workman:
I am able to replicate this and have filed a ticket to look into a resolution.

Thank you, Steve; however, your use of "this" (singular) makes me wonder: did you notice that I'd reported two failure scenarios in this thread?

  1. Attempts to access the Save as Collection feature via the Library drop-down/menu instead of a Library tab or window
    [Save as Bibliography also fails in this scenario, as NB.Mick reported]
  2. Attempts to use the Save as Collection feature when a Collections tab is already open.
    [Save as Bibliography does not also fail in this scenario]

?

Posts 262
LogosEmployee
Steve Workman | Forum Activity | Replied: Thu, Jun 11 2015 5:14 PM

I apologize for my poor word choice.  We do have a ticket for both of the issues.

Posts 147
Pete De Bonte | Forum Activity | Replied: Thu, Jun 11 2015 8:39 PM

Steve Workman:
I apologize for my poor word choice.  We do have a ticket for both of the issues.

Super!

(and as for wording, I only expect God to be perfect : )

Posts 1471
Angela Murashov | Forum Activity | Replied: Tue, Jun 23 2015 11:55 AM

Pete De Bonte:

Steve Workman:
I am able to replicate this and have filed a ticket to look into a resolution.

Thank you, Steve; however, your use of "this" (singular) makes me wonder: did you notice that I'd reported two failure scenarios in this thread?

  1. Attempts to access the Save as Collection feature via the Library drop-down/menu instead of a Library tab or window
    [Save as Bibliography also fails in this scenario, as NB.Mick reported]
  2. Attempts to use the Save as Collection feature when a Collections tab is already open.
    [Save as Bibliography does not also fail in this scenario]

?

Both of these issues should be fixed in 6.4 RC1.

Page 1 of 1 (12 items) | RSS