speed issue. What does acceptable performance look like?

Page 1 of 2 (22 items) 1 2 Next >
This post has 21 Replies | 2 Followers

Posts 164
Rick Harrell | Forum Activity | Posted: Thu, Feb 4 2010 2:13 PM

I have been attempting to spped up Logos 4. I have tried most of the fixes referenced on the Wiki (tablet stuff, compatibility settings,etc.) and have seen no appreciable change. I have been trying to speed up the Information pane – it takes 5 seconds to begin to update and  3 or more  seconds to complete the update on both machines, while the hover info is almost instantaneous. Searches are quite quick.

Is this normal performance for Logos 4?

My systems -

Toshiba laptop, 4 Gig ram, AMD Turion x2 dual core mobile RM-72 2.10 Ghz, Windows Vista Home Premium service pack 2. 320 Gig hard drive

Hp desktop – 3 Gig ram, desktop - XP professional SP 3,  3 Gig ram, AMD 64 X2 dual core 2.18 ghz., 250 gig HD

 

Any thoughts?

Posts 323
Doug | Forum Activity | Replied: Thu, Feb 4 2010 2:44 PM

frederickharrell:

I have been attempting to spped up Logos 4. I have tried most of the fixes referenced on the Wiki (tablet stuff, compatibility settings,etc.) and have seen no appreciable change. I have been trying to speed up the Information pane – it takes 5 seconds to begin to update and  3 or more  seconds to complete the update on both machines, while the hover info is almost instantaneous. Searches are quite quick.

Is this normal performance for Logos 4?

My systems -

Toshiba laptop, 4 Gig ram, AMD Turion x2 dual core mobile RM-72 2.10 Ghz, Windows Vista Home Premium service pack 2. 320 Gig hard drive

Hp desktop – 3 Gig ram, desktop - XP professional SP 3,  3 Gig ram, AMD 64 X2 dual core 2.18 ghz., 250 gig HD

 

Any thoughts?

What you are describing sounds quite normal to me.  This is about the same performance that I get on my HP laptop with 3 gigs ram, AMD Turion Ultra 64 X2 2.2GHz.  Are noticing anything sluggish in particular?  Or does the program just run like it's big and bulky?  That's kind of what it feels like to me on my laptop.  Now, I have an i7 desktop system at home that doesn't really struggle with L4 at all.

 

Posts 97
Greg Gray | Forum Activity | Replied: Thu, Feb 4 2010 2:54 PM

With the new Beta, the information tool can be much faster depending on how you set it up.  I have tried Logos 4 on 5 different setups - I have tried upgrading ram - went from a dual core to a quad on the desktop - tried a ssd (great for everything else but makes very little difference to L4), and a faster video card.  The video card seems to make the biggest difference by far. 

Posts 164
Rick Harrell | Forum Activity | Replied: Thu, Feb 4 2010 2:55 PM

Doug:
Are noticing anything sluggish in particular?  Or does the program just run like it's big and bulky? 

 

My issue is with the Information pane update speed - where 3.0 hover was really snappy on both machines to get equivalent info from 4 takes 8+ seconds. I also have internet turned off.

Posts 164
Rick Harrell | Forum Activity | Replied: Thu, Feb 4 2010 3:11 PM

My laptop is less than a year old and I blew most of my computer budget for the year on the Logos upgrade (gold to platinum) so I will not be doing any hardware upgrades. Photoshop CS4 feels fast compared to this.

Posts 1
Rob Bushway | Forum Activity | Replied: Thu, Feb 4 2010 3:32 PM

I am noticing the same performance issues, even with internet turned off. Hover takes 5 - 8 seconds, moving around menu options hangs frequently, keyboard input in to the search is slow as well.

Is Logos aware of these performance issues? I find them unworkable.

Posts 1228
Ron | Forum Activity | Replied: Thu, Feb 4 2010 4:16 PM

Greg Gray:

With the new Beta, the information tool can be much faster depending on how you set it up.  I have tried Logos 4 on 5 different setups - I have tried upgrading ram - went from a dual core to a quad on the desktop - tried a ssd (great for everything else but makes very little difference to L4), and a faster video card.  The video card seems to make the biggest difference by far. 

Greg,

What video card did you have previously and what card did you upgrade to?  Where did you notice the performance improvement after the upgrade?  The reason I'm asking is because a) I'm surpised that a video card upgrade made a bigger difference than going from dual core to quad core and b) I'm debating between those two upgrades myself (currently have a 7600GT video card and a Core 2 Duo 3GHz...debating a current mainstream class [<=$200] video card and/or upgrading to a Core 2 Quad 3GHz.)

Posts 38
Francis Jeffries | Forum Activity | Replied: Thu, Feb 4 2010 4:37 PM

If you want your installation to speed up a bit.  Try setting the USE THE Internet option to no in the program setting.   You will not be able to sync with your other installations, but it will probably speed things up.  Do not set download automatically to no.   Might help, might not.  I think all the performance has to do with the cloud and sync. Stick out tongue

Posts 22
Tam Nguyen | Forum Activity | Replied: Mon, Feb 8 2010 8:11 PM

I have a core2quad @ 3 ghz  and 4 GB of rams.

It still takes my system about 5 secs to load new data in the Information Window. I have to resort to L3 for my translations. I could not recommend Logos 4 for anyone that primarily uses it for translation as of now.

Posts 116
Matt | Forum Activity | Replied: Mon, Feb 8 2010 9:07 PM

frederickharrell:
Any thoughts?

I see lags commensurate with yours on my system.  I believe Logos will eventually iron these hiccups out, but for those who are used to snappier performance from their modern-day computers with other more CPU and data-intensive programs, I think it would be beneficial for Logos to officially state on their 'to-do' list that these types of performance tuning will be addressed in due time.  I guess it's implied by 'fine-tuning the software,' but that is a bit vague in my opinion.

Has Logos made any offiical statement about these types of issues?

Matt

Specs:

  • Windows 7 x64
  • Quad Xeon 2.83 GHz x2
  • 16GB RAM
  • Nvidia 285 GTX 1GB VRAM
  • Logos 4.1 Platinum, SR-3, indexed
    Posts 667
    Jonathan Pitts | Forum Activity | Replied: Tue, Feb 9 2010 3:07 AM

    This performance sounds about the same as mine. Using a laptop without a separate graphics card, I found the program was very slow starting if I had the exegetical guide or passage guide open (and I found most of the stuff in those guides I did not use). Having changed to only using the guides when I specifically want the information, performance is better.

    I now rely much more on the Information pane. Performance is acceptable when the laptop is plugged in, although I wouldn't say no to it being a little faster. However, when reading on the train and relying on the battery, it can be hard work and very slow.

    I guess there has to be some delay in the Information pane responding, otherwise it will try looking up every word that the cursor passes over even briefly. But it could do with being a bit faster.

    Posts 10817
    Forum MVP
    Jack Caviness | Forum Activity | Replied: Tue, Feb 9 2010 7:33 AM

    JonathanPitts:
    I guess there has to be some delay in the Information pane responding, otherwise it will try looking up every word that the cursor passes over even briefly. But it could do with being a bit faster.

    The current Beta has an option to have Information update only when you click, but it still loads slowly. However, it does speed thing up a bit when Information does not respond to every word you pass over.

    Hopefully, this will make it into 4.0b soon.

    Posts 164
    Rick Harrell | Forum Activity | Replied: Wed, Feb 10 2010 11:55 AM

    Has anyone noticed any speed increase when upgrading to Windows 7 from Vista?

    In the Beta (How do I get this?) can you limit the info that is shown in the info pane? The first info I get when hovering over an OT word is not at all helpful. If I could limit the info pane to my favorite resources as i could with the mouse hover in Logos 3 it would make the program much more usable.

    Posts 248
    Daniel Arnott | Forum Activity | Replied: Wed, Feb 10 2010 12:18 PM

    I am reluctant to use Logos as much as I would like to because it's such a chore! My laptop sounds like it is going to take off due to the CPU going crazy. I like the software but I must admit to being a bit disgruntled that such an expensive piece of software runs so badly on a fairly high spec machine. Something dosnt seem quite fair to me. I know one day we will all be running mega machines and I'm sure it will all work fine then, but that isn't the point. If you spend $1000 on a piece of software you expect it to work well. The forum is constantly full of people with issue after issue. Shame. But I hold out that one day it will be more useable.

    Smile

    Posts 248
    Daniel Arnott | Forum Activity | Replied: Wed, Feb 10 2010 12:23 PM

    Matt if your specs are this good, how good a machine are we gonna need for Logos!!

    Specs:

  • Windows 7 x64
  • Quad Xeon 2.83 GHz x2
  • 16GB RAM
  • Nvidia 285 GTX 1GB VRAM
  • Logos 4.0a Platinum, SR-3, indexed
    Posts 115
    Joel J. | Forum Activity | Replied: Tue, Feb 16 2010 6:16 PM

     

    I could see how a video card could make a difference.  I upgraded to 4gb, but don't see much of a difference in terms of speed.  Unfortunately, although Logos 4 is primarily about the text, the graphics seem to slow it down.

    Worse yet, most of us who use laptops are often stuck with integrated graphics cards.  Does anyone know of any tricks with virtual memory or anything to help with that?  After doing some research, my guess is that there really isn't really a way around a slow graphics card.

    - Joel

    Posts 248
    Daniel Arnott | Forum Activity | Replied: Wed, Feb 17 2010 11:25 AM

    have you set Logos to turn off the Windows visuals when it runs?

    Posts 164
    Rick Harrell | Forum Activity | Replied: Wed, Feb 17 2010 3:32 PM

    Daniel Arnott:
    have you set Logos to turn off the Windows visuals when it runs?

     

    What??? What are they and how do I do that? Program menu? Visual Cues? Visual bookmarks?

    Posts 1658
    SteveF | Forum Activity | Replied: Wed, Feb 17 2010 4:25 PM

    frederick harrell:
    What are they and how do I do that?

    I have turned off the Aero features.

    Regards, SteveF

    Posts 164
    Rick Harrell | Forum Activity | Replied: Tue, Mar 2 2010 1:18 PM

    I added a new video card to my desktop this weekend: I went with ATI Radeon HD 4600 - 1 Gig ddr2 memory.

    The good news - It made Photoshop CS4 Extended MUCH quicker.

    The somewhat good news - the info pane update on hovering over a word in a bible passage is now averaging about 3 seconds (with an occasional 10+ second hiccup) better than a 50% improvement.

    Still havn't had a successful update of LLDLS 3 resources after way  too many attempts.

    Page 1 of 2 (22 items) 1 2 Next > | RSS