Replace with Passage MAC - Still waiting

Page 1 of 6 (120 items) 1 2 3 4 5 Next > ... Last »
This post has 119 Replies | 5 Followers

Posts 87
Rino M. Dattilo | Forum Activity | Posted: Mon, Sep 21 2015 5:38 PM

Still waiting for the repair / fix for replace with passage on Mac. 

This feature will allow you to highlight a passage in Pages / activate the service menu replace with passage will paste in that passage. When you activate it now, it will bring Logos to the forefront then get stuck for about 60-90 seconds. :( 

It has been a long time and every Logos beta we get I hope and pray for a fix. 

OS X.11 GM / Logos 6.6.0.0056

Posts 262
LogosEmployee
Steve Workman | Forum Activity | Replied: Mon, Sep 28 2015 3:33 PM

We are unable to consistently reproduce this on 10.11.  We are looking into this.  We are unable to get this behavior on 10.10 or on 10.9.

Posts 4686
Forum MVP
Mike Binks | Forum Activity | Replied: Tue, Sep 29 2015 1:44 AM

Using the blank page in the templates folder.

Each of these references stalls Pages for a couple of minutes.

 The space on the second monitor is switched back to the Logos home page.

They do not replace the reference with the verse.

OS X 10.11.1 Logos 

Logos Bible Software 6.6  6.6.0.0056 (Update channel: beta)

Posts 262
LogosEmployee
Steve Workman | Forum Activity | Replied: Tue, Sep 29 2015 9:32 AM

We can reproduce this on 10.11.1, which is the beta for the future release of OS X 10.11.  Do you still have the difficulties on 10.11?

Posts 4686
Forum MVP
Mike Binks | Forum Activity | Replied: Tue, Sep 29 2015 2:46 PM

Steve Workman:

We can reproduce this on 10.11.1, which is the beta for the future release of OS X 10.11.  Do you still have the difficulties on 10.11?

Dunno - haven't got that anymore - Sorry

Posts 59
FrMoses | Forum Activity | Replied: Wed, Sep 30 2015 10:09 PM

Hello,

I can confirm that with OS X 10.11 "El Capitan", Logos 6.6 SR-1, and Microsoft Word 15.13.1, the functionality is still broken. All of these programs are public, stable versions, not betas.

When I try "Replace with Passage" on a simple reference like John 3:5, Word hangs for a few moments, the window focus moves to Logos, but then nothing happens. 

I reported this months ago during the 10.11 Public Beta, but was told the issue was due to the beta software. I imagine the public release should help you sort things out now.

God help you to fix this quickly, as it is perhaps the most used feature for many.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 59
FrMoses | Forum Activity | Replied: Wed, Sep 30 2015 10:19 PM

I just updated Microsoft Word to 15.14 and can confirm it's still not working.

When browsing through my console at the time of trying to execute the service, I came across this:

9/30/15 10:17:46.916 PM SandboxedServiceRunner[507]: assertion failed: 15A284: libxpc.dylib + 23599 [3E09C275-A33B-357A-B0AB-A2DDF88EC9D5]: 0x13

9/30/15 10:17:46.916 PM SandboxedServiceRunner[507]: Application com.faithlife.LogosLauncher never opened its Services port before the timeout.

Hopefully, that can point the developers in the right direction of fixing this once and for all. 

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 262
LogosEmployee
Steve Workman | Forum Activity | Replied: Thu, Oct 1 2015 4:06 PM

FrMoses,

Based on this information, you should see multiple options for Replace with Passage in you keyboard shortcuts section.  This error is stemming from a previous version of Logos installed on the computer I believe it was 6.3.  

There are two ways to resolve this. Please go to Preferences>Keyboard>Shortcuts, select Services on the left hand side and scroll down until you locate Copy Bible Verses and Replace with Passage. You should see multiple options for these services.  The first option would be finding the correct one with a little trial and error, this will not resolve the issue merely bypass it.  

The other option is available only after you have determined the correct Copy Bible Verses and Replace with Passage.  If you Right click on the incorrect listings, you can select Show in Finder and then send the incorrect options to the trash.  That should get you all cleared up.

Posts 59
FrMoses | Forum Activity | Replied: Thu, Oct 1 2015 10:52 PM

Thank you, Steve. I was so happy to receive your response and a method of trying to fix this, but sadly, it did not work, because I don't have multiple versions of "Replace with Passage" and "Copy Bible Verses." There is only one of each underneath Preferences > Keyboard > Services > Text.

I even tried to go into ~/Library/Services to see if there were errant copies, but I found none.

Most recently, I tried "Replace with Passage" in TextEdit, but the same thing happened: TextEdit froze for a few seconds, the window focus moved to Logos, and I was left with the same reference as before.

Do you have any other recommendations?

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 70
Hugh DeLong | Forum Activity | Replied: Fri, Oct 2 2015 6:18 AM

I upgraded to El Capitan, and now the copy verses is no longer working. It now also stalls for a few seconds, and then changes focus to Logos. It doesn't change the reference in the copy verses panel however. So frustrating when things break. 

Posts 59
FrMoses | Forum Activity | Replied: Fri, Oct 2 2015 8:51 PM

Yes, agreed, this is quite frustrating.

Is anyone from Logos reading this? I've read several threads about this issue on Macs, but no official fix yet. Should we be calling Customer Support instead of seeking help from the developers here? I ask only because these problems seem to go back months and I'm worried no one from Logos is reading this.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 22077
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Oct 3 2015 1:26 AM

FrMoses:
Is anyone from Logos reading this?

Steve Workman - who replied a few posts above - is a Faithlife employee

Posts 70
Hugh DeLong | Forum Activity | Replied: Sat, Oct 3 2015 12:47 PM

OK - found a 'solution'. Downloaded Accordance and installed their services package. Not quite as flexible in formatting... but it is working. How I long for the days of InstaVerse and Windows ... well, at least THIS aspect of it. A simple program that just worked. It would even popup the scripture if you hovered the mouse over the reference. With all of Logos' work and all of the 'it just works' advertising for Apple, why can't we get something STABLE to accomplish this?

Posts 59
FrMoses | Forum Activity | Replied: Sat, Oct 3 2015 1:12 PM

Thanks, Graham. It's nice to know he is a Faithlife employee. He suggested a fix two days ago, but it didn't work. Now what? I'm happy to assist with the testing until we get this problem sorted out once and for all. I have two different Macs (Mac Pro and Macbook Pro) that have the same issue, so it's clearly not something isolated.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Sat, Oct 3 2015 9:10 PM

I am so thankful to see people responding to this. For me it has been months. I have Accordance and still use it - and that is what I have been using to paste passages into my documents. BUT - this should have been resolved a year ago! I have posted on it - I have called tech support many times - all to now avail. I am not speaking out of anger (maybe a bit of frustration) but fact. I have asked to talk to an engineer or someone with some knowledge of the applications workings. Bottom line - no Faithlife response. In fact, I have always been told its an Apple issue. Well, Accordance got it to work. Online Bible - a very inexpensive application has it working. I too have offered many suggestions and my help, but I have again heard nothing.

Even the "fix" listed above really doesn't make sense. I have never had duplicates in my system services menu. I was hopeful I missed something and followed the directions and nothing. 

Here is my heart - if it this is a feature of the app - fix it - this is not an inexpensive application. I don't need a new feature I need the features that we have to work. I just have had a year of this "back self" feeling. I think it is very sad BUT I am thankful that others are speaking up!Smile Maybe someone will listen and finally fix this. We need many more to speak up and write. 

Posts 59
FrMoses | Forum Activity | Replied: Sun, Oct 4 2015 1:13 AM

SUCCESS!

I believe I found a workaround. Following Steve's post above, it seemed to me there might be an issue with the actual Logos services not being able to communicate with the app, so I decided to create a new user on my Mac and run Logos as if from a new installation. It took a while to install and download 8 GB of content, but once everything was up, I opened TextEdit and tried the shortcut. Nothing happened, so I went into System Preferences > Keyboard > Services and enabled the two Logos services (which were unchecked and disabled by default.) After that, the services worked!

Following this train of thought, I resolved to completely remove the Logos application from my main system, so I used a free app called App Cleaner to search for and trash all Logos files. I followed up with a Spotlight search that included system files and invisible files to make sure everything was deleted. 

Now, this is an important step: Restart your system after removing Logos. This has the effect of removing the Logos services from your Mac. Open Sys Prefs > Keyboard > Services and make sure the Logos services are no longer listed.

Afterwards, reinstall Logos as usual and make sure to restart your Mac once the installation and indexing have completed. Be patient and let everything finish. Then, go to Sys Prefs > Keyboard > Services and ensure the Logos services are enabled. After that, they should work normally.

Although this workaround was successful for me, I hope Faithlife addresses this issue, if only to save themselves bandwidth. Pushing out a 160 MB update is far better than every user downloading gigabytes of data just to reinstall the app.

I hope this help others with the same issue.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 59
FrMoses | Forum Activity | Replied: Sun, Oct 4 2015 1:18 AM

One more thing to the Faithlife engineers:

If this workaround does indeed work for others, why not push out a small app that will simply remove and reinstall the Logos services on a person's machine? Or even add the option to do so as a Logos tool?

If the issue is that the service cannot communicate with the app, perhaps reinstalling the service and reconnecting the app is all we need to do, and this can be done by a simple app or tool within Logos, just in case it gets broken in the future.

Blessings

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Sun, Oct 4 2015 5:45 AM

ReMoses,

I am glad you got this working. Mine though is a clean install on a new machine. I will give this a try. 

Thanks

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Sun, Oct 4 2015 12:22 PM

FrMoses,

I follow your directions to the "T" - I still get the hang after a clean install of Logos.

I am thankful it is working for you. Again I pray that someone from Faithlife will be gracious enough to:

1. Respond to us 

2. Tell us that they are Faithlife

3. And give us a some of their quality time to resolve this issue!

Posts 27800
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Oct 4 2015 12:43 PM

Rino M. Dattilo:
Tell us that they are Faithlife

For clarification: The green Faithlife icon under Steve Workman's avatar tells you that he is with Faithlife. 

OSX & iOS | Logs |  Install

Page 1 of 6 (120 items) 1 2 3 4 5 Next > ... Last » | RSS