Replace with Passage MAC - Still waiting

Page 2 of 6 (120 items) < Previous 1 2 3 4 5 Next > ... Last »
This post has 119 Replies | 5 Followers

Posts 59
FrMoses | Forum Activity | Replied: Sun, Oct 4 2015 4:06 PM

Dear Rino,

You're right, the fix does not work.

Last night, I got it to work on my Mac Pro, but this morning, I tried the same steps on my Retina MacBook Pro (Mid-2012) and found that the services were still broken. Perplexed, I tried to understand why it worked on the Mac Pro, but not the MacBook, and then I realized that, last night, I removed the Logos app and installed the Verbum app on the Mac Pro. (As far as I can tell, they work the same, and one is a rebranded version of the other.) This morning, however, I removed the Logos app and reinstalled the Logos app on my MacBook, and it did not work.

Now, I am wondering whether the problem is with the Logos app itself, so I am about to try uninstalling Logos and installing Verbum on my MacBook right now. I'll report the results in an hour or so, God willing.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 59
FrMoses | Forum Activity | Replied: Sun, Oct 4 2015 4:26 PM

SUCCESS!

As a follow-up to my last two posts (please read them to understand), I can confirm that uninstalling Logos and installing Verbum in its place fixed the broken "Replace with Passage" and "Copy Bible Verses" services on both my Macs. I also found a way to avoid having to redownload and reindex all of the resources. Here are the steps:

1. Download AppCleaner, which is free, and use it to find all of Logos' files.

2. Trash everything except the Logos4 directory in ~/Library/Application Support.

3. Empty the Trash and restart.

4. Download Verbum at the links on the bottom of this page: https://www.logos.com/product/47040/verbum-6-core-engine

5. Copy Verbum from the disk image to your Applications folder

6. Start Verbum and let it begin the process of downloading resources, but close it right after it begins.

7. In your ~/Library/Application Support folder, you should see both a Logos4 and a Verbum folder. Confirm they both have the same structure, with subfolders like Data, User, etc.

8. If the structure is the same, trash the Verbum folder and rename Logos4 to Verbum.

9. Launch Verbum and confirm everything is okay.

10. Restart your Mac (to refresh the Services).

11. After it reboots, open System Preferences > Keyboard > Services and make sure the two services are enabled.

12. Launch Verbum and TextEdit.

13. Try the services, and hopefully, they will work. I can confirm this worked on both a Mac Pro and a MacBook Pro.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Sun, Oct 4 2015 10:21 PM

FrMoses,

I am a long time Accordance user and someone in my congregation purchased me the Diamond collection so there is a lot of money here for us. My question to you is, What is Verbum????

Rino

Posts 59
FrMoses | Forum Activity | Replied: Sun, Oct 4 2015 10:23 PM

Verbum is simply a rebranded version of Logos that is targeted for Catholic users. I don't see any difference in functionality between the two.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 13374
Forum MVP
Mark Barnes | Forum Activity | Replied: Mon, Oct 5 2015 1:19 AM

FrMoses:
I don't see any difference in functionality between the two.

There are some minor differences in functionality, or at least in configuration. I can't remember all of them off the top of my head, but there are certainly some guide sections that are different in Verbum, and default prioritisation is different. Owning certain datasets/resources that are only available in Verbum base packages (e.g. Catholic Topic Index, and Saints) also unlocks certain extra features in both Logos and Verbum.

Posts 70
Hugh DeLong | Forum Activity | Replied: Mon, Oct 5 2015 5:26 AM

So.. I am to completely uninstall Logos 6, download and install Verbum, spend the time and bandwidth downloading my whole library..  on two computers... just to fix this that was working until a week ago? This not being the first time this has 'broken', I have no illusion that it won't break again even with Verbum. Yes, I am frustrated with this! No, I am not going to spend the time to do this 'fix'. No, I am not excited about Logos service and response to the issue.   Hugh

Posts 2216
Forum MVP
John Fidel | Forum Activity | Replied: Mon, Oct 5 2015 5:50 AM

Hugh I agree that they should provide a fix that does not require you to reinstall everything. I can duplicate your problem on my mbp. I don't use the feature much but that is beside the point. 

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Mon, Oct 5 2015 6:16 AM

John Fidel:
Hugh I agree that they should provide a fix that does not require you to reinstall everything. I can duplicate your problem on my mbp. I don't use the feature much but that is beside the point. 

The underlying issue here is we are relying on the OS to support the provided services. We do not install anything, our application advertises that it provides the two services. Unfortunately, at least in the one set of logs statements provided by FrMoses, it looks like the OS has cached information from Logos 6.4.

FrMoses:
SandboxedServiceRunner[507]: Application com.faithlife.LogosLauncher never opened its Services port before the timeout.

You should not need to uninstall everything in order for the services to work correctly. In the Services listing in System Preferences, you can right-click on the service name and select "Show in Finder" to see the application that the OS thinks is providing the service. If the application is reveals in Finder is not the one in /Applications, you should be able to safely delete that version of Logos and empty your trash. You may need to log out and log back in or restart your Mac for the OS to update the available services.

If the services are still not working correctly for you, you can try deleting all copies of Logos from your system, emptying the trash and restarting your Mac. When you log in again, the services should no longer appear in System Preferences. At this point you should be able to copy the latest version back into the /Applications folder, launch it and the services should appear in System Preferences again.

Mac Developer
Faithlife

Posts 70
Hugh DeLong | Forum Activity | Replied: Mon, Oct 5 2015 6:30 AM

Martin - appreciate your input. The finder shows only the one logos 6 application, so pointing to a wrong app install is not the problem. For clarification, you are suggesting deleting the Logos App ... and that leaves all the resources (library) in place...  Then reinstalling Logos App. You used the phrase "copy the latest ersion back into the /Applications folder' (I probably am still using 'install' terminology'). Is that a correct understanding...   copy the dmg back into the applications folder? It will then need to find the resources and reindex everything?  I yet remain much more familiar with Windows tech...  learning the ins / outs of Mac.  thanks

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Mon, Oct 5 2015 7:44 AM

Martin,

I have a clean install with a new computer. Not a time machine backup. It doe not work for me and I even followed FrMoses fix. Like I stated before, this is a constant issue. My suggestion is that Logos look at another way to make it work. There has to be something in your service code. If Online Bible is working though all this through services, then something in the Logos code must need tweaked. I know there will be OS issues, but we have heard that reasoning for over a year. 

Martin, you are actually the first Mac Dev that I have noticed that has responded to one of my many posts. Like I had said before, and you can search out my posts, from here on the forum and where you post suggestions for the logos application. I have put a year plus into this for help. I have called my Logos rep Brian Kent, he tried to get to a dev - no luck. All of this on my part to help. And maybe because the forums are silent to only a few of us who use this feature, I believe it is vital and an amazing part of the work flow. When one can just place a scripture reference in a document, and with a key stroke invoke a system service that will paste the passage in the document - it is a time saver. I just don't think many people know of it or more would.

Like Hugh, who I thank for responding, we are wanting to help, not just complain. All the work that FrMoses posted, I believe should have been reports that Faithlife should have given us, IMHO. And when a customer had been asking for over a year - supporting your product - don't you believe that is the case also???

Again, Hugh I thank you for this. And I don't want this frustration to be public, thus my many calls to Faithlife. You can reach me privately - if you like. But I ask that you please forward this frustration and that Faithlife would respond with some fixes. The ones that you are suggesting are not fixes. 

Posts 59
FrMoses | Forum Activity | Replied: Mon, Oct 5 2015 8:40 AM

Martin Potter:

You should not need to uninstall everything in order for the services to work correctly. In the Services listing in System Preferences, you can right-click on the service name and select "Show in Finder" to see the application that the OS thinks is providing the service. If the application is reveals in Finder is not the one in /Applications, you should be able to safely delete that version of Logos and empty your trash. You may need to log out and log back in or restart your Mac for the OS to update the available services.

If the services are still not working correctly for you, you can try deleting all copies of Logos from your system, emptying the trash and restarting your Mac. When you log in again, the services should no longer appear in System Preferences. At this point you should be able to copy the latest version back into the /Applications folder, launch it and the services should appear in System Preferences again.

Thanks, Martin, for addressing this issue, but I think there is more to the problem than that. Even when I deleted every single file — including system and invisible files — from my Mac and reinstalled a fresh copy of the latest version of Logos, the services did not work. They only worked when I switched over to Verbum.

As for the poster who mentioned having to redownload and reindex all of one's resources, I think you can safely keep the Logos4 directory under ~/Library/Application Support, since that seems to house your credentials, resources, layouts, etc.

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 59
FrMoses | Forum Activity | Replied: Mon, Oct 5 2015 8:43 AM

Hugh DeLong:
For clarification, you are suggesting deleting the Logos App ... and that leaves all the resources (library) in place...  Then reinstalling Logos App. You used the phrase "copy the latest ersion back into the /Applications folder' (I probably am still using 'install' terminology'). Is that a correct understanding...   copy the dmg back into the applications folder?

I think you have the right idea, but on Macs, you don't copy the DMG anywhere. You double-click the DMG and copy the Logos app from it into your /Applications folder.

More info on DMGs generally: http://guides.macrumors.com/Disk_image

I use Verbum with an 8-Core Mac Pro (2013) and a MacBook Pro (2017)

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Mon, Oct 5 2015 8:47 AM

Martin, you are actually the first Mac Dev that I have noticed that has responded to one of my many posts. Like I had said before, and you can search out my posts, from here on the forum and where you post suggestions for the logos application. I have put a year plus into this for help. I have called my Logos rep Brian Kent, he tried to get to a dev - no luck. All of this on my part to help. And maybe because the forums are silent to only a few of us who use this feature, I believe it is vital and an amazing part of the work flow. When one can just place a scripture reference in a document, and with a key stroke invoke a system service that will paste the passage in the document - it is a time saver. I just don't think many people know of it or more would.

Like Hugh, who I thank for responding, we are wanting to help, not just complain. All the work that FrMoses posted, I believe should have been reports that Faithlife should have given us, IMHO. And when a customer had been asking for over a year - supporting your product - don't you believe that is the case also???

Again, Hugh I thank you for this. And I don't want this frustration to be public, thus my many calls to Faithlife. You can reach me privately - if you like. But I ask that you please forward this frustration and that Faithlife would respond with some fixes. The ones that you are suggesting are not fixes. 

Posts 70
Hugh DeLong | Forum Activity | Replied: Mon, Oct 5 2015 9:21 AM

Martin - I did the process... removed Logos app to trash, emptied trash, rebooted.

The copy verses and the replace with text services were now gone. 

did the 'install' of Logos app to applications folder...  opened and signed in.

Opened Word, and checked services...  NO 'copy verses' or 'replace text' services  :-(  Something wasn't automatic!   What now to get the services to be available again?  (thanks for your patience)    Hugh

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Mon, Oct 5 2015 9:22 AM

Hugh DeLong:
The finder shows only the one logos 6 application, so pointing to a wrong app install is not the problem.

Did you select "Show in Finder" after right-clicking the the item(s) in the Services preference pane? This will show you the application the OS thinks is providing the service.

Hugh DeLong:
For clarification, you are suggesting deleting the Logos App ... and that leaves all the resources (library) in place...  Then reinstalling Logos App. You used the phrase "copy the latest ersion back into the /Applications folder' (I probably am still using 'install' terminology'). Is that a correct understanding...   copy the dmg back into the applications folder? It will then need to find the resources and reindex everything?

Yes, I mean just delete the application and copy (install) the new version from the DMG to your /Applications folder. This will not cause you to have to download or index again as it is only replacing the application and not the data.

Mac Developer
Faithlife

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Mon, Oct 5 2015 9:25 AM

Hugh DeLong:

did the 'install' of Logos app to applications folder...  opened and signed in.

Opened Word, and checked services...  NO 'copy verses' or 'replace text' services  :-(  Something wasn't automatic!   What now to get the services to be available again?  (thanks for your patience)    Hugh

Newer version of the OS require you to enable the service(s) before they appear in the menu. If you look in the services preference pane, you should see the two services again, but they will not be enabled/checked. Clicking on the checkbox should enable them so they appear in the services menu again.

Mac Developer
Faithlife

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Mon, Oct 5 2015 9:29 AM

FrMoses:
Thanks, Martin, for addressing this issue, but I think there is more to the problem than that. Even when I deleted every single file — including system and invisible files — from my Mac and reinstalled a fresh copy of the latest version of Logos, the services did not work. They only worked when I switched over to Verbum.

Can you post updated logs including your Console logs? The last logs you posted indicated that they were trying to use an old (6.4) version of the application.

FrMoses:
As for the poster who mentioned having to redownload and reindex all of one's resources, I think you can safely keep the Logos4 directory under ~/Library/Application Support, since that seems to house your credentials, resources, layouts, etc.

You are correct, there should be no need to delete your ~/Library/Application Support/Logos4 folder.

Mac Developer
Faithlife

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Mon, Oct 5 2015 9:36 AM

Rino M. Dattilo:
Martin, you are actually the first Mac Dev that I have noticed that has responded to one of my many posts. Like I had said before, and you can search out my posts, from here on the forum and where you post suggestions for the logos application. I have put a year plus into this for help. I have called my Logos rep Brian Kent, he tried to get to a dev - no luck. All of this on my part to help. And maybe because the forums are silent to only a few of us who use this feature, I believe it is vital and an amazing part of the work flow. When one can just place a scripture reference in a document, and with a key stroke invoke a system service that will paste the passage in the document - it is a time saver. I just don't think many people know of it or more would.

Ultimately, we are relying on the OS to provide this service since it is one of the few/only ways to provide inter-application communication. The down side is we don't have the ability to log any information until we receive a request from the OS so there is no way for us to really tell what the OS is doing. Console logs might be helpful in determining what the OS is doing, but they don't contain a whole lot of information.

Mac Developer
Faithlife

Posts 87
Rino M. Dattilo | Forum Activity | Replied: Mon, Oct 5 2015 9:50 AM

Martin,

Here is my ultimate question: How can you help me to get this to work, for myself and others? I have followed your directions so I am humbly asking for help. I will do what you ask of me. 

I understand that you have to work with the OS. All I am saying is "if" others are having it work with the OS, how can we? 

And a BIG Thank you for responding.

Posts 70
Hugh DeLong | Forum Activity | Replied: Mon, Oct 5 2015 10:05 AM

Martin - I shutdown everything, rebooted yet again, and now they do appear in the services list... however, they do not work  :-(  They  point to the Logos 6 app when I do the 'show in finder' routine. But, in Word, when I press the shortcut, it just gives me a long pause. It appears as if the focus shifts to the Logos app... and then after a minute or so, it returns to Word without having copied anything :-(  

I can walk through all of this yet one more time... but am more frustrated having deleted and reinstalled Logos only to have it continue to not work.    Hugh

Page 2 of 6 (120 items) < Previous 1 2 3 4 5 Next > ... Last » | RSS