Logos slowing down and KJV interlinear not working

Page 2 of 2 (29 items) < Previous 1 2
This post has 28 Replies | 0 Followers

Posts 1150
Anthony H | Forum Activity | Replied: Wed, Mar 3 2010 9:34 AM

Dave Hooton:

Anthony

Look in your resources folder C:\Users\su\AppData\Local\Logos4\Data\n2nhhvsy.jbs\ResourceManager\Resources\ (enable hidden files and folders) and look for *.lbxlls files. Is KJV1900 one of those (as opposed to being KJV1900.logos4)?

Do you have L3 installed and does it contain KJV1900.lbxlls?

What other *.lbxlls files do you have?

Can you upload your last logos4Indexer.log file from March 2nd?

Is KJV1900 one of those (as opposed to being KJV1900.logos4)?

Yes, kjv1900 is  "KJV1900.lbxlls". But the other two are "KJV1900NT.lbsrvi" and "KJV1900OT.lbsrvi".

Do you have L3 installed and does it contain KJV1900.lbxlls?

Yes, L3 is installed and contains KJV1900.lbxlls.

What other *.lbxlls files do you have?

I have 49 files with the old L3 extension.

 

Can you upload your last logos4Indexer.log file from March 2nd?

 

yes,  48131.Logos4.log

 

And here's one from today.

5706.Logos4.log

 

Its always a "System.NullReferenceException" and NOT the "System.ArgumentOutOfRangeException" which is associated with the indexer creating a "bad index file".

I don't know much...I know these errors are like "idiot lights" on a dashboard, but they don't have the same cause. (another reason why I knew it wasn't a "bad index file".)

Whisper

Posts 1150
Anthony H | Forum Activity | Replied: Wed, Mar 3 2010 12:44 PM

Dave Hooton:

Anthony

Look in your resources folder C:\Users\su\AppData\Local\Logos4\Data\n2nhhvsy.jbs\ResourceManager\Resources\ (enable hidden files and folders) and look for *.lbxlls files. Is KJV1900 one of those (as opposed to being KJV1900.logos4)?

Do you have L3 installed and does it contain KJV1900.lbxlls?

What other *.lbxlls files do you have?

Can you upload your last logos4Indexer.log file from March 2nd?

Dave,

I did an experiment based on your questions. I deleted all of the .lbxlls files and did a "update resources". It download the files, some were in the old .lbxlls format other in the .logos4.

I took note to see what the kjv1900 was in the download folder (before Logos moved them to the resource folder). It was kjv1900.logos4. On restart it moved them over, then during the 1,2,3 stages after relaunch it removed kjv1900.logos4 and replaced it with kjv1900.lbxlls.

Is this some sync lic. issue since I have L3 and L4 installed?

Is there a way of circumventing L4 in its replacement of the .logo4 files?

Anthony

7080.01_Logos4_removeOldExt.log

2768.02_Logos4_DL_check.log

3386.03_Logos4_setScan.log

7802.04_Logos4_AfterScan.log

7506.05_Logos4_dl.log

5758.06_Logos4_SetScanM.log

7002.07_Logos4_L4_replaced.log

Posts 1150
Anthony H | Forum Activity | Replied: Wed, Mar 3 2010 1:54 PM

BUG! BUG! Combo BUG! BUG!

I think what I have discovered here is a combo bug. Part one ( http://wiki.logos.com/Bug$3a_Error_accessing_KJV1900 ) : is that kjv1900.lbxlls (interlinear) crashes L4. This kjv1900.lbxlls is pulled into L4 (by L4) from L3(?) and replaces the (kjv1900.logos4) L4 version for some reason (newer file- see bug link below). Part two: So the link below is the bug reported that .logos4 files are being replaced with .lbxlls files.

http://wiki.logos.com/Bug$3a_L4_not_updating_$2a.lbxlls_files_with_$2a.logos4_files

I have watched L4 download the kjv1900.logos4 file three times. Once L4 is restarted to add the new resource(s) it moves the new resources over from the download folder to the resource folder and then replaces the kjv1900.logos4 with kjv1900.lbxlls. (This also happens to approximately 28 other .logos4 files that are downloaded and replaced with equivalent .lbxlls, though I can't confirm that they cause any problems)

I have trashed my index files and I am attempt to pause L4 indexing long enought to place back the kjv1900.logos4 file and start indexing again to see if the file will hold (this is post "prepairing 1,2,3 stages".)

Posts 1150
Anthony H | Forum Activity | Replied: Wed, Mar 3 2010 4:12 PM

Anthony Hamlin:

BUG! BUG! Combo BUG! BUG!

I think what I have discovered here is a combo bug. Part one ( http://wiki.logos.com/Bug$3a_Error_accessing_KJV1900 ) : is that kjv1900.lbxlls (interlinear) crashes L4. This kjv1900.lbxlls is pulled into L4 (by L4) from L3(?) and replaces the (kjv1900.logos4) L4 version for some reason (newer file- see bug link below). Part two: So the link below is the bug reported that .logos4 files are being replaced with .lbxlls files.

http://wiki.logos.com/Bug$3a_L4_not_updating_$2a.lbxlls_files_with_$2a.logos4_files

I have watched L4 download the kjv1900.logos4 file three times. Once L4 is restarted to add the new resource(s) it moves the new resources over from the download folder to the resource folder and then replaces the kjv1900.logos4 with kjv1900.lbxlls. (This also happens to approximately 28 other .logos4 files that are downloaded and replaced with equivalent .lbxlls, though I can't confirm that they cause any problems)

I have trashed my index files and I am attempt to pause L4 indexing long enought to place back the kjv1900.logos4 file and start indexing again to see if the file will hold (this is post "prepairing 1,2,3 stages".)

IT WORKED!

Though I had to do a 2nd update after the launch to force it to see the kjv1900.logos4 file (...among the others). It downloaded them as if it was going to go thru the process again but upon restarted it did a short index and when I opened the kjv1900 interlinear it worked... no crash.

Now the question is, if I have L4 scan my L3 will it revert back to kjv1900.lbxlls?

 

4405.Logos4Indexer.log

2845.Logos4_preManualFix.log

7142.Logos4.log

 

 

Performance site note: Thanks to Steve Sando I have a bit better performance by enabling Write Caching and Advanced Performance on the HDD and using a High-Speed USB disk under ReadyBoost (Vista) to enhance the systems responsiveness.

http://community.logos.com/forums/t/12829.aspx

 

Praise the Lord. Victory in Christ Jesus ... Victory in patience through Christ. Big Smile

Posts 24920
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Mar 3 2010 4:31 PM

Anthony Hamlin:
Now the question is, if I have L4 scan my L3 will it revert back to kjv1900.lbxlls?

Anthony

YES!  I'll answer in more detail a little later, but you have grasped the reason for my questions!

Dave
===

Windows & Android

Posts 24920
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Mar 3 2010 7:00 PM

Anthony Hamlin:
Is this some sync lic. issue since I have L3 and L4 installed?

Just an Indexer issue. It is copying newer versions from L3 at C:\Program Files\Libronix DLS\Resources\ . This especially applies to KJV1900 as the L3 file is version 2010-01-15T00:50:16Z  and the L4 file is version 2009-11-24T00:48:21Z (NB. internal Logos version, not external Date Modified). You can get the version from Resource Information in L4, under the heading of Support Info.

Anthony Hamlin:
Is there a way of circumventing L4 in its replacement of the .logo4 files?

You can hide the L3 resource files during a download  eg. move the 28 or so affected .lbxlls files to another folder and add that to the Resource Paths in L3. When downloading rename that folder until indexing is complete!

 

Dave
===

Windows & Android

Posts 24920
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Mar 3 2010 7:12 PM

Anthony Hamlin:
Part one ( http://wiki.logos.com/Bug$3a_Error_accessing_KJV1900 ) : is that kjv1900.lbxlls (interlinear) crashes L4. This kjv1900.lbxlls is pulled into L4 (by L4) from L3(?) and replaces the (kjv1900.logos4) L4 version for some reason (newer file- see bug link below).

L4 gets it from the L3 Resource Paths which causes this error. But it is indeed Invalid (thanks for updating it).

Anthony Hamlin:

Part two: So the link below is the bug reported that .logos4 files are being replaced with .lbxlls files.

http://wiki.logos.com/Bug$3a_L4_not_updating_$2a.lbxlls_files_with_$2a.logos4_files

Until this bug is fixed we need the workaround I indicated.

 

Dave
===

Windows & Android

Posts 24920
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Mar 3 2010 7:18 PM

Anthony Hamlin:
Praise the Lord. Victory in Christ Jesus ... Victory in patience through Christ. Big Smile

IndeedYes!

Dave
===

Windows & Android

Posts 1150
Anthony H | Forum Activity | Replied: Fri, Mar 5 2010 7:29 AM

Anthony Hamlin:

Performance site note: Thanks to Steve Sando I have a bit better performance by enabling Write Caching and Advanced Performance on the HDD and using a High-Speed USB disk under ReadyBoost (Vista) to enhance the systems responsiveness.

http://community.logos.com/forums/t/12829.aspx

UPDATE 03052010

!!!! ATTENTION !!!!!  USE SOME CARE with this performance tweak (when enabling Write Caching and Advanced Performance on the HDD ). 

My System became unbootable (except in safe mode) when a few win/sys dll's (boot-start files) failed to load properly after Logos4 froze and I had to force a restart. !!!!!  
               -I may have damaged the HDD.

I spent my afternoon and evening yesterday re-installing Vista/my Apps and Logos... again.  That makes it 3 times since I upgraded to L4.  Crying

Page 2 of 2 (29 items) < Previous 1 2 | RSS