Linux version of Logos Bible Software

Page 41 of 50 (984 items) « First ... < Previous 39 40 41 42 43 Next > ... Last »
This post has 983 Replies | 53 Followers

Posts 59
Rik Shaw | Forum Activity | Replied: Thu, Dec 19 2019 7:42 AM

@Adam, you are correct. wasta-logos-setup has as a dependency wasta-wine (that installs to /opt/wasta-wine/) and thus does NOT need any separate wine version installed. The reason wasta-wine was split out as a separate package was so that any update to wasta-logos-setup would not require re-downloading the patched wine version, saving users on limited internet connections (like me!) many MB.

@Ollie wine 4.0.x will NOT work. You need to either have wasta-logos-setup with wasta-wine or you need to follow the manual steps to add the winehq repository to get wine-staging 4.21(+). Both ways are listed in the Logos 8 in Ubuntu Guide.

Posts 95
Dirk Kellner | Forum Activity | Replied: Thu, Dec 19 2019 11:29 PM

The appearance of the fonts within logos@linux isn't as sharp as in windows. The fonts are like "washed out". I tried to fix it by changing the hinting and rendering, but logos seems not to be influenced by this changes. Any idea? I use logos in kubuntu and mint. The problem persists in both systems.

Posts 24
Olrik van der Woerd | Forum Activity | Replied: Sun, Dec 22 2019 4:56 AM

Rik Shaw:
@Ollie wine 4.0.x will NOT work. You need to either have wasta-logos-setup with wasta-wine or you need to follow the manual steps to add the winehq repository to get wine-staging 4.21(+). Both ways are listed in the Logos 8 in Ubuntu Guide.

Thanks for the reply, but the problem occurred with the wasta-patch included:

Ollie Pindakaas:
Yesterday I tried it with Wine 4.0.3 and the Wasta patch on a Mint 19.2-Cinnamon (4.2.4), when Logos crashed.

So for me now, it seems that the easiest way is just to update the kernel, but for that I need a newier videocard:

About the kernel, I have 4.15.0-72-generic, which seems the best chose with an old Nvidia Video card (Geforce GTX 570 ti)
.But a newer videocard is already on the planning (including an extra monitor for just Logos).

In other words, I shall put me own MINT-project on hold.

Posts 849
Bill Anderson | Forum Activity | Replied: Sun, Dec 22 2019 7:11 AM

Ollie Pindakaas:
Yesterday I tried it with Wine 4.0.3 and the Wasta patch on a Mint 19.2-Cinnamon (4.2.4), when Logos crashed.

Ollie,

From your reply, it's unclear whether you completely removed Wine 4.0.3 before running the steps in the Logos Google doc. I say that because when I first started trying to get this to work, I didn't get that point. Try completely uninstalling Wine 4.0.3 and then try the steps in the Google doc again to see if that works. 

Posts 673
Frank Sauer | Forum Activity | Replied: Sun, Dec 22 2019 1:50 PM

I was just reading the Release Notes for the latest Wine 5.0 - it appears that the crash of Logos when set to Win 8/10 has been fixed.

Could this allow the errors with audio and printing to be fixed by running under Win 10?

Posts 1041
John Goodman | Forum Activity | Replied: Sun, Dec 22 2019 5:40 PM

It might help but there is at least one other show stopper bug for running in win10 mode. See: https://appdb.winehq.org/objectManager.php?sClass=version&iId=38306

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 1041
John Goodman | Forum Activity | Replied: Sun, Dec 22 2019 5:42 PM

Folks can I request that you log on to winehq appdb and go to the page for Logos 8 https://appdb.winehq.org/objectManager.php?sClass=version&iId=38306

Once there please vote for it! This may help encourage developer attention etc.

Many thanks

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 1041
John Goodman | Forum Activity | Replied: Mon, Dec 23 2019 2:02 PM

We currently have 16 votes in the wine app db. Over 19 would put us in the top 100. The top 10 apps have hundreds of votes. More votes may attract more dev attention and there are outstanding bugs that need dev support. Especially with 64bit indexing. If we could drum up votes based on the interest in this thread I think it would really help. Many thanks.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 673
Frank Sauer | Forum Activity | Replied: Mon, Dec 23 2019 4:06 PM

Long story - short... I screwed up the Logos install while messing around with updating Wine to 5.0 RC2. I have all my data backed up - so that is a bonus.

However wasta-logos-setup will not work - coming up with errors about the directory not being found.

I also did full autoremove of wine and wasta, rebooted then tried from the start.

I'm running Kubuntu 19.10

Also, following the step by step, wine 5.0 rc2 installs and I have gotten through the setup but the then get the never ending cycle of crashing at download

Any thoughts?

Posts 1041
John Goodman | Forum Activity | Replied: Mon, Dec 23 2019 4:23 PM

Yeah - wine 5.0 rc 2 does not have  ReOpenFile() implementation. You need to install the wine-staging version of wine if you want it to work. Most of what the wasta package does apart from install a patched version of wine is configuring your wine prefix. Installing .net etc. If that was all done already you can use wine-staging without wasta. But if you went with wine-stable or wine-devel you won't find it can work.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 673
Frank Sauer | Forum Activity | Replied: Mon, Dec 23 2019 4:48 PM

Thanks John! That seems to be working. It has crashed once while it was scanning for the copied resources/updating resources action. Otherwise it seems to be setting up fine. This was following Nick's instructions into the wine-logos8 directory

Posts 42
Daniel Ribeiro da Silva | Forum Activity | Replied: Tue, Dec 24 2019 6:38 AM

Hi!

If there is more people like me that have a linux pure 64bits (no-multilib) and want to run Logos 32bits, there is a good solution. I don't like to install all multilib things just for the sake of one application (wine), then I created a AppImage that have almost all 32bits libs that wine need to work on all 64bits linux distributions. I also created instructions for the Logos Bible instalation: https://github.com/ferion11/Wine_Appimage/wiki/Logos-Bible
* The last "8.10.0.0032" version fixed the "outofmemoryexception" for me. And it's working now :)

Posts 84
aaylnx | Forum Activity | Replied: Tue, Dec 24 2019 6:47 AM

Tried voting (twice actually).  It was at 19 when I voted, and remained 19 afterward even after refreshing the browser.  Maybe it takes a while for the votes to be counted?  Hope we can keep getting votes.  For others interested in voting, you must register an account first.

John Goodman:

Folks can I request that you log on to winehq appdb and go to the page for Logos 8 https://appdb.winehq.org/objectManager.php?sClass=version&iId=38306

Once there please vote for it! This may help encourage developer attention etc.

Many thanks

Posts 84
aaylnx | Forum Activity | Replied: Tue, Dec 24 2019 7:00 AM

Very interesting!  Is it possible to wrap everything up into one AppImage file?  Possibly with the installation step already done so that the user would just have to login to their account and then their files would be downloaded and indexed?

Daniel Ribeiro da Silva:

Hi!

If there is more people like me that have a linux pure 64bits (no-multilib) and want to run Logos 32bits, there is a good solution. I don't like to install all multilib things just for the sake of one application (wine), then I created a AppImage that have almost all 32bits libs that wine need to work on all 64bits linux distributions. I also created instructions for the Logos Bible instalation: https://github.com/ferion11/Wine_Appimage/wiki/Logos-Bible
* The last "8.10.0.0032" version fixed the "outofmemoryexception" for me. And it's working now :)

Posts 42
Daniel Ribeiro da Silva | Forum Activity | Replied: Tue, Dec 24 2019 7:04 AM

It's possible, but the version of Logos Bible would be fixed (not good for updates), because the inside of AppImage is read-only.

Posts 673
Frank Sauer | Forum Activity | Replied: Tue, Dec 24 2019 7:06 AM

When you vote, make sure you tick one of the three check boxes when it asks what application you want to replace. I tried just submitting first, because I had no applications chosen, but the vote did not take. I clicked vote again and clicked one of the check boxes and then submit - the vote immediately registered.

I did it twice more, for a total of three new votes - we are at 22 now

aaylnx:

Tried voting (twice actually).  It was at 19 when I voted, and remained 19 afterward even after refreshing the browser.  Maybe it takes a while for the votes to be counted?  Hope we can keep getting votes.  For others interested in voting, you must register an account first.

John Goodman:

Folks can I request that you log on to winehq appdb and go to the page for Logos 8 https://appdb.winehq.org/objectManager.php?sClass=version&iId=38306

Once there please vote for it! This may help encourage developer attention etc.

Many thanks

Posts 84
aaylnx | Forum Activity | Replied: Tue, Dec 24 2019 7:10 AM

Got it.  That worked.  Thanks!  We're up to 23 now.

Frank Sauer:

When you vote, make sure you tick one of the three check boxes when it asks what application you want to replace. I tried just submitting first, because I had no applications chosen, but the vote did not take. I clicked vote again and clicked one of the check boxes and then submit - the vote immediately registered.

I did it twice more, for a total of three new votes - we are at 22 now

aaylnx:

Tried voting (twice actually).  It was at 19 when I voted, and remained 19 afterward even after refreshing the browser.  Maybe it takes a while for the votes to be counted?  Hope we can keep getting votes.  For others interested in voting, you must register an account first.

John Goodman:

Folks can I request that you log on to winehq appdb and go to the page for Logos 8 https://appdb.winehq.org/objectManager.php?sClass=version&iId=38306

Once there please vote for it! This may help encourage developer attention etc.

Many thanks

Posts 84
aaylnx | Forum Activity | Replied: Tue, Dec 24 2019 7:17 AM

Interesting.  Yes, I had forgotten about AppImages being read-only.  It totally makes sense that they are read-only from a security perspective, but not helpful to us in this instance.  I don't know how the app would be able to download all of the files from the website either.

BTW, I have been able to successfully spin up this whole mess on a LXC/LXD container on Ubuntu.  The LXC container should work on other distros too, I just like the way LXD provides a very nice rest api for working with LXC containers.  I keep meaning to provide instructions on how to do this on the Google Doc.  I will get around to it one day.  Also, I see no reason why the base container could not be shared.  By base container I mean everything installed but not yet logged into.  You'd have to have your own Logos account to log into it and run it.  This kind of approach would not be as newbie friendly as having an Appimage (or Snap or Flatpak), but it does solve the portability issue as well as the library issue.

Daniel Ribeiro da Silva:

It's possible, but the version of Logos Bible would be fixed (not good for updates), because the inside of AppImage is read-only.

Posts 42
Daniel Ribeiro da Silva | Forum Activity | Replied: Tue, Dec 24 2019 9:57 AM

I don't have tested. But for the video play, you will need on linux all gstreamer codecs installed (if using wine 32bits, you need all the 32bits versions), include gst-libav and the ffmpeg (or libav). On wine side (with winetricks) you will need win7 profile, directmusic, directplay, directshow, xvid and ogg. It's a lot of work just to see videos. I'm happy with only the audio/video don't working for now. You can see on wine database site that almost all audio/video apps players also don't work, it isn't just a Logos Bible Software problem. When the wine devs solve for the others apps, then the Logos Bible will start to play videos too.

Posts 24
Olrik van der Woerd | Forum Activity | Replied: Tue, Dec 24 2019 12:43 PM

@Bill: Whoops, I dint read the ubuntu guide fully. It seems that I have to update wine 4.0.3 manually to Wine 4.21...

According to @John, Wine-staging (now Wine 5.0 rc2) should work too:

John Goodman:
Yeah - wine 5.0 rc 2 does not have  ReOpenFile() implementation. You need to install the wine-staging version of wine if you want it to work. Most of what the wasta package does apart from install a patched version of wine is configuring your wine prefix. Installing .net etc. If that was all done already you can use wine-staging without wasta. But if you went with wine-stable or wine-devel you won't find it can work.

Page 41 of 50 (984 items) « First ... < Previous 39 40 41 42 43 Next > ... Last » | RSS