Linux version of Logos Bible Software

Page 45 of 47 (931 items) « First ... < Previous 43 44 45 46 47 Next >
This post has 930 Replies | 48 Followers

Posts 121
Paul Unger | Forum Activity | Replied: Wed, Feb 12 2020 10:36 AM

Yeah, weird... I've got a random thing where there's a space between an apostrophe and what follows, like this in Firefox > Preferences:

[picture showing up when I edit, but not in preview or when I post...]

Posts 24
Olrik van der Woerd | Forum Activity | Replied: Mon, Feb 24 2020 7:45 AM

Meanwhile I tried to install Logos 8;11.0.0017 from source, but the program doesnt start. Maybe because there is no Logos in Home/.wine-logos/drive-c/users/[Name]/Application Data... I tried to install Logos from source...

Something else, I have some free time to spare, and I would like to learn how to use LibreOffice.Is it a good idea that I clean up the ubuntu guide? Just for reading purposes, not for improving the code skills...

Posts 32
Daniel Ribeiro da Silva | Forum Activity | Replied: Tue, Feb 25 2020 11:36 AM

Ollie Pindakaas:

Meanwhile I tried to install Logos 8;11.0.0017 from source, but the program doesnt start. Maybe because there is no Logos in Home/.wine-logos/drive-c/users/[Name]/Application Data... I tried to install Logos from source...

Something else, I have some free time to spare, and I would like to learn how to use LibreOffice.Is it a good idea that I clean up the ubuntu guide? Just for reading purposes, not for improving the code skills...

* You can try to find the Logos executable using the command:

find $HOME/.wine-logos -name Logos.exe |  grep "Logos\/Logos.exe"

* About the LibreOffice is a good option. But for edit Microsoft files (like docx) the most compatible on linux, at this time, is the WPS Office. And the WPS Office have the same usage that the MS Office. Documentation update is always welcome :)

Posts 671
Frank Sauer | Forum Activity | Replied: Sat, Feb 29 2020 6:09 PM

Have to say this project continues to get better! Thank you to all who are a part of it!

Currently running:

Kubuntu 20.04

Logos 8.11 64 Bit

Wine 5.3 64 Bit Prefix

Windows 10 default

The videos now appear to play fine

No indexer issues

Some black box graphical glitches

Read Aloud still crashes

Printing is still not working

So overall - it is a daily driver. The glitches and Printing being fixed would make it perfect for me personally, as I do not use Read Aloud on my laptop.

Great job All!

Posts 32
Daniel Ribeiro da Silva | Forum Activity | Replied: Sun, Mar 1 2020 6:20 AM

Frank Sauer,

Is good to know about this. The bug reports, together with the votes, is getting results fast (so, let's keep doing it).

Workaround: On the "Print/Export" window, you can just use the "Export" option. Sometimes, I just Export to "Rich Text Format (Word, etc.)", but I like more the option "Copy to clipboard" then paste on the WPS Office (so, I can edit before print).

Posts 121
Paul Unger | Forum Activity | Replied: Wed, Mar 11 2020 11:09 AM

I have had persistent indexing issues. @Frank Sauer addressed this on page 42 (https://community.logos.com/forums/p/121/1081696.aspx#1081696), but his solution didn't work for me... What DID work was to copy the index information from a second, up-to-date, everything downloaded Win7 machine I have:

C:\Users\username\AppData\Local\Logos\Data\randomID\BibleIndex, ~/LibraryIndex, and ~PersonalBookIndex

and paste it into my corresponding wine-logos folders:

/home/user/.wine-logos/drive_c/users/username/Local Settings/Application Data/Logos/Data/randomID/BibleIndex, ~/LibraryIndex, and ~PersonalBookIndex.

Indexing now works! Takeaway: keep a copy of known-good indexing folders--you never know when you'll need them!

Posts 671
Frank Sauer | Forum Activity | Replied: Wed, Mar 11 2020 3:58 PM

Paul,

You may be experiencing an issue with the Library Catalog. I have noticed a few instances of this happening lately after any resource upgrades and/or new resources added to the library. It appears that this has caused the indexer to run continually without ever completing and was not fixed with the workaround that I posted earlier in your reference.

When this was happening to me, I noticed that the Library Catalog folder appeared to be corrupted based upon number of files. I deleted everything in the Library Catalog folder and opened Logos, allowed it to refresh the Library Catalog, it then indexed with no issues. Library Catalof looks to be an 8 file folder when complete.

Paul Unger:

I have had persistent indexing issues. @Frank Sauer addressed this on page 42 (https://community.logos.com/forums/p/121/1081696.aspx#1081696), but his solution didn't work for me... What DID work was to copy the index information from a second, up-to-date, everything downloaded Win7 machine I have:

C:\Users\username\AppData\Local\Logos\Data\randomID\BibleIndex, ~/LibraryIndex, and ~PersonalBookIndex

and paste it into my corresponding wine-logos folders:

/home/user/.wine-logos/drive_c/users/username/Local Settings/Application Data/Logos/Data/randomID/BibleIndex, ~/LibraryIndex, and ~PersonalBookIndex.

Indexing now works! Takeaway: keep a copy of known-good indexing folders--you never know when you'll need them!

Posts 121
Paul Unger | Forum Activity | Replied: Wed, Mar 11 2020 4:27 PM

Hi Frank,

My issue was with indexing right after installing--it never got past 7%... I tried clearing out the three ___Index folders, as you suggested in your post, but that didn't work for me. When I copied known-good index files into them, indexing proceeded as expected.

I downloaded a new book this morning (after applying my fix), and indexing went ahead without a hitch. Here's hoping it continues!

Posts 1
Paul Natekin | Forum Activity | Replied: Fri, Mar 20 2020 7:11 PM

https://askzorin.com/c/logos-bible-software-linux/13  Discussion form for Linux

Posts 121
Paul Unger | Forum Activity | Replied: Mon, Mar 23 2020 10:42 AM

"Software Updater" (Ubuntu) just informed me of a 182 MB update for "Logos Installer". Running "Update now" from within Logos tells me there is no update available... Do I need the update that "Software Installer" is offering? Is there any way to find out what the "Logos Installer" package contains?

Posts 32
Daniel Ribeiro da Silva | Forum Activity | Replied: Mon, Mar 23 2020 11:55 AM

Paul Unger:

"Software Updater" (Ubuntu) just informed me of a 182 MB update for "Logos Installer". Running "Update now" from within Logos tells me there is no update available... Do I need the update that "Software Installer" is offering? Is there any way to find out what the "Logos Installer" package contains?

"Logos Installer" package, like the name, only have what's is necessary to install and run Logos.

After Logos is installed, it can update itself. Then you don't need one new "Logos Installer", but is still a good ideai to update it (in case you need it again)

Posts 121
Paul Unger | Forum Activity | Replied: Mon, Mar 23 2020 12:00 PM

Thanks! I kind of thought that was the case, but just wanted to confirm it.

Posts 209
James Hudson | Forum Activity | Replied: Tue, Mar 24 2020 4:20 AM

Hi Daniel,

Amazing scripts - thank you!

Have used the Installer to install!

Can you let me know the purpose of the Indexer.sh script?

Thanks.

James

Posts 52
Rik Shaw | Forum Activity | Replied: Tue, Mar 24 2020 4:52 AM

@Paul or others, to be clear, the update your system is notifying you of is the update to wasta-logos-installer, which I bumped to version 8.9.0.0030. So as Daniel or others have pointed out, this would only be used if you re-run wasta-logos-setup, which you can re-run if you want to "repair" your install.

On this note, here is the best link for tracking what the newest version of logos is:

https://wiki.logos.com/Logos_8_Release_Notes

I note there that version 8.12 was just released, as a "RC". Is the most recent "stable" release 8.10.0.0034? If so, my Logos is NOT updating to 8.10, but is still at 8.9.x.

Do others see this from their Logos Wine installs (that it won't update to newer feature releases?)

Maybe there is a setting to indicate you want to move to newer feature releases not just bug releases for the current feature version?

Posts 32
Daniel Ribeiro da Silva | Forum Activity | Replied: Tue, Mar 24 2020 5:42 AM

James Hudson:

Hi Daniel,

Amazing scripts - thank you!

Have used the Installer to install!

Can you let me know the purpose of the Indexer.sh script?

Thanks.

James

Well, the LogosIndexing.sh is just for when the Logos fail to do the indexing by itself (can happens).

Glad to help :)

Posts 121
Paul Unger | Forum Activity | Replied: Tue, Mar 24 2020 8:41 AM

Rik Shaw:
I note there that version 8.12 was just released, as a "RC". Is the most recent "stable" release 8.10.0.0034? If so, my Logos is NOT updating to 8.10, but is still at 8.9.x.

Do others see this from their Logos Wine installs (that it won't update to newer feature releases?)

I'm at version 8.8 SR-1 | 8.8.0.0046 (32 bit) (from Help > About). I've run "Update now" a number of times over the past couple of weeks and I'm always told there are no updates available. Based on the "Release Notes" page, I'm stuck back in October 2019... Just looking at the details of the releases, though, it doesn't look like I'm missing much--a few bug fixes that haven't affected me. The 8.11 and 8.12 releases have a heap of new features and fixes, but it looks like those are just for "gold" package owners.

Posts 52
Rik Shaw | Forum Activity | Replied: Tue, Mar 24 2020 11:49 PM

Paul,

You can run wasta-logos-setup to apply the 8.9.x that is now part of wasta-logos-installer. It will do an inplace update to your Logos so that it won't lose your resources, indexes, etc. (but please make a backup copy of your ~/.wine-logos FIRST just to make sure you will be safe).

Later I am happy to move the wasta-logos-installer to 8.10.x or up to 8.12.x if we feel that the "RC" ("gold") version is safe. Maybe to be safe we should wait for it to be out of "RC" ("release candidate") status.

Rik

Posts 121
Paul Unger | Forum Activity | Replied: Wed, Mar 25 2020 7:42 AM

Rik Shaw:
You can run wasta-logos-setup to apply the 8.9.x that is now part of wasta-logos-installer. It will do an inplace update to your Logos so that it won't lose your resources, indexes, etc. (but please make a backup copy of your ~/.wine-logos FIRST just to make sure you will be safe).
Is this the only way to update to a more recent version number? Download the installer package when prompted by Software Updater, and then run wasta-logos-setup in the Terminal? Logos won't do so on its own? Nor Software Updater, for that matter (i.e., I have to run wasta-logos-setup after Software Updater has downloaded the installer package)? If so, that's fine--I'm just curious. And a bit unsure of the steps...

Posts 52
Rik Shaw | Forum Activity | Replied: Wed, Mar 25 2020 10:57 AM

Paul Unger:

Is this the only way to update to a more recent version number? Download the installer package when prompted by Software Updater, and then run wasta-logos-setup in the Terminal? Logos won't do so on its own? Nor Software Updater, for that matter (i.e., I have to run wasta-logos-setup after Software Updater has downloaded the installer package)? If so, that's fine--I'm just curious. And a bit unsure of the steps...

Paul, It is *definitely* a workaround, I am not sure of other users if they are able to have Logos update itself or not, but this is again a *workaround* until we can sort out *why* Logos isn't updating itself (it used to, so I am not sure if it is a settings change or??)

Do other users have any comments on if Logos is updating for them or not?

Posts 32
Daniel Ribeiro da Silva | Forum Activity | Replied: Thu, Mar 26 2020 11:04 AM

Rik Shaw:

Do other users have any comments on if Logos is updating for them or not?

Yes, it is.

But i'm not using wasta-wine, so maybe it isn't relevant.

Page 45 of 47 (931 items) « First ... < Previous 43 44 45 46 47 Next > | RSS