Logos.com crashing firefox for mac

Page 1 of 1 (10 items)
This post has 9 Replies | 1 Follower

Posts 946
John Goodman | Forum Activity | Posted: Sat, Jun 4 2016 8:45 AM

I'm finding that the logos.com website is crashing firefox 46.0.1 for mac. Mac OS 10.11.5.

It has happened 2 times to me when clicking to place an order. This has not happened on any other site at all.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 192
LogosEmployee
Mike Estes - Logos | Forum Activity | Replied: Mon, Jun 6 2016 8:46 AM

Hi John,

Sorry for the issues with our site and for taking so long to get back to you.  Could you give me a bit more details in the steps to reproduce the issue?  I'm not able to reproduce it on that version of FireFox, though I'm not on the latest version of OS X.

Do you have any plugins installed in Firefox?  Does it repro with those turned off if you do?  Does this only occur on the cart page or does it happen elsewhere on the site as well?  Does Firefox or your Mac OS give you any details on the crash?

Thank you,
Mike

Posts 946
John Goodman | Forum Activity | Replied: Mon, Jun 6 2016 2:15 PM

I can't reproduce it without buying something! It happens when I place an order. As I click to complete the order. I only know the order has gone through because the book downloads. I have a suspicion it is to do with hardware acceleration of the graphics on the site. I have onboard graphics and a discreet card. Logos.com is one of a very few sites that causes the discreet card to get fired up!

Cheers,John

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Mon, Jun 6 2016 3:39 PM

Hi John,

I am unable to reproduce this issue. Are you using OS X 10.11.5 natively or in a virtual machine? What exact video hardware setup do you have (the more details the better)?

Posts 946
John Goodman | Forum Activity | Replied: Wed, Jun 8 2016 3:45 AM

As per my sig: MacBookPro8,2, i7, 16GB, 500GB SSD, Latest OS X

Thanks

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Wed, Jun 8 2016 2:02 PM

Does the crash occur with other browsers or just Firefox? To test this you can "purchase" a free resource. 

Posts 946
John Goodman | Forum Activity | Replied: Thu, Jun 9 2016 12:37 PM

It's just firefox. I bought a book in safari just now... not a freebie.

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 192
LogosEmployee
Mike Estes - Logos | Forum Activity | Replied: Mon, Jun 13 2016 8:07 AM

Hi John,

Just to follow up it appears that a page that an order summary page I left open last week when trying to repro this problem had crashed at some point since then.  I sent in the bug report to Apple/FF or whoever those go to.

The one out of the ordinary thing I see is that the bug report had some data on it indicating that perhaps I (and perhaps you) are on some sort of new feature roll out that they might be testing.  FWIW there's nothing on this order summary page that I can see that would cause a browser to crash.  That seems more a FireFox issue than something that we can update/change.  I sent along the report with a follow up email, though I doubt they'll send me anything, so hopefully they'll fix this.

I'll see if I can get some sort of crash dump to see if I can find out more.  Though getting it to repro on demand seems like it might be difficult to do.

Thanks,
Mike

Posts 192
LogosEmployee
Mike Estes - Logos | Forum Activity | Replied: Mon, Jun 13 2016 8:15 AM

Another update, it appears my crash was linked to a case that is now showing as resolved fixed.  I can't see the case it was duplicated to though so I cannot say for sure when or how it was fixed.  Nor how to possibly duplicate it.

Let us know if it repros again and also be sure to send in the crash report if it does.

Thanks again,
Mike

EDIT Or maybe not fixed...  the date it was resolved was in March.  So be sure to report it as I was on the latest version of FF as you were.

EDIT AGAIN:  I was wrong, there is a newer version as of a week ago.  I updated to FF 47.0.

Page 1 of 1 (10 items) | RSS