Bug - Full Screen misbehaviour

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Posted: Fri, Sep 2 2016 1:27 AM

1586.LogosLogs.Mike.20160902-083516.zip

I have tried to post a video of my screen which oscillates between desktops but get an error.

In order to reproduce ( I don't know which features are germane)

Logos 7 in full screen mode.

Two screen set up.

Go to bible (in my case via a shortcut) and open directly in a floating window. This is important.

Make the floating window full screen.

Go the book icon and select 'Show reading view.'

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Fri, Sep 2 2016 12:56 PM

Here is a link to a video that I took of the above behaviour.

Posts 2630
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Sep 6 2016 12:11 PM

Mike Binks:

1586.LogosLogs.Mike.20160902-083516.zip

I have tried to post a video of my screen which oscillates between desktops but get an error.

In order to reproduce ( I don't know which features are germane)

Logos 7 in full screen mode.

Two screen set up.

Go to bible (in my case via a shortcut) and open directly in a floating window. This is important.

Make the floating window full screen.

Go the book icon and select 'Show reading view.'

I've tried reproducing these steps:

  1. Create a two desktop setting.
  2. Open Logos 7 into Full Screen.
  3. Open a Bible from a shortcut into a floating window.
  4. Turn on Reading View.
  5. Use CTRL + arrow key to switch between the two desktops. 
  6. I even tried switching very fast.

I was unable to reproduce this behavior. Am I missing any steps?

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Tue, Sep 6 2016 12:28 PM

Hi Philana

Thanks for looking into into this.

I just reproduced the effect while checking my processes.

I did not get to step five in your list before the workspace switching started - the only way to stop it was to quit Logos.

It did not require a 'Force Quit'.

This may be something that only happens with MacOS Sierra it does not happen on my single screen laptop running El Capitan.

If Apple release a user version of the OS on Wednesday it might be worth having a close look at my logs.

Posts 2630
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Sep 6 2016 12:35 PM

Mike Binks:

Hi Philana

Thanks for looking into into this.

I just reproduced the effect while checking my processes.

I did not get to step five in your list before the workspace switching started - the only way to stop it was to quit Logos.

It did not require a 'Force Quit'.

This may be something that only happens with MacOS Sierra it does not happen on my single screen laptop running El Capitan.

If Apple release a user version of the OS on Wednesday it might be worth having a close look at my logs.

Once they release a public version I can take a look. Let me know in this thread if it still persists, especially once a public version is out. 

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Fri, Sep 9 2016 1:31 AM

Philana R. Crouch:
Once they release a public version I can take a look. Let me know in this thread if it still persists, especially once a public version is out. 

I can confirm that this behaviour persists in the GM release of MacOS 10.12 (16A320) and 7.1 Beta 3.

Posts 2630
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Fri, Sep 9 2016 4:37 PM

Mike Binks:

I can confirm that this behaviour persists in the GM release of MacOS 10.12 (16A320) and 7.1 Beta 3.

Mike, even with MacOS 10.12 I'm unable to reproduce this. Do you have any other apps running, or any other hardware that might be in use? 

Does this happen as you open the Bible in Reading View?

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Sat, Sep 10 2016 1:20 AM

Hi Philana

I have attached the dates log sample and archived logs.

I don't have anything other than standard apps running on the machine.

I have just tried this with the RCL from a shortcut and various books from the library.

If the main panel is not in Full Screen (click on the green button to hide the task bar) then reading view opens normally.

If the main panel in full screen then selecting reading view starts the oscillations.

3678.LogosLogs.Mike.20160910-090642.zip

6708.LogosLogs.Mike.20160910-090651.zip

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Mon, Sep 12 2016 12:59 PM

Unfortunately the behaviour continues into Beta 4.

Posts 2630
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Sep 12 2016 3:12 PM

Mike Binks:

Unfortunately the behaviour continues into Beta 4.

Mike, I wrote up a case for the team to look at. As a work around for now, since Reading View puts the resource into full screen, use full screen for the resource. 

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Tue, Sep 13 2016 8:30 AM

Thanks Philana

Actually I don't use reading view normally - but the incidence has the hall marks of a bug that will jump up and bite the developers one day when they don't expect it.

I would imagine that squashing the bug now might well pay dividends down the line.

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Tue, Sep 13 2016 2:21 PM

Mike,

I have tried to reproduce this issue on macOS Sierra and have been unable to replicate the behavior you are seeing.

Mike Binks:
Two screen set up.

Based on your logs, I am assuming this means two separate monitors not set up to mirror. What are your settings for Spaces under System Preferences->Mission Control?

Mac Developer
Faithlife

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Wed, Sep 14 2016 12:23 AM

Hi Martin

Martin Potter:
Based on your logs, I am assuming this means two separate monitors not set up to mirror. What are your settings for Spaces under System Preferences->Mission Control?

Yes I have the iMac main screen with 7 workspaces and off to the left have an Acer Monitor with 5 workspaces.

These are the settings that I have...

I changed my settings to match yours but the oscillation still occurs as soon as I select reading view on a resource set to full screen on the same monitor as the main Logos window i.e. if I move the resource to the second monitor and go to full screen and then reading view it does not happen.

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Thu, Sep 15 2016 9:46 AM

Mike,

After looking into this more, I am guessing that you have Logos assigned to a specific desktop. This feature has some issues with our application and a lot of other applications, including some of Apple's. This is not new to Sierra, however the behavior is different from 10.11, where if you switch away from reading view, you will never be able to get back to that window until you exit reading view.

Mac Developer
Faithlife

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Fri, Sep 16 2016 12:20 AM

Well you seem to have found the source of the issue Martin. Well done and thank you!

Indeed with this setting reading view does misbehave...

whereas with this setting the reading view moves to a new space of its own and behaves normally.

Perhaps, in the interim, Faithlife should grey-out the none operating options?

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Fri, Sep 16 2016 7:43 AM

Mike Binks:
Perhaps, in the interim, Faithlife should grey-out the none operating options?

Unfortunately, that is not a possibility as Apple does not have any way for developers to interact with Spaces.

Mac Developer
Faithlife

Posts 4642
Forum MVP
Mike Binks | Forum Activity | Replied: Fri, Sep 16 2016 11:20 AM

Nothing is impossible - just ask Bob to buy a controlling stake in Apple.

Page 1 of 1 (17 items) | RSS