Faithlife Tv. not working

Page 1 of 1 (4 items)
This post has 3 Replies | 0 Followers

Posts 23
C Stutzman | Forum Activity | Posted: Wed, Sep 28 2016 6:22 PM

 I am trying the free month. I have to say it is not going well. The 1st day was the best but still it was acting funky. I tried several different things. It usually hangs up after a few seconds. I tried watching a movie and it stopped about 2/3 of the way through. The bar that shows the time running and total time showed that the movie was over. Had to restart 3 times clicking farther and farther down the timeline. I did get to see all of it though. The last two day it will run between 5 and 10 seconds and just stops. I am not getting anything to show that more content is downloading. After waiting about 5 min. I tried other things but everything is the same. Thought ok try internet explorer 11. That is really weird as it will show things related to my account, but nothing else. My M. Ed classes show, as well as say the videos to show how to use Logos. All other content is just not there. No movies, specials,  discussions ect.. I am using the following software:

Edition : Windows 10 home
Version : 1607
OS Build : 14393.187

Microsoft Edge 38.14393.0.0
Microsoft EdgeHTML 14.14393

Internet explorer 11
Version : 11.187.14393.0
Update Versions : 11.0.35 (KB3185319)

Any suggestions would be very nice. Thnx.

Posts 977
LogosEmployee
Dave Dunkin (Faithlife) | Forum Activity | Replied: Thu, Sep 29 2016 9:35 AM

I'm sorry this isn't working well for you. Am I understanding correctly that there are two problems: 1) videos don't play all the way through, and 2) not all videos are showing up when you browse faithlifetv.com? Do other video services work without problem (e.g. YouTube or Netflix)?

Posts 23
C Stutzman | Forum Activity | Replied: Thu, Sep 29 2016 11:24 AM

Dave Dunkin (Faithlife):

I'm sorry this isn't working well for you. Am I understanding correctly that there are two problems: 1) videos don't play all the way through, and 2) not all videos are showing up when you browse faithlifetv.com? Do other video services work without problem (e.g. YouTube or Netflix)?

1. That 1st movie I tried it would play partial. But after that 1st day that I signed up runs anywhere from 5 to 10 seconds is all. This is using Microsoft Edge. So really weird the performance drop so much in one day. But it did.

2. Using internet explorer 11 the videos do not show up at all on the main page. It shows only the videos associated with my Logos Acct. So  almost all the different classifications of videos on the main page are blank. There is no videos showing.

Microsoft edges shows all the videos, but they only play for a few seconds then hang up.

I do have Netflix and it runs great in Microsoft Edge. YouTube runs great. And running the videos under the news feeds run great.

Posts 126
James Milne Smith | Forum Activity | Replied: Fri, Sep 30 2016 9:53 PM

I am using Faithlife TV on my television screen through my Apple TV device, in Malaysia. I have a pretty good internet signal. Sometimes clips work OK, but mostly they will play part the way through then return suddenly to the beginning. As I want to show these clips to my small groups, and we always have a limited time, I find this very frustrating.

Page 1 of 1 (4 items) | RSS