Will 3.0 work on L4?

Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 35
Zach Fortenberry | Forum Activity | Posted: Fri, Mar 12 2010 9:12 AM

I purchased Luther's Work (55 vol) but it is 3.0.  Will this work with my L4?  According to the sales department it will but I am just trying to get a heads up before it arrives tomorrow.

Posts 270
Stein Dahl | Forum Activity | Replied: Fri, Mar 12 2010 11:34 AM

It should work in L4.

If you have L3 installed, you can install Luther's into L3 and then syncronize your licences.  That way, the next time you run L4 it will "see" that you have this new resource in L3, and will automatically update to include the Luther's you now have in L3.

If you don't have L3 installed any more, you may have to call Logos Customer Service and have them unlock it for you.  Then it will become available in your L4.

Hope this is the info you need.

Posts 35
Zach Fortenberry | Forum Activity | Replied: Fri, Mar 12 2010 11:48 AM

Thanks Stein!!  That was a huge help!

Posts 8967
RIP
Matthew C Jones | Forum Activity | Replied: Fri, Mar 12 2010 1:26 PM

I bought Luther's Works 3.0  when I was running Logos 3.0.

It appears in my Version 4.0 library after I upgraded.

If the files are any different I am sure Version 4 will update them.

Logos 7 Collectors Edition

Posts 35
Zach Fortenberry | Forum Activity | Replied: Fri, Mar 12 2010 7:47 PM

thanks Matthew!!  

Page 1 of 1 (5 items) | RSS