Copy/Paste Footnotes in Word for Mac Workaround

Page 1 of 2 (34 items) 1 2 Next >
This post has 33 Replies | 10 Followers

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Posted: Fri, Dec 9 2016 1:08 PM

While we do not currently have an automatic fix within the software, our devs have found a workaround using a macro.

First: Download the file linked below.

Link

Second: Follow the instructions illustrated in the image below to add a Macro to Word and enable a Keyboard Shortcut.

Posts 262
Jonathan Bradley | Forum Activity | Replied: Fri, Dec 9 2016 9:25 PM

It works perfectly. Took me about 2 minutes to get it all set up. Thank you!

Posts 203
Jackie Watts | Forum Activity | Replied: Sat, Dec 10 2016 10:17 AM

Any option for Mac  iWork Pages (version 6)? I've been asking, posting, and waiting on this for close to 3 years. Thank you.

Posts 8014
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Sat, Dec 10 2016 10:54 AM

Jackie Watts:

Any option for Mac  iWork Pages (version 6)? I've been asking, posting, and waiting on this for close to 3 years. Thank you.

Unfortunately, this is entirely up to Apple (see previous response here: https://community.logos.com/forums/p/76735/538469.aspx#538469) and we can't find a way to work around it. 

Posts 13
Nathan Chapman | Forum Activity | Replied: Sat, Dec 10 2016 2:16 PM

Thank you for attempting a work around, but.

This is not a work around. Instead it is a macro for an RTS paste option that I already referenced, see previous document posted.

This is a paste option that still now leaves unwanted citations and does not produce the requested footnote help that previously was in place.

It unfortunately took me several attempts and even a reinstallation of the Word program to realize all of this. Have a good rest of your weekend. Please do not consider this an actual fix or solution. Nothing has changed from my initial point of contact other than I wasted a portion of my Saturday afternoon trying to get a temporary fix to work that I already had access to.

Posts 262
Jonathan Bradley | Forum Activity | Replied: Sat, Dec 10 2016 6:06 PM

Nathan Chapman:

Thank you for attempting a work around, but.

This is not a work around. Instead it is a macro for an RTS paste option that I already referenced, see previous document posted.

This is a paste option that still now leaves unwanted citations and does not produce the requested footnote help that previously was in place.

It unfortunately took me several attempts and even a reinstallation of the Word program to realize all of this. Have a good rest of your weekend. Please do not consider this an actual fix or solution. Nothing has changed from my initial point of contact other than I wasted a portion of my Saturday afternoon trying to get a temporary fix to work that I already had access to.

They never said it was a fix, but a temporary workaround. It works fine for me. Can you post a screenshot of what it was doing for you? 

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Dec 12 2016 12:55 PM

Nathan Chapman:

This is a paste option that still now leaves unwanted citations and does not produce the requested footnote help that previously was in place.

Nathan,

I'm sorry you are experiencing difficulty. As stated this is a workaround and not a fix. A workaround is defined as "a method for overcoming a problem or limitation in a program or system." 

You mentioned that when you copy paste it leaves unwanted citations, can you verify in your Program Setting for Logos that Copy Footnotes is set to No. The image below shows the results with the setting set to Yes and No when copying to Word (with the Macro enabled and set with keyboard shortcut).

Posts 16
Wally | Forum Activity | Replied: Thu, Dec 29 2016 9:51 PM

I am very grateful to the Lord for your skills...this has helped me tremendously!!

SDG!

Posts 4
Debora Piper | Forum Activity | Replied: Mon, Jan 9 2017 7:21 AM

Awesome! Thanks for walking us through the process. Success on my first try! 

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Jan 9 2017 8:30 AM

Debora Piper:

Awesome! Thanks for walking us through the process. Success on my first try! 

Hi Debora,

Glad you found it helpful!

Posts 1
James Pavlic | Forum Activity | Replied: Mon, Jan 16 2017 11:26 AM

Fantastic. Thank you!

Posts 1564
John Kight | Forum Activity | Replied: Thu, Feb 9 2017 6:37 PM

Has this been fixed yet?

For book reviews and more visit sojotheo.com 

Posts 262
Jonathan Bradley | Forum Activity | Replied: Thu, Feb 9 2017 9:36 PM

John Kight:

Has this been fixed yet?

Unfortunately, no, it has not been fixed yet. The macro workaround is the only way that I know of to have it work. 

Posts 5
jamie | Forum Activity | Replied: Tue, Feb 14 2017 12:23 AM

This works great for me.

One question: Does anyone know how to make it paste (with the citation) but also match formatting. I have it working with the macro but it's not matching my formatting, which for research papers can be quite cumbersome to have to reformat every time I cite (which is a lot!). 

Posts 35
Chad Williams | Forum Activity | Replied: Thu, Apr 6 2017 1:23 PM

Is this still not fixed? Automatic footnotes used to be a big selling point for Logos. I find this missing feature very disappointing. 

Posts 1
Lisa Scheffler | Forum Activity | Replied: Thu, Apr 27 2017 3:13 PM

I followed the directions and it's not working for me. When I copy something from Logos and press cmd+L in Word (that's the shortcut key I assigned), nothing happens. If I paste using cmd+V it only pastes the text - for a while it was pasting the footnotes under the paragraph, but now there is nothing. 

I am running Logos 7 and Word 2015.32. Any suggestions? Am I doing something wrong?

Thanks

Posts 262
Jonathan Bradley | Forum Activity | Replied: Thu, Apr 27 2017 9:01 PM

Lisa Scheffler:

I followed the directions and it's not working for me. When I copy something from Logos and press cmd+L in Word (that's the shortcut key I assigned), nothing happens. If I paste using cmd+V it only pastes the text - for a while it was pasting the footnotes under the paragraph, but now there is nothing. 

I am running Logos 7 and Word 2015.32. Any suggestions? Am I doing something wrong?

Thanks

The only thing I can think of is the mistake I made several times in setting this up is the step that isn't numbered: close the first document and open a new one. 

Posts 262
Jonathan Bradley | Forum Activity | Replied: Thu, Apr 27 2017 9:02 PM

Chad Williams:

Is this still not fixed? Automatic footnotes used to be a big selling point for Logos. I find this missing feature very disappointing. 

Chad, from what I understand, the problem originated with something Microsoft Word did. 

Posts 233
Jeff Terrell | Forum Activity | Replied: Wed, Jun 28 2017 9:08 AM

THANK YOU for this workaround!  Got it to work with Word 15.35.  One question:

One additional remaining item is that the paste defaults to the Normal.dot font format.  Is there a way to get the macro to paste and match destination? 

Posts 1
Larry Dickerson II | Forum Activity | Replied: Fri, Nov 3 2017 9:50 AM

This works great! It fixes the problem. I used the same keyboard shortcut for paste (command + v) and it works just like before. My citations automatically paste into my document. Thank You!

Page 1 of 2 (34 items) 1 2 Next > | RSS