Anyone else having the library take forever to show books in the library browser?

Page 1 of 1 (15 items)
This post has 14 Replies | 3 Followers

Posts 18
Rick Dobrowolski | Forum Activity | Posted: Wed, Feb 8 2017 12:03 PM

I'm having this happen all the time when I am scrolling through the library. My macOS and Logos are updated to the latest versions, and I have the fastest processor and RAM possible on my 2015 Macbook Pro. Anyone else having this same problem?

Posts 3219
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Feb 8 2017 12:26 PM

Tile View is very slow to render when scrolling. Also on a 2015 MacBook Pro.

There have been some threads about that, but I don't know if a case has ever been opened.

As a workaround for now, detail view is very responsive.

Posts 4645
Forum MVP
Mike Binks | Forum Activity | Replied: Thu, Feb 9 2017 12:42 AM

PetahChristian:

Tile View is very slow to render when scrolling. Also on a 2015 MacBook Pro.

There have been some threads about that, but I don't know if a case has ever been opened.

As a workaround for now, detail view is very responsive.

I have seen these threads and wondered what was up as I have never had these problems either on my MacBook or iMac.

Your post now enlightens me :-)

I always use details view (guess I am only interested in getting the work done not enjoying the scenery) which, as you say, is always responsive.

I tried 'Cover View' and this too seemed to scroll well.

'Tile View', on the other hand did exhibit significant stalls.

For now the answer seems to be evident.

Posts 18
Rick Dobrowolski | Forum Activity | Replied: Sat, Feb 11 2017 3:35 PM

I admit my stupidity. I have been using Logos for over a decade and never realized that the Library had different views. I have always used the default. When I changed the view, it works fine. Odd that it needs a workaround, though. Most definitely it is some kind of bug.

Posts 948
Deacon Steve | Forum Activity | Replied: Sat, Feb 11 2017 5:36 PM

Rick Dobrowolski:

Most definitely it is some kind of bug.

Possibly.  Just checked a lower end Windows laptop with a traditional hard drive and integrated graphics and I do not see a delay in scrolling in tile view.  Hmmm.  I wonder what's going on there.

Posts 4645
Forum MVP
Mike Binks | Forum Activity | Replied: Sun, Feb 12 2017 1:57 AM

Rick Dobrowolski:

I admit my stupidity. I have been using Logos for over a decade and never realized that the Library had different views. I have always used the default. When I changed the view, it works fine. Odd that it needs a workaround, though. Most definitely it is some kind of bug.

Don't feel bad Rick - software was created to make us all know our place in creation!

I guess, given Steve's experiment that this will turn out to be one of those Mac things that have not been tweaked effectively on the transition from Windows. I can see how this may well have gone unnoticed/uncommented on. When I was doing my investigation my first thought was 'why would anyone want this view? It seems to be a half way house between Detail and Cover view. Not much good at showing the covers and not much good at providing detail. So I guess you may be almost unique in having suffered it and I predict that you will not return to it after trying the alternatives.

Posts 2
Dave Bisset | Forum Activity | Replied: Tue, Feb 14 2017 11:08 AM

I had the same problem and I had to upgrade my computer's RAM - it is running with 32G ram and I can not be happier

Posts 24931
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Feb 14 2017 2:03 PM

Dave Bisset:

I had the same problem and I had to upgrade my computer's RAM - it is running with 32G ram and I can not be happier

Did you only have 4 GB previously?

Dave
===

Windows & Android

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Feb 15 2017 9:27 AM

Rick Dobrowolski:

I'm having this happen all the time when I am scrolling through the library. My macOS and Logos are updated to the latest versions, and I have the fastest processor and RAM possible on my 2015 Macbook Pro. Anyone else having this same problem?

Rick,

Can you record and upload a screencast of what you are observing? I'm trying to replicate this on my MacBook Pro, and it doesn't seem to be taking very long to load. That's with a library of 48K resources. Jing is a free screenshot and screencast application.

https://www.techsmith.com/jing.html

Thanks!

Posts 18
Rick Dobrowolski | Forum Activity | Replied: Thu, Feb 16 2017 7:46 AM

Okay, here's the screencast. I'm not sure if it will upload. If not, I'll try it again.

Posts 18
Rick Dobrowolski | Forum Activity | Replied: Thu, Feb 16 2017 7:49 AM

Okay, that didn't work. Let me host on Dropbox and see if that works.

Scrolling screencast

Posts 18
Rick Dobrowolski | Forum Activity | Replied: Thu, Feb 16 2017 7:50 AM

Okay, I give up. Here's the link: 

https://www.dropbox.com/s/x18n1bbjq4d9ngs/logoslibraryscrolling.swf?dl=0

Posts 1341
PL | Forum Activity | Replied: Thu, Feb 16 2017 7:54 AM

I'm on Windows 10 laptop and did not have any delays with any of the 3 views. (Also did not know about the other two views until now.)

Posts 702
JH | Forum Activity | Replied: Thu, Feb 16 2017 8:26 AM

Philana R. Crouch:

Rick Dobrowolski:

I'm having this happen all the time when I am scrolling through the library. My macOS and Logos are updated to the latest versions, and I have the fastest processor and RAM possible on my 2015 Macbook Pro. Anyone else having this same problem?

Rick,

Can you record and upload a screencast of what you are observing? I'm trying to replicate this on my MacBook Pro, and it doesn't seem to be taking very long to load. That's with a library of 48K resources. Jing is a free screenshot and screencast application.

https://www.techsmith.com/jing.html

Thanks!

Philana,

This looks like the same issue described here that you said already has a case open to correct it.

Posts 18
Rick Dobrowolski | Forum Activity | Replied: Thu, Feb 16 2017 11:38 AM

JH, just watched your screencast. That's exactly what mine is doing. Wow, that's a really old bug then. Time to squash it.

Page 1 of 1 (15 items) | RSS