Logos 7.4 SR-1 (7.4.0.0051) is available for download

Page 1 of 1 (7 items)
This post has 6 Replies | 2 Followers

Posts 3007
LogosEmployee
Philana R. Crouch | Forum Activity | Posted: Mon, Feb 13 2017 1:14 PM

Logos 7.4 SR-1  (7.4.0.0051) is available for download.

If you have automatic updates turned on, 7.4 SR-1 will be downloaded automatically the next time your system checks for updates. To install it right away, enter the Update Now command. If you encounter problems with the auto update, download 7.4 SR-1 using the links at https://www.logos.com/install 

Release Notes

Posts 9229
Forum MVP
Bruce Dunning | Forum Activity | Replied: Mon, Feb 13 2017 5:32 PM

Thanks to you and your team for these continual improvements.

Using adventure and community to challenge young people to continually say "yes" to God

Posts 186
Paul L. White | Forum Activity | Replied: Tue, Feb 14 2017 4:32 AM

Howdy,

I am thankful for the update, and wanted to report to you something for your perusal.

Every morning after 2am Texas time, I peruse Vyrso and Logos for any free books.  Today there was Mark Ward's new volume on the advantages of electronic libraries (which I really like!).

The challenge is that Logos is taking a Very Long Time to index.  In just over an hour, the index was only a5 44%.  The indexer is taking 248,000 kb or so in memory, and using close to 100% of the CPU.

More than two hours (is what it appears this will take) is what it takes to index a brand new library!

Thought you should know.

Paul L. White

Satisfied Logos User since 1.6

Posts 28309
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Feb 14 2017 7:54 AM

Paul L. White:
wanted to report to you something for your perusal.

Please create a new thread, provide appropriate details including logs. See my signature line for details. 

OSX & iOS | Logs |  Install

Posts 62
Larry Parker | Forum Activity | Replied: Tue, Feb 14 2017 9:45 AM

I installed this last night and it downloaded 17 gigs of files.  Then it did it's usual stuff for a long time and everything ran fine.  This morning it tells me that resources need updating and I can't get into my Logos 7.  So I go to LogosSetup.exe and it tells me everything is up to date.  Now it looks like the only way to fix this is to uninstall everything (Silver) and start over.

I just upgraded to Logos 7 Silver from Logos 5 Silver too.

Update:  I just ran Repair and it fixed it.  Weird...

Update2:  Found out what caused this.  I was using the previous icon to open Logos and the update changed the location and made a newer icon.  The newer one works, the older one says "Resources need updating."  My fault.  :)

Posts 25663
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Feb 14 2017 11:58 AM

Larry Parker:
the older one says "Resources need updating."  My fault.  :)

Not your fault. Repair should be attempted as a fix rather than uninstalling. Weird..but well done!

Dave
===

Windows 10 & Android 8

Posts 62
Larry Parker | Forum Activity | Replied: Tue, Feb 14 2017 4:42 PM

Well the good news is that I got it back up and running without a reinstall.  Thank God!  Thank you too Dave.  Big Smile

Page 1 of 1 (7 items) | RSS