A15 Stuck on Download of New Book Purchases

Page 1 of 1 (7 items)
This post has 6 Replies | 0 Followers

Posts 67
LO | Forum Activity | Posted: Sat, Mar 20 2010 7:40 AM

Dear Devs,

I recently purchased some new resources some of which automatically downloaded and indexed in A15 with no problems. However, my most recent purchase (i.e. the Louis Berkhof collection) will not complete its download. I have attempted the following solutions, each of which results in a growl popup which says that A15 is now downloading 18.3 MB. However, the popup (and the blue status bar icon) immediately disappear, and the download does not happen:

1. Every time I start A15

2. Every time I re-start A15

3. Every time I run the "update resources" command

4. Every time I run the "update now" command

5. Due to the simultaneous downloading and indexing (see note below) I thought there may be an indexing problem, so I ran the "rebuild index" command, but to no avail. The download is still stuck at the 18.3 MB update.

6. "Merge index" did not fix it.

7. "rebuild Bible index" did not fix it.

As it stands now, I only have one book of the Louis Berkhof collection in my library.

My latest logs are attached.

2727.Archive.zip

I should add--though I don't know whether this is directly related--the downloading and indexing of updates this past week (esp. Thu and Fri) seemed odd. (I am specifically referring to the updates noted here: http://community.logos.com/forums/t/13801.aspx) The updates did not all come in one download, but required multiple re-starts right after each other. (i.e. Just after it would finish one download, A15 would go for two or three more, one after the other.) Also, several times I received double growl popups indicating that A15 was attempting to download updates and index simultaneously. Is this simultaneous download/indexing bit a problem?

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Sun, Mar 21 2010 2:14 PM

It appears that there is/was some kind of server problem:

03/20/2010 10:27:42 | DEBUG | 22 |  MacDownloadJob | Could not complete download. The remote server returned an error: (403) Forbidden.

I would suggest trying "Update resources" from the Command Bar again and seeing if the updates work now.

The downloads that fail will be requeued up for later downloading. After each new download is completed, Logos 4 sets a flag that tells the indexer to rediscover any newly downloaded books. Once the indexer restarts, all the downloaded books are discovered and if necessary, indexed. Occasionally, if there were failed downloads (as in this case), you'll also see that new books are trying to be downloaded. The books that are downloading are not being indexed at the same time, so there is no conflict. The downside is that the indexer may have to rebuild your supplemental index to add the new books which were not previously downloaded, but the trade off is being able to use your new resources sooner, rather than for waiting for all pending downloads to complete before indexing.

Mobile Development Team Lead

Posts 67
LO | Forum Activity | Replied: Mon, Mar 22 2010 3:52 AM

HI Tom,

No dice on the "update resources."

I tried a few more things:

1. Downloaded and installed the books manually in Libronix, then re-started A15 and ran "update resources"...no go

2. Deleted the following files: DownloadManager.db, Metadata.db, ResourceManager.db, ResourceSyncManager.db, Updates.db. Upon restarting L15 presented a "downloading 8.5Gig" message, so I canceled the download. Then L15 went through "preparing your library." Then it downloaded a 118 Mb update. I restarted, and walla, the Berkhof collection appeared.

However, L15 still is attempting to download the same 18.3Mb update, and it presents the same three growl popups every time I open (i.e. 1. Indexing started, which immediately disappears; 2. Downloading 18.3mb; 3. Indexing started, simultaneous w/ #2, but then it immediately disappears and apparently cancels the download). So, something is still not working properly.

It is not a huge deal at the moment, but I figured you guys would want to know in case there is a bug somewhere. Here's my latest logs. The last thing I've done is (a) restarted and (b) attempted an "update resources":

3058.Archive.zip

I'll test it again after today's update . . . .

Posts 67
LO | Forum Activity | Replied: Tue, Mar 23 2010 9:46 AM

...ok, after upgrading to A16 I encountered the same problems. So, I ran "merge index," and now the two indexing Growl popups are now gone. (Improvement!)

Now I just have the 18.3 Mb download notification hanging on. It disappears just about as soon as it appears. "Update resources" and "Update now" and re-starting the app all cause the same notification. It just seems like it is stuck or it refuses to complete the download and terminates it just after startting it. Perhaps it is a server issue, like you thought earlier.

Anyhow, it is not a huge pain. Everything else seems to be functioning properly in A16. Here's the latest logs after running the "update resources" command:

42287.Archive.zip

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 1 2010 3:09 PM

LO:

Try deleting your DownloadManager.db and Updates.db files. Earlier when you went on the deleting spree (specifically ResourceManager.db, ResourceSyncManager.db)  and it started downloading many items that was because it no longer recognized you had those resources, so it wanted to go get them. I think perhaps deleting the two database (db) files I suggested should fix it. Either that or you could try a re-index (painful I know but indexing is better now than it was in the past). Oh, and when you index, don't let your computer go to sleep.

 

Posts 67
LO | Forum Activity | Replied: Fri, Apr 2 2010 5:30 AM

Hi Tommy,

Deleting those 2 files and running the "merge index" command have fixed the problem. Thanks for the tip!

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Apr 6 2010 1:52 PM

LO:

Good to hear it.

 

Page 1 of 1 (7 items) | RSS