Possible A16 bug. Crash/hang problem. app not responding.

Page 1 of 1 (18 items)
This post has 17 Replies | 0 Followers

Posts 22
Tony Garcia | Forum Activity | Posted: Mon, Mar 22 2010 4:24 PM

Here is the log files.

7536.possible A16 bug.zip

After updating, it re-launched and worked fine, until I did a search. Now when I open it, it hangs and nothing loads on the home screen. Let me know if you need something else or if I didn't do the bug reporting right. This is my first time.

Posts 22
Tony Garcia | Forum Activity | Replied: Mon, Mar 22 2010 4:25 PM

Oh! Just wanted to say that I love the improvements (what I've seen so far). Great job dev team. Hope I can help.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Mon, Mar 22 2010 4:40 PM

Tony,

Where did you do the search? Was it from the Home page, or did you click on the Search icon and run a search that way?

What was your search on?

Mobile Development Team Lead

Posts 22
Tony Garcia | Forum Activity | Replied: Mon, Mar 22 2010 4:43 PM

I searched for "Romans 8" and hit enter. The search was done in the Home Page (with the "Go" button), not the search bar.

Logos opens for me, but nothing on the home page is loading (even though it did when I first updated. I was able to open the customize menu and I was checking out the file menu, so the update applied and was working.

Posts 22
Tony Garcia | Forum Activity | Replied: Mon, Mar 22 2010 4:47 PM

I don't know if this will help, but this is the error log that Apple put together for me after I had to force quit.

 

0257.crash log by apple.rtf

Posts 22
Tony Garcia | Forum Activity | Replied: Mon, Mar 22 2010 5:16 PM

Here is another bug report. This time it let me do one passage guide search (from the home screen) before hanging on the second. I have never had problems with this before. Just thought I'd post another log. Hope this helps.

 

8424.Bug report 2.zip

Posts 57
Bryan Smith | Forum Activity | Replied: Mon, Mar 22 2010 7:51 PM

Tony Garcia:

Here is another bug report. This time it let me do one passage guide search (from the home screen) before hanging on the second. I have never had problems with this before. Just thought I'd post another log. Hope this helps.

 

8424.Bug report 2.zip

Seem to be having the same problem. Opened the first time and now hangs every time.

Log 8270.Console Messages.log.zip

Posts 23
John Wetzig | Forum Activity | Replied: Tue, Mar 23 2010 9:49 AM

I also had the same problem. Works when I first open the passage guide to a passage, but if I enter a second passage I get the flying pizza.

Still a great & helpful program!

 

0488.Archive 2.zip

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Mar 23 2010 10:47 AM

I think this bug has to do with the fact that the People, Places and Things sections are *REALLY* slow right now. We mentioned this in the release notes, and depending on what kind of system you're running on (2 cores vs. 4 or 8), the "hang" can seem longer because of all the work going.

Running a search for a passage on the home page runs a Passage guide and an Exegetical guide. Depending on which base package you have this can cause lots of work to happen on the CPU.

When I run this on my Mac pro at work, I can see that the CPU goes up to 400-500% because there are 4 or 5 threads which all want to do work on the CPU. On my Macbook at home, which has 2 cores, this search takes much longer because there's only 2 processors to do all of the work.

If you leave it running long enough, it will come back. On some machines this may be up to 2-3 minutes.

I realize that this is unacceptable and we're hoping to speed this up soon.

 

Mobile Development Team Lead

Posts 23
John Wetzig | Forum Activity | Replied: Tue, Mar 23 2010 10:51 AM

Another crash. This time I was scrolling through "Luke the Historian" by Bob Utley. Suddenly, flying pizza, floating beachball, whatever. 

 

4300.Archive 2.zip

Posts 23
John Wetzig | Forum Activity | Replied: Tue, Mar 23 2010 10:55 AM

Thanks, Tom. I'll be more patient next time. (He says to his wife...)

 

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Tue, Mar 23 2010 12:31 PM

John,

JohnWetzig:
Another crash. This time I was scrolling through "Luke the Historian" by Bob Utley. Suddenly, flying pizza, floating beachball, whatever. 

Did the application crash and disappear, or was it just busy? Did you force quit?

I can see in the console logs that it was terminated, but I can't see anything related to a crash.

 

 

Mobile Development Team Lead

Posts 23
John Wetzig | Forum Activity | Replied: Tue, Mar 23 2010 12:41 PM

I did force quit. Probably should have waited longer. If it happens again, I promise I'll be more patient.

Thanks for a great program!

Posts 219
Dennis Miller | Forum Activity | Replied: Wed, Mar 24 2010 7:00 AM

Ditto to what everyone else is reporting. Core2 Duo 2.66 iMac 4 gig ram.

Posts 35
Zach Fortenberry | Forum Activity | Replied: Wed, Mar 24 2010 8:12 AM

i keep getting hung up on Romans 8 as well.  I have have to restart my computer about 7 times.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Wed, Mar 24 2010 8:49 AM

Zach Fortenberry:
i keep getting hung up on Romans 8 as well.  I have have to restart my computer about 7 times.

I tested this last night on A16 from my Macbook 2.0 ghz at home. It took about 10 minutes for the passage and exegetical guides to finish, but it didn't hang.

Can you just give it about 10 minutes and see if it works? Long term, that's not acceptable, I know, but we haven't gotten around to optimizing that part of the code yet.

Mobile Development Team Lead

Posts 35
Zach Fortenberry | Forum Activity | Replied: Wed, Mar 24 2010 11:01 AM
Reply More
Tom Philpot Replied: Today 8:49 AM

Zach Fortenberry: i keep getting hung up on Romans 8 as well.  I have have to restart my computer about 7 times.

 

I tested this last night on A16 from my Macbook 2.0 ghz at home. It took about 10 minutes for the passage and exegetical guides to finish, but it didn't hang.

Can you just give it about 10 minutes and see if it works? Long term, that's not acceptable, I know, but we haven't gotten around to optimizing that part of the code yet.

 

 

Thanks Tom!! I'll try that!

Posts 35
Zach Fortenberry | Forum Activity | Replied: Wed, Mar 24 2010 9:46 PM

Tom,

That worked!! thanks!!  

Page 1 of 1 (18 items) | RSS