Copy and Paste

Page 1 of 1 (18 items)
This post has 17 Replies | 1 Follower

Posts 120
David Manning | Forum Activity | Posted: Tue, Mar 30 2010 4:34 AM

I know its not in any order, but Cam do you have a time frame on the copy and paste feature?

Thanks

MacBook Pro 15" Retina 1TB Flash 2.8 Quad i7 16 GB Ram OSX 10.13.4

iMac 27"3.2 GHz Intel Core i5 - 32 GB Ram 10.13.4

Posts 2774
J.R. Miller | Forum Activity | Replied: Tue, Mar 30 2010 11:03 AM

Yes, it works now by right clicking and selecting "copy".

My Books in Logos & FREE Training

Posts 152
Mike Strawn | Forum Activity | Replied: Thu, Apr 1 2010 3:29 AM

 

Doesn't always work - I tried selecting various sections of 1Corinthians 15 ESV - and depending on which portions I select - the Copy Option appears upon a Right Click - and other times it doesn't  - can't seem to pick up on a pattern - but it is inconsistent. See attached screenshots.

 

 

 

Posts 10520
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Apr 1 2010 4:30 AM

Mike Strawn:
Doesn't always work - I tried selecting various sections of 1Corinthians 15 ESV - and depending on which portions I select - the Copy Option appears upon a Right Click - and other times it doesn't  - can't seem to pick up on a pattern - but it is inconsistent. See attached screenshots.

Mike

Your screen shot does not show the right side of the right-click menu, so I don't know whether you are aware of this or not. You need to click on "Selection" on the right in order to have "Copy" on the left.

Posts 235
Stephen Ashton | Forum Activity | Replied: Thu, Apr 1 2010 4:31 AM

Mike – I haven't been able to reproduce this issue precisely as shown on your screenshots. However, I do get similar lists if I a) click on a word or selection, and b) click on white space. See below:

Does this help?

Read FAQ and Guide for Reporting Bugs.

13" Macbook • 2GHz • 2GB RAM • OS 10.6.6 • 160GB Hard Drive

Posts 10520
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Apr 1 2010 4:36 AM

Jack Caviness:
Your screen shot does not show the right side of the right-click menu, so I don't know whether you are aware of this or not.

I know it's rather tacky to reply to your own post, but I too k a closer look at Mike's screen shot. There is enough of the right side of that menu to see that no options appear there, and he does have text selected in both shots. So neither Stephen nor I have duplicated what Mike is seeing.

Posts 235
Stephen Ashton | Forum Activity | Replied: Thu, Apr 1 2010 4:36 AM

Jack – Looks like we were replying at the same time. I think yours is the better answer though!

Read FAQ and Guide for Reporting Bugs.

13" Macbook • 2GHz • 2GB RAM • OS 10.6.6 • 160GB Hard Drive

Posts 10520
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Apr 1 2010 4:45 AM

Stephen Ashton:
Jack – Looks like we were replying at the same time. I think yours is the better answer though!

I don't think either one of us has yet duplicated Mike's problem though. I even tried 1 Cor 15 in the ESV to make sure it was not resource specific. I selected verses 1-2 both with and without the chapter number, but still no cigar.

Sorry, Mike, I can't seem to find a way to help you. I don't know if log files will help in this case or not.

Posts 15
Skip Gaede | Forum Activity | Replied: Thu, Apr 1 2010 5:40 AM

I have both Logos 3 and Logos 4 on my Mac, and have been copying and pasting from Logos 3 until today, when I tried it in Logos 4 for the first time.

Not knowing there was a different way to do it, I simply highlighted a passage of Scripture and did a CMD-C, CMD-V. What I got was a mess, with some portion of the clipboard in very small font, and other portions in very large font. When I went to try changing the font size, the software said all of the text was at the same size!

To replicate: Open NIV to John 20:10-18, highlight the text, do CMD-C, and paste it into a slide with a text box in PowerPoint 2008.

This is not a show stopper, as it works fine in Logos 3. I'm using alpha 16A on Snow Leopard 10.6.2 (64 bit) if that matters.

Blessings,
--skip

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 1 2010 11:10 AM

Hey Skip:

Could you try pasting special in PowerPoint and see if there is a "paste special" option. It will look like what you see here, and your options should look like this. Otherwise I know elsewhere others have documented issues pasting into Word: http://community.logos.com/forums/t/14612.aspx. Dave Mitchell replied saying: 

There are some known issues with pasting into Microsoft Word, and pasting footnotes into Pages does not currently work. We're working on both issues. In the meantime, if you have Word, but not Pages, you should be able to paste your text from Logos into TextEdit, and then copy it from there into Word.

Try that and see if it helps.

 

Posts 15
Skip Gaede | Forum Activity | Replied: Thu, Apr 1 2010 11:41 AM

@Tommy,

The Paste Special... had three options: RTF (default), Stylized, and Plain Text. Options 2 and 3 both worked, and the results were the same. Option 1 is what I was using when I did a Paste, and the results looked like this:

 

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 1 2010 11:58 AM

Skip:

I think you meant to paste a screen. It did not post. As for your text though: When you said Options 2 and 3 worked, do you mean they operated correctly or with the same results as before (I.E. pasting with font irregularities).

 

 

 

Posts 15
Skip Gaede | Forum Activity | Replied: Thu, Apr 1 2010 12:10 PM

@Tommy,

I fixed my reply so you can see what it looks like. Options 2 & 3 resulted in unformatted text being inserted. The verse numbers were down on the line as plain text. I can always get the text correctly using Logos 3, but it would be nicer...

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 1 2010 2:41 PM

Have you tried pasting into TextEdit and then over to PowerPoint?

 

Posts 15
Skip Gaede | Forum Activity | Replied: Thu, Apr 1 2010 2:50 PM

@Tommy,

Yes, I just tried it, and it's not terribly interesting. While the verse numbers retain their superscript formatting, the citation information is lost. Until the feature is fixed in Logos 4, it seems much simpler to use Logos 3, which gets it right.

Fixing the problem is on the "To Do" list, correct?

Thanks,
--skip

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 1 2010 3:30 PM

skipgaede:

@Tommy,

Yes, I just tried it, and it's not terribly interesting. While the verse numbers retain their superscript formatting, the citation information is lost. Until the feature is fixed in Logos 4, it seems much simpler to use Logos 3, which gets it right.

Fixing the problem is on the "To Do" list, correct?

Thanks,
--skip

Since it is the same issue as with Word--yes--it is in the "To Do" list.

 

Posts 152
Mike Strawn | Forum Activity | Replied: Fri, Apr 2 2010 4:55 AM

If you notice the slight differences in the selection that I made - the first starts with the Chapter Number included - all the way to the end of Verse 2 - where the Copy Option appears. The second selection starts with the word NOW - avoiding the Chapter Number and the space following and it end right after "received," - that selection does not produce the Copy Option. I did try what Jack suggested - Click on the Selection itself to the Right and then the Copy function did work - it's just a bit inconsistent that sometimes the Copy Option displays on the Left side and you can simply select it there - rather than have to incur an additional Mouse-Click and choose the Selection first.

Hope that helps for those who are trying to replicate what I did.

Thanks for all the interest in getting to the bottom of this. 

-Mike

Posts 15
Skip Gaede | Forum Activity | Replied: Fri, Apr 2 2010 5:49 AM

Being a newbie w.r.t. Logos 4, is there a reason why we need to use the right-click and choose "copy" from the contextual menu instead of just using the keyboard shortcut (CMD-C)?

Thanks,
--skip

Page 1 of 1 (18 items) | RSS