Hang: 7.10 freezes when Home Page opens at startup

Page 1 of 1 (11 items)
This post has 10 Replies | 0 Followers

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Posted: Tue, Oct 17 2017 8:09 AM

Starting with 7.10, Logos hangs while opening the Home Page at startup.

(Using the Command key startup option,) I've changed the program settings to open to a blank layout, and Logos now longer hangs at startup.

Once the program is open, I am able to show and hide the Home Page without any issues.

I've seen other reports of this problem (going back a few months), but never experienced it myself until this 7.10 update.

Logs in the previous thread, before it was determined to be a Home Page issue.

Logos 7.10 (7.10.0.0019) on macOS 10.13 (17A405)

MacBook Pro (Retina, 15-inch, Mid 2015), if it matters.

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 28284
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Oct 17 2017 8:41 AM

Which specific computer? There was an issue related to some machines, but I dont remember the details... I was unaffected. 

OSX & iOS | Logs |  Install

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Replied: Tue, Oct 17 2017 8:53 AM

alabama24:
Which specific computer? There was an issue related to some machines, but I dont remember the details... I was unaffected. 

PetahChristian:
MacBook Pro (Retina, 15-inch, Mid 2015), if it matters.

I remember seeing some posts about 2011 models, and Home Page issues, but everything has been running fine up until 7.10.

Since nothing else (OS, hardware, third-party software, or program settings) has changed except 7.10, I'm guessing that something different -- some deadlock? -- about how 7.10 starts is causing it to hang, rather than a hardware/compatibility issue.

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Oct 18 2017 6:25 AM

Has a case been opened for this issue? Is this an existing or new issue? Thanks!

Hoping this won't take many releases to eventually fix, as I really like being able to start off with the Home Page when Logos is opened.

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 55
LogosEmployee
Matt Preucil | Forum Activity | Replied: Wed, Oct 18 2017 10:54 AM

Petah,

I'm sorry that you're experiencing this problem. Your samples suggest that there is some deadlock in Mono's method jitter and apparently the current state of our code running on your hardware exhibits the issue. I'm glad you found a temporary workaround, and hopefully we'll be able to resolve this for you soon.

The problem was likely introduced for you in 7.10, which contained a Mono version upgrade. We didn't run into this problem in testing.

We are looking at upgrading Mono to the next stable version (just released) which does have performance improvements in the jitter. I'm optimistic that simply different executing code paths have a good chance of avoiding this deadlock scenario (if it wasn't fixed internally with those changes). If not, then we can look into patching the bug after we are on the new version. However, we generally like to maximize internal testing with new versions of frameworks, so these changes likely won't ship until the 7.12 timeframe.

If I come across another way to fix the bug, I'll follow up here. Additionally, it's possible that different application code might also "fix" the issue for you, so it would be worth testing again with each new release.

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Oct 18 2017 11:17 AM

Thanks very much, Matt, for the feedback, and providing a rough idea of when a fix might be available.

It's much better knowing it may take until the 7.12 timeframe, than not knowing if or when the problem might be fixed.

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 3628
Forum MVP

PetahChristian:
Once the program is open, I am able to show and hide the Home Page without any issues.

Ran into my first issue.

Started Logos. Program had downloaded a book, and was indexing. Clicked on the Home Page icon to view the Home Page, and Logos immediately crashed.

Not sure if this is related to the new Mono version, but this crash happened in Mono SGen. 

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 32
Chuck Alford | Forum Activity | Replied: Tue, Oct 24 2017 2:52 PM

I started having problems with this same issue today as well. Logos will crash when trying to load home page. I do get it to open the home page after relaunching it a couple of times. I'm running OS Sierra on a Mid 2014 MacBook Pro. 

Does anyone know if has been reported and being worked on by the Dev team?

Thanks

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Replied: Tue, Oct 24 2017 3:46 PM

Sorry about the crash.

Chuck Alford:
Does anyone know if has been reported and being worked on by the Dev team?

The original problem (of Logos hanging when opening the Home Page) has been reported to the developers.

As far as it crashing when opening the Home Page, you might want to report that (different?) problem in a new thread, to ensure that the devs also know about it crashing.

We usually don't know what the devs are specifically working on, but Philana does update forum threads once a fix has been made by the dev team.

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Replied: Mon, Nov 27 2017 5:15 PM

Matt Preucil:
Additionally, it's possible that different application code might also "fix" the issue for you, so it would be worth testing again with each new release.

FYI, 7.11 doesn't completely avoid the deadlock issue. Two out of three attempts of launching to the Home Page at startup led to the program freezing.

Thankful that I can open to a blank layout in the meantime.

Logos 7.11 (7.11.0.0023) on macOS 10.13.1 (17B48)

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 3628
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Jan 10 2018 7:01 PM

Reporting that this issue appears to be fixed in Logos 7.12 (7.12.0.0027) on macOS 10.13.2 (17C88).

I've been able to launch to the Home Page at startup, four times, without the program freezing.

Thanks!

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Page 1 of 1 (11 items) | RSS