Workaround for Crash on Mac when navigating to certain areas of Logos 7

Page 1 of 1 (8 items)
This post has 7 Replies | 0 Followers

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Posted: Thu, Dec 14 2017 11:50 AM

A handful of customers have been experiencing crashes when navigating to certain areas of Logos 7 on macOS.

These customers would experience a crash in:

Ask the Author Tool
Bible Browser Tool
Bible Senses Tool
Community Notes Tool
Text Comparison Tool
Courses Tool
Free Resource Preview for unowned books
Groups Tool
Home Page
Media Tool
Morph Grid Document
Reading Plan Document Overview view
Sermon Document

The customer or a third-party software may have enabled "Automatic Proxy Configuration." Deselecting that option in the Network settings of macOS will resolve the problem. We are working on a code solution to avoid such problems, but in the meantime if you are crashing at the above locations follow the instructions below:

1. Click the Apple icon in the top left corner.
2. Click "System Preferences."
3. Click "Network." 
4. Click "Advanced." 
5. Click "Proxies." 
6. Deslect "Automatic Proxy Configurations" if it is selected. 
7. Click "Apply" (if prompted).
7. Restart Logos 7.

Note: A third party application may have enabled this setting, and deselecting it may cause the application to not work properly.


Below is an excerpt from a log indicating this particular crash 

NSUncaughtSystemExceptionException: Uncaught system exception: signal 5
Stack trace:
0 +[LoggingUtility logCrash:] [0x10de4bdd7 - MarshalUtility]
1 -[OurAppController exceptionHandler:shouldLogException:mask:] [0x10eab1a0e - ApplicationBundle]
2 -[NSExceptionHandler _handleException:mask:] [0x7fff3e579eb9 - ExceptionHandling]
3 NSExceptionHandlerUncaughtSignalHandler [0x7fff3e579c9d - ExceptionHandling]
4 _sigtramp [0x7fff63d72f5a - libsystem_platform.dylib]
5 (null)
6 cef_time_delta [0x1184d79cf - Chromium Embedded Framework]
7 cef_time_delta [0x1185910cd - Chromium Embedded Framework]
8 KeychainReauthorizeIfNeededAtUpdate [0x1199a1dbc - Chromium Embedded Framework]
9 ChromeAppModeStart_v4 [0x118299519 - Chromium Embedded Framework]
10 ChromeAppModeStart_v4 [0x11829928d - Chromium Embedded Framework]
11 cef_initialize [0x116d39ec4 - Chromium Embedded Framework]
12 (wrapper managed-to-native) Xilium.CefGlue.Interop.libcef:initialize (Xilium.CefGlue.Interop.cef_main_args_t*,Xilium.CefGlue.Interop.cef_settings_t*,Xilium.CefGlue.Interop.cef_app_t*,void*) {0x7fccbd5ad298} + 0x6f (0x1472bd5d0 0x1472bd6c3) [0x7fcccbf138b0 - MonoHost]
13 Logos.WebBrowser.WebBrowserFactory:.ctor (Logos.WebBrowser.WebBrowserFactorySettings) {0x7fccd8312ab0} + 0x1240 (0x1472b7df0 0x1472b9218) [0x7fcccbf138b0 - MonoHost]
14 LDLS4.AppModel:CreateWebBrowserFactory () {0x7fcccdd95770} + 0x647 (0x1472b67d0 0x1472b7038) [0x7fcccbf138b0 - MonoHost]

 

Posts 1
Frank Hopson III | Forum Activity | Replied: Fri, Dec 15 2017 5:55 PM

Worked for me. Thanks!!

Posts 20
Pastor Park | Forum Activity | Replied: Sat, Dec 16 2017 10:33 PM

Thanks for trying. I guess it helped the other guy, but mine was not selected when I checked my network settings.

Posts 28
Pastor Lloy B. Stevens | Forum Activity | Replied: Mon, Dec 18 2017 3:46 AM

Thanks, it did the trick. My ad blocker had asked me to select automatic proxy configuration...

Posts 49
LogosEmployee
Matt Preucil | Forum Activity | Replied: Mon, Dec 18 2017 9:48 AM

Kevin and Stephanie, if you are currently experiencing this crash and it is not fixed by adjusting your system's proxy settings, I'd love to help troubleshoot. Do you have some logs available?

Posts 205
Marshall Harrison | Forum Activity | Replied: Tue, Dec 19 2017 5:44 AM

Automatic Proxy Configuration wasn't checked on my system.

I get periodic crashes/exits from the program. I haven't narrowed it down but it seems to happen most when I close a resource. Frustrating but I just open Logos again and move forward.

My system:

Hardware Overview:

  Model Name: MacBook Pro

  Model Identifier: MacBookPro11,3

  Processor Name: Intel Core i7

  Processor Speed: 2.6 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 6 MB

  Memory: 16 GB

  Boot ROM Version: MBP112.0142.B00

  SMC Version (system): 2.19f12

  Serial Number (system): C02MQ0FSFD59

  Hardware UUID: 40C61B23-7CF4-50CB-B3D8-C902B0B76C25

ystem Software Overview:

  System Version: macOS 10.13.2 (17C88)

  Kernel Version: Darwin 17.3.0

  Boot Volume: Macintosh HD

  Boot Mode: Normal

  Computer Name: Marshall’s MacBook Pro

  User Name: Marshall Harrison (marshallharrison)

  Secure Virtual Memory: Enabled

  System Integrity Protection: Enabled

  Time since boot: 1:30

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Dec 20 2017 4:17 AM

Marshall Harrison:
I get periodic crashes/exits from the program.

We need logs from the app. to diagnose your issue.

Dave
===

Windows & Android

Posts 22
Joe Smysor | Forum Activity | Replied: Mon, Dec 25 2017 7:51 PM

I am having the same issue. Logos 7 crahses on open on a MacBook Pro.  I am using High Seria. I have emailed logs to support but have not heard back in a week (I know there's been a holiday so I'm not upset).  

Proxies is normal. Out of ideas.

Page 1 of 1 (8 items) | RSS