Bible & Biblia Stable release not found on Amazon Store

Page 1 of 1 (3 items)
This post has 2 Replies | 0 Followers

Posts 2675
David Ames | Forum Activity | Posted: Thu, Mar 8 2018 10:00 AM

Bible & Biblia Stable release not found on Amazon Store

Faithlife Announcements:
Feb 20 2018 6:02 PM
The Android team is pleased to announce the 6.1.1 Stable release of the Bible, Biblia, FSB, Verbum, Faithlife Ebooks and Noet apps.


Amazon Store direct download links:
Logos - http://www.amazon.com/Logos-Bible-Software/dp/B0062RM1VQ
Faithlife Study Bible - http://www.amazon.com/Logos-Bible-Software-Faithlife-Study/dp/B007XYDE5O
Biblia - http://www.amazon.com/Logos-Bible-Software-Biblia/dp/B007XWM7XQ
Noet - http://www.amazon.com/Logos-Bible-Software-Classics-Research/dp/B00HK581D

A) Why no Verbum on Amazon Store ?

B) Tried loading 6.1.1 from those links to Cloud and reinstalling. Still get 5.17 517010094
Uninstalled 5.17 and tried to reinstall 6.1.1  Got 5.17 still

C) Tried to find any Faithlife app on the Amazon Store directly and could find none.
Only find faithlife groups
Searched for "Logos bible app for kindle fire" does not show any Logos product

How do I catch the executable on my Samsung so I can install it on my Amazon??
[[the older versions work fine and I have no problem with side loading an app]]

Posts 32
LogosEmployee
Carla S. | Forum Activity | Replied: Thu, Mar 8 2018 11:54 AM

Hi David,

We are happy to help you with your questions today.  

Amazon doesn’t make Vyrso or Verbum available for Kindle devices. Though we’ve requested that they do so they have never sent us a reply, nor added our apps into the app store for Kindle devices.

It appears that you are running Android version 4.4 which is no longer supported (https://community.logos.com/forums/t/154881.aspx).

The Logos app isn’t found when searching the Kindle store because it’s either being withheld by Amazon from certain devices, or because your device is running a version of Android 4.4 that is not supported.  Version 6.1.1 of the Faithlife mobile apps can’t be sideloaded on that version of Android either. 

We offer for any device that cannot install our mobile app the option of using the browser on that device and going to https://app.logos.com . Once you log in, you will be able to see the resources from your library and access to a growing number of features in the web app.  I hope that this information finds you well.  

Posts 2675
David Ames | Forum Activity | Replied: Thu, Mar 8 2018 1:46 PM

Carla Schermerhorn:

Hi David,

We are happy to help you with your questions today.  

Amazon doesn’t make Vyrso or Verbum available for Kindle devices. Though we’ve requested that they do so they have never sent us a reply, nor added our apps into the app store for Kindle devices.

It appears that you are running Android version 4.4 which is no longer supported (https://community.logos.com/forums/t/154881.aspx).

The Logos app isn’t found when searching the Kindle store because it’s either being withheld by Amazon from certain devices, or because your device is running a version of Android 4.4 that is not supported.  Version 6.1.1 of the Faithlife mobile apps can’t be sideloaded on that version of Android either. 

We offer for any device that cannot install our mobile app the option of using the browser on that device and going to https://app.logos.com . Once you log in, you will be able to see the resources from your library and access to a growing number of features in the web app.  I hope that this information finds you well.  

From Amazon: "Updates for Fire HDX 8.9 (3rd Gen) are no longer being sent". Current update is Android 4.4 KitKat  4.5.5.3  Apparently 4 years is the life time of a tablet.  [came from the PC world where a PC was expected to last 10 years.  

Have installed the Logos Apps on my other, newer, tablet. Now just have to learn how to use the new changes.

Did learn something - the Amazon App Store seems to not allow you to see Apps you can not run. 

Thanks for the feedback.

Page 1 of 1 (3 items) | RSS