BUG im Predigt Editor

Page 1 of 2 (21 items) 1 2 Next >
This post has 20 Replies | 3 Followers

Posts 17
Matthias Redikop | Forum Activity | Posted: Wed, Mar 21 2018 5:24 AM

Hallo

Ich habe einen BUG im Predigt Editor, im Bereich Predigtinfo.

Das Datum das ich, unter dem Punkt Anlässe, eingebe, wird leider nicht gespeichert.

Ich gebe das Datum und klicke auf "Predigtinfo ist fertig". Öffne ich danach wieder die Predigtinfo, steht im ersten Datum Feld das Datum "1.1.2017" und nicht das Datum, dass ich eingegeben habe. Die anderen Datums Felder sind komplett leer, obwohl ich dort auch ein Datum eingetragen habe.

Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Wed, Mar 21 2018 4:05 PM

Bei mir funktioniert es, wie es soll.

Wenn das Problem weiterhin besteht, könntest du mir Logs schicken? 

Logs erstellen ist unter Windows recht einfach:

  1. Starte Logos, halte unmittelbar nach dem Öffnen die „STRG“-Taste gedrückt. Lasse die Taste gedrückt, bis das Anmelde-Fenster kommt. Du weißt, dass es funktioniert hat, wenn das kommt.
  2. Geh die Schritte durch, die zum Absturz führen.
  3. Geh in den Ordner Dokumente, dort findest du den Ordner Logos Log Files. Wenn darin keine Datei namens Logos.log ist, fang noch einmal von vorne an (Logos läuft vermutlich noch im Hintergrund), ansonsten fahr fort:
  4. Mache einen Rechtsklick auf den Ordner und wähle „Senden an“ -> „ZIP-komprimierter Ordner“. Die ZIP-Datei hängst du mir dann hier oder in einer Email an deutsch@faithlife.com an.
Posts 17
Matthias Redikop | Forum Activity | Replied: Fri, Mar 23 2018 5:24 AM

Ich habe meine Logs an deutsch@faithlife geschickt. 

Ich selber habe in den Logs nichts gefunden, was das Verhalten erklären würde. 

Mir scheint es so, als würde das Control mit dem deutschen Datums Format nicht zurecht kommen. 

Wenn ich das Datum im dt. Format eingeben (19.02.2018 -> dd.mm.yyyy) wird die Eingabe nicht übernommen. Dann ist beim nächsten öffnen das Feld entweder wieder leer oder das Datum, das davor drin stand, steht wieder drin. Gebe ich aber im eng. Format das Datum ein (02.19.2018 -> mm.dd.yyyy) wird das Datum zwar gespeichert, aber ein Tag wird abgezogen, so dass im Feld 18.02.2018 drin steht.

Vielleicht kannst du danach mal schauen.

Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Fri, Mar 23 2018 10:21 AM

Matthias Redikop:
Mir scheint es so, als würde das Control mit dem deutschen Datums Format nicht zurecht kommen. 

Wir hatten schon in der Vergangenheit Probleme mit dem Datum (das mit dem abgezogenen Tag), die wir bisher leider nicht verfolgen konnten, weil wir sie nicht reproduzieren können und die Kunden, die sie bislang gemeldet haben, uns keine Logs geschickt haben. Es ist also durchaus möglich, dass es da einen Bug gibt.

Ich benutze aber selbst das deutsche Datumsformat, und bei mir hat alles wie erwartet funktioniert. Mithilfe der Logs können wir der Sache hoffentlich auf den Grund gehen. 

Posts 65
Thomas Boehme | Forum Activity | Replied: Tue, Mar 27 2018 9:41 AM

Ich kann das Problem mit dem Datumsfeld bestätigen.
Allerdings habe ich als Menü-Sprache momentan "English" eingestellt.
Meine Regional Settings und Keyboard sind jedoch auf "Deutsch".
Und das würde ich auch als maßgeblich für das Datumsformat betrachten.

Grüßle

Thomas

Posts 65
Thomas Boehme | Forum Activity | Replied: Tue, Mar 27 2018 9:51 AM

Auch mit Deutsch als Menü-Sprache werden Datümer nur nach englischem Format erkannt.

Also:

18.6.2018 geht nicht
6.18.2018 geht --> ergibt allerdings 17.6.2018 (immer ein Tag abgezogen)

4 Dez 2018 geht nicht
4 Dec 2018 geht --> ergibt 3.12.2018

Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Tue, Mar 27 2018 10:35 AM

Thomas Boehme:

Auch mit Deutsch als Menü-Sprache werden Datümer nur nach englischem Format erkannt.

Also:

18.6.2018 geht nicht
6.18.2018 geht --> ergibt allerdings 17.6.2018 (immer ein Tag abgezogen)

4 Dez 2018 geht nicht
4 Dec 2018 geht --> ergibt 3.12.2018

Das ist ein echter Phantom-Bug. Wir haben schon von einigen wenigen Usern gehört, dass er auftritt, aber Matthias war jetzt der erste, der uns Logs dazu geschickt hat (vielen Dank!). Bei uns funktioniert alles tadellos. Ohne den Fehler selbst zu reproduzieren oder Logs zum Analysieren können wir der Sache nur schwer auf den Grund gehen. Wenn du uns auch noch Logs schicken könntest, wäre das genial. (S.o.)

Posts 39
Alexander Moch | Forum Activity | Replied: Tue, Mar 27 2018 1:22 PM

Thomas Boehme:

Auch mit Deutsch als Menü-Sprache werden Datümer nur nach englischem Format erkannt.

Also:

18.6.2018 geht nicht
6.18.2018 geht --> ergibt allerdings 17.6.2018 (immer ein Tag abgezogen)

4 Dez 2018 geht nicht
4 Dec 2018 geht --> ergibt 3.12.2018

Habe das eben mal auf Win7 mit Version 7.13.0.0017 ausprobiert und konnte exakt dasselbe Verhalten feststellen. Danach hat Logos nicht mehr reagiert, konnte es nur über den Task Manager schließen. Hier die Logs:

8816.Logos Log Files.zip

Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Tue, Mar 27 2018 2:09 PM

Alexander Moch:

Thomas Boehme:

Auch mit Deutsch als Menü-Sprache werden Datümer nur nach englischem Format erkannt.

Also:

18.6.2018 geht nicht
6.18.2018 geht --> ergibt allerdings 17.6.2018 (immer ein Tag abgezogen)

4 Dez 2018 geht nicht
4 Dec 2018 geht --> ergibt 3.12.2018

Habe das eben mal auf Win7 mit Version 7.13.0.0017 ausprobiert und konnte exakt dasselbe Verhalten feststellen. Danach hat Logos nicht mehr reagiert, konnte es nur über den Task Manager schließen. Hier die Logs:

8816.Logos Log Files.zip

Vielen Dank! 

Habt ihr denn eigentlich dasselbe Problem wie Matthias mit den mehrfachen Anlass-Terminen?

Posts 65
Thomas Boehme | Forum Activity | Replied: Tue, Mar 27 2018 11:50 PM

Was genau meinst du?
Das beschriebene Verhalten hat nichts damit zu tun,
ob man nur ein oder mehrere Datumsfelder vor sich hat.
Es passiert im ersten genauso wie im dritten Feld.

Posts 39
Alexander Moch | Forum Activity | Replied: Wed, Mar 28 2018 1:42 AM

Ben Misja (Faithlife):
Habt ihr denn eigentlich dasselbe Problem wie Matthias mit den mehrfachen Anlass-Terminen?

Matthias hatte geschrieben, dass bei ihm Termin-Felder leer bleiben (nach erneutem Öffnen). Das passiert, wenn man das deutsche Datumsformat nutzt. Thomas hat diese Fälle mit "geht nicht" deklariert. Es handelt sich also um denselben Fehler, nur unterschiedlich beschrieben. Die Anzahl der Anlässe spielt dabei keine Rolle. Das Verhalten ist bei jedem Anlass dasselbe.

Primärer Bug: Der Predigt-Editor kann an genannter Stelle das deutsche Datumsformat nicht interpretieren.

Sekundärer Bug: Bei Eingabe eines englischen Datumformats zieht der Predigt-Editor einen Tag ab.

Posts 17
Matthias Redikop | Forum Activity | Replied: Wed, Mar 28 2018 2:07 AM

Genau, dass Feld bleibt leer, wenn es vorher leer war und ich das Datum im dt. Format eingebe. 

Steht vorher schon ein Datum drin und ich geben ein Datum im dt. Format ein, dann behält das Feld das vorherige Datum.

Gebe ich ein Datum im eng. Format ein, wird das Datum minus ein Tag übernommen.

Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Wed, Mar 28 2018 9:36 AM

Matthias Redikop:

Genau, dass Feld bleibt leer, wenn es vorher leer war und ich das Datum im dt. Format eingebe. 

Steht vorher schon ein Datum drin und ich geben ein Datum im dt. Format ein, dann behält das Feld das vorherige Datum.

Gebe ich ein Datum im eng. Format ein, wird das Datum minus ein Tag übernommen.

Danke. Meine Frage war, ob Thomas und Alexander dasselbe beobachten oder ob sie ausschließlich das Problem mit der falsch interpretierten Datumseingabe haben. 

Posts 65
Thomas Boehme | Forum Activity | Replied: Wed, Mar 28 2018 9:10 PM

Alexander Moch:

Primärer Bug: Der Predigt-Editor kann an genannter Stelle das deutsche Datumsformat nicht interpretieren.

Sekundärer Bug: Bei Eingabe eines englischen Datumformats zieht der Predigt-Editor einen Tag ab.

Ja, genau. Danke für die Präzisierung!

Und vielleicht der Vollständigkeit halber:

Tertiärer Bug: Das Datumsformat richtet sich nicht nach den Regional Settings im Betriebssystem. (Lässt sich erst abschließend klären, wenn der Primäre Bug gelöst ist.)

Posts 21
Johannes Klein | Forum Activity | Replied: Mon, Apr 16 2018 6:04 AM

Kann beide Bugs bestätigen.

Posts 6
dimon | Forum Activity | Replied: Sat, Jun 30 2018 1:45 PM

Habe heute einen weiteren Fehler im Predit-Editor festgestellt.

Die automatische Auswahl des Bibeltextes passt nicht mit der Versangabe überein. Es gibt immer einen Vers Versatz. Siehe Bild

Posts 39
Alexander Moch | Forum Activity | Replied: Sat, Jun 30 2018 2:13 PM

dimon:
Die automatische Auswahl des Bibeltextes passt nicht mit der Versangabe überein. Es gibt immer einen Vers Versatz.

Dieser Bug wurde vor längerem auch schon an anderer Stelle gemeldet:

https://community.logos.com/forums/t/159388.aspx?PageIndex=1 (vierter Eintrag von unten)

Leider ist er immer noch nicht behoben.

Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Mon, Jul 2 2018 10:16 AM

Alexander Moch:

dimon:
Die automatische Auswahl des Bibeltextes passt nicht mit der Versangabe überein. Es gibt immer einen Vers Versatz.

Dieser Bug wurde vor längerem auch schon an anderer Stelle gemeldet:

https://community.logos.com/forums/t/159388.aspx?PageIndex=1 (vierter Eintrag von unten)

Leider ist er immer noch nicht behoben.

Ja, das ist ein bekannter Bug. Der Predigteditor unterstützt leider die Eingabe im Versschema der Standardbibel noch nicht, sondern fällt auf das englische zurück. 

Es ist leider immer ein Abwägen, wie schwerwiegend ein Problem ist und wie viele Nutzer es betrifft. Priorität haben für uns momentan die Realisierung der lokalisierten Datentypen (Propositionale Gliederungen, Figurative Language, usw.) und der deutsche Atlas. Das soll aber nicht heißen, dass diese beiden Predigteditor-Probleme ignoriert werden. 

Danke für eure Geduld!

Posts 506
L.A. | Forum Activity | Replied: Tue, Jul 3 2018 9:51 AM

Ben Misja (Faithlife):
Wir hatten schon in der Vergangenheit Probleme mit dem Datum (das mit dem abgezogenen Tag), die wir bisher leider nicht verfolgen konnten, weil wir sie nicht reproduzieren können und die Kunden, die sie bislang gemeldet haben, uns keine Logs geschickt haben. Es ist also durchaus möglich, dass es da einen Bug gibt.

Ist ja schon ein paar Monate her... Ich habe auch keine Lösung, aber vielleicht einen Gedanken, der in die Richtung einer Lösung des Bugs zeigen könnte.

  • Bei mir selbst tritt der Bug nicht auf.
  • Vielleicht liegt es aber daran, dass ich mehr oder weniger in derselben Zeitzone lebe. Bei der Android-App der Herrnhuter Losungen gab 2014 ein ähnliches Problem, das relativ schnell gelöst werden konnte. Da gab es kein Problem bei europäischen Nutzern, aber u.a. bei mir, der ich in Brasilien lebe. 
  • Die Antwort des Supports war folgende: "Es scheint hier ein Problem mit der Datum- bzw Zeiterkennung (Serverzeit Deutschland <-> Ortszeit Rest der Welt) zu geben bzw. werden die Daten den falschen Tagen zugeordnet." 
Posts 514
LogosEmployee
Ben Misja (Faithlife) | Forum Activity | Replied: Tue, Jul 3 2018 10:16 AM

Guter Hinweis - wir haben inzwischen gemerkt, dass das möglicherweise auch andere Nutzer in Europa betrifft, und dass es wohl eher an den Online-Diensten als an Logos selbst liegt. 

Page 1 of 2 (21 items) 1 2 Next > | RSS