Indexing never ends.

Page 1 of 2 (36 items) 1 2 Next >
This post has 35 Replies | 3 Followers

Posts 242
Nielsen Tomazini | Forum Activity | Posted: Thu, Apr 12 2018 8:02 AM

Hi everyone.

After trying to install Logos in a different driver I got problems with my installation. So, I decided to do a clean install of Logos7. However it did not solve the problem because Indexing would always start from 0% every time I open Logos. So I tried to rebuild the Index but it did not solve the problem. So then I decided to format my laptop. I formatted it and began a clean install of Logos 7. Installation ran without a problem, but then Index had the same behavior, it never ends.

I waited for the "second time" index to go through but it did not change. When I start Logos, Index starts again from 0%, every time.

Please see attached my Log files.

3678.Logos Log Files.zip

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 19141
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Apr 12 2018 10:17 AM

Nielsen Tomazini:
After trying to install Logos in a different driver I got problems with my installation.

Please elaborate a bit about different drive and problems. Curious about drive hardware ?

Please enable diagnostic logging => https://www.logos.com/support/windows/report-problem since the zip file did not have Logos.log nor LogosIndexer.log file for crash context (and other diagnostic messages).

Nielsen Tomazini:
When I start Logos, Index starts again from 0%, every time.

If indexing did not complete previously, then it starts over at 0 %

Keep Smiling Smile

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Thu, Apr 12 2018 10:34 AM

Thanks for you help Keep Smiling.
Concerning moving Logos 7 to another drive, I gave it up, I need Logos running asap so, I kept myself in the traditional installation - like being converted to an Orthodox Logos Theology.

I thought the logging was enable, but anyway it is enabled now. However, Indexing was running when I enabled it. I shut down Logos, paused index, then opened Logos again and index is running again.
Should I wait for this indexing to finish and run it again to register what happens in the logging?

Concerning your point "If indexing did not complete previously..."
I understand that and it seems that index is over, it goes about 60% and then it disappears like when it reaches 100%. But when I open Logos the next time, index starts again.



www.aprendalogos.com 
Youtube: AprendaLogos

Posts 19141
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Apr 12 2018 11:41 AM

Nielsen Tomazini:
However, Indexing was running when I enabled it. I shut down Logos, paused index, then opened Logos again and index is running again.

Please check LogosIndexer.log file for diagnostic messages. Indexer running after being paused may not be logging (may need to stop Indexer process and restart Indexer for logging messages to be written).

Nielsen Tomazini:
Concerning your point "If indexing did not complete previously..."
I understand that and it seems that index is over, it goes about 60% and then it disappears like when it reaches 100%. But when I open Logos the next time, index starts again.

Previous zip file showed Indexer crashing (so did not complete previously), but lacked diagnostic context about what crashed (so humanly not know crash cause, which could be a corrupt resource OR ran out of space OR something else).

Keep Smiling Smile

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Thu, Apr 12 2018 12:00 PM

After enabling logging I decided to rebuild index just to be sure the whole process gets logged. However indexing is in only 15% after more than 1 hour indexing (my machine: Surface Pro 3, i5, 4Gb RAM, 125Gb SSD [showing 53Gb of free space at this moment]). I believe I will have to pause indexing because I will need to go home. If the logging does not get the error until there, I will ask Logos to rebuild index again and leave the computer to index overnight.

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Fri, Apr 13 2018 7:58 AM

Hi everyone,

Here comes my Logos Log files. Still Indexing start from 0% when I open Logos.

Thanks for any help.

Blessings,

58752.Logos Log Files.zip

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 26505
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Apr 13 2018 9:04 AM

Stop the indexing if necessary (kill LogosIndexer.exe in Task Manager) and exit Logos.

Permanently delete the folder C:\Users\niels\AppData\Local\Logos\Data\42g5wja0.3n4\LibraryIndex and restart Logos. Indexing should start.

Dave
===

Windows 10 & Android 8

Posts 19141
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Apr 13 2018 11:58 AM

Nielsen Tomazini:
Here comes my Logos Log files. Still Indexing start from 0% when I open Logos.

LogosIndexer.log file has message (after 577 out of 4,252 resources were indexed):

Info LibraryIndex Library indexing canceled, failed, or ran out of storage space; deleting temporary files.

LogosIndexerError.log has a variety of errors, which includes two Indexer crashes and io stream errors with different resources.

The crash in LogosIndexerCrash.txt had contextual information in LogosIndexer.log until the Indexer was started again.

When Indexer crashes, please check modified dates of LogosIndexer.log and LogosIndexerCrash.txt => when they are the same, please zip up log files and attach them.

Because of io stream errors, you may want to check your SSD => https://www.lovemysurface.net/surface-pro-3-ssd-speed-problems/

Blog mentions Bitlocker as a potential performance issue so curious if Bitlocker is enabled ?

Keep Smiling Smile

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Fri, Apr 13 2018 12:05 PM

Thanks a lot for your feedback Keep Smiling.
I will check my SSD health.
Bitlocker is enabled. I will turn this off but I have had this Surface for 3 years always with Bitlocker on and never had a problem, but anyway, if this solves the problem, that is fine for me.
Thanks again.

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Sat, Apr 14 2018 6:58 AM

Please see attached the Log files of my last attempt to make it work.

Now I have Bitlocker Off and on a health check of my SSD no problems were found.

I will do through another Indexing turning of  all that I can (anti-virus, not so important Windows processes).

Thanks again

5700.Logos Log Files.zip

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 19141
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Apr 14 2018 12:29 PM

One item to check is your LibraryIndex folder permissions => https://www.logos.com/support/windows/error-writing-to-file (since writing postings for Library Indexing goes into LibraryIndex folder - personally would not use temporary work around for indexing since that changes AppData location). 

LogosIndexer.log file shows crash happening shortly after beginning to write postings into a new Library index. LogosIndexer.log snippets for crash context:

2018-04-13 22:56:12.3841 9 Info LibraryIndex 4,252 resources need to be indexed, and will be merged into an index of 0 resources.
2018-04-13 22:56:12.3841 9 Info LibraryIndex Re-indexing because the existing index is corrupt or missing.
2018-04-13 22:56:12.3841 9 Info LibraryIndex Final count: 4,252 resources need to be indexed; no merge necessary.

2018-04-13 22:56:12.5247 1 Info WindowsIndexerProgram Setting notification icon tool tip to: Software Bíblico Logos está indexando (0% completa)

2018-04-13 22:56:12.7279 16 Warn SearchEngineImpl Using BlockRunManagerPostingsFileWriter due to 32-bit or insufficient RAM (4001MB).
2018-04-13 22:56:12.7435 16 Info LibraryIndex Creating a new library index 'index-build' (type 0) in C:\Users\niels\AppData\Local\Logos\Data\42g5wja0.3n4\LibraryIndex

2018-04-14 02:23:22.5608 16 Info WindowsIndexerProgress 4,252 of 4,252 resources indexed; current phase progress is 58.6%
2018-04-14 02:23:22.6233 16 Info LibraryIndex (5m 47.1s) Indexing LLS:VULGATACLEM
2018-04-14 02:23:22.6233 16 Info LibraryIndex Waiting for background threads to finish.
2018-04-14 02:23:22.6233 16 Info LibraryIndex Finished indexing resources (in 3h 27m 8s); writing postings.
2018-04-14 02:23:24.9514 16 Error IndexerProgram Unhandled exception: System.InvalidOperationException: Operation is not valid due to the current state of the object.
at Libronix.SearchEngine.BlockRunManagerPostingsFileWriter.ExternalMergeSortFileBlocks(BlockRunManager mgrIn, BlockRunManager mgrOut, IWorkState state, Action`1 fnReportProgress)
at Libronix.SearchEngine.BlockRunManagerPostingsFileWriter.WritePostings(IWorkState state, IIndexerProgress progress, Stream stream, Func`2 createPostingWriter)
at Libronix.SearchEngine.PostingsFileCreator.WritePostings(IWorkState state, IIndexerProgress progress)
at Libronix.SearchEngine.Indexer.WritePostings(IWorkState state)
at Libronix.DigitalLibrary.LibraryIndex.DoBuildIndex(ILibraryIndexWorkState state, Int32 nResourceCount, String strIndexName, Int32 nAdditionalThreads, IndexFileFormat indexFileFormat)
at Libronix.DigitalLibrary.LibraryIndex.BuildIndex(LibraryIndexWorkState state, String strIndexName, IndexFileFormat indexFileFormat)
at Libronix.DigitalLibrary.LibraryIndex.IndexResources(IPausableWorkState threadOwnerWorkState, LibraryIndexWorkState state)
at Libronix.Utility.Threading.WorkStateThreadOwner`1.ThreadProc(Object objData)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart(Object obj)

Apologies since this user does not know which object(s) to check for goofy status during DoBuildIndex for WritePostings with ExternalMergeSortFileBlocks (that could be temporary files so would check permissions for TEMP locations => https://www.askvg.com/where-does-windows-store-temporary-files-and-how-to-change-temp-folder-location/ especially within AppData\Local)

Keep Smiling Smile

Posts 9057
LogosEmployee

Keep Smiling 4 Jesus :):
One item to check is your LibraryIndex folder permissions => https://www.logos.com/support/windows/error-writing-to-file (since writing postings for Library Indexing goes into LibraryIndex folder - personally would not use temporary work around for indexing since that changes AppData location).

That's unlikely to be the problem here, as temporary indexing data will already have been written (successfully) to that folder.

I'm not yet sure what is causing the problem, though.

Posts 9057
LogosEmployee

Nielsen Tomazini:

2018-04-13 11:48:38.7714 14 Error ApplicationUtility Failure during indexing; will reindex. ~IndexingException: IndexingException for LLS:HISTORY2 2012-02-15T20:05:05Z: Attempted to read past the end of the stream.

We're investigating this error.

Posts 9057
LogosEmployee

This looks like an indexing bug introduced in Logos 7.14; it will be fixed in the next release.

There is a workaround that will let indexing complete correctly, but it will make indexing take a lot longer and you'll need to remember to undo the workaround when the fix ships.

Posts 22
Christie Smit | Forum Activity | Replied: Sun, Apr 15 2018 12:17 PM

Is this also the cause for the error message when try searching: "Some search results may be missing or incorrect while your library is being updated"?

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Sun, Apr 15 2018 12:54 PM

Keep Smiling, I cannot thank you enough for your willingness to help. I really appreciate that.

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Sun, Apr 15 2018 12:57 PM

Thanks a lot Bradley for your explanations.
Do you have an idea how long should take for the fix be shipped? If it will take more than 2 weeks I would like to try the workaround. Can you explain here what I have to do?

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 19141
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sun, Apr 15 2018 1:42 PM

Christie Smit:

Is this also the cause for the error message when try searching: "Some search results may be missing or incorrect while your library is being updated"?

Indexer crashing can be one cause. Also have seen this message when Library index is being updated: adding new resource(s) so search results in those new resource(s) do not appear until indexing has completed.

Nielsen Tomazini:

Keep Smiling, I cannot thank you enough for your willingness to help. I really appreciate that.

Thankful for many friendly forum and Faithlife discussions: have learned a lot plus have a lot to learn.

+1 Yes Thankful for Bradley's investigation and explanation.

FYI: speculating 7.15 stable release on Mon 14 May, which could be preceded by a stable 7.14 service release (with indexer crash fix).

Keep Smiling Smile

Posts 22
Christie Smit | Forum Activity | Replied: Wed, Apr 18 2018 10:29 PM

Nielsen, is your indexing problem solved?

I experience the same problem.

Hope there is a solution!

Regards

Here are my Logos Log Files:

7077.Logos Log Files.zip

Posts 19141
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Apr 19 2018 3:49 AM

Christie Smit:
Here are my Logos Log Files:

LogosIndexer.log shows Logos 7.14.0.0024 on Windows 10 is currently indexing: 620 out of 861 resources indexed (with normal messages).

LogosIndexerCrash.txt has date of Mon 16 Apr 2018 while LogosIndexer.log has yesterday's date. Logos Indexer was restarted after crash on Mon 16 Apr 2018 so context for that crash was overwritten.

When Indexer crashes, please check modified dates of LogosIndexer.log and LogosIndexerCrash.txt => when they are the same, please zip up log files and attach them.

Keep Smiling Smile

Page 1 of 2 (36 items) 1 2 Next > | RSS