Page 1 of 1 (12 items)
This post has 11 Replies | 1 Follower

Posts 6
Joseph C. Coenen | Forum Activity | Posted: Wed, Apr 18 2018 2:50 PM

This is a re-post as I missed where to attach the logs on the first attempt.7610.LogosLogs.josephcoenen.20180418-173237.zip

I recently bought a new 2018 MacBook Pro running macOS High Sierra version 10.13.4.  After transferring my information from my old iMac, I then downloaded the Logos 7 software from logos.com.  I tried to launch the application, the sign in dialogue window came up, I entered my account email and password and hit the sign in button.  The "preparing library" message displayed for about 1-2 seconds.  Then a message box saying, "Logos quit unexpectedly" appeared.  I tried this several times, same result.  I called tech support, he suggested re-downloading the Logos 7 software, which I did, re-launched the app, same result.  The technician then sent me a link for troubleshooting problems on a Mac.

I tried Solution 1 by deleting the app and re-downloading the app.  Same result, quit unexpectedly.

I tried Solution 2 by verifying the folder permissions and re-launching the app.  Same result, quit unexpectedly.

I tried Solution 3 by checking the font book for corrupt fonts, none found.  Re-launched the app, same result, quit unexpectedly.

I have now tried Solution 4 by downloading the Logos Logging Utility app.  The archived logs are attached.

I must say I have been greatly disappointed with Logos software on my Mac computers.  I paid over $2000 to get the software I have but you developed it so much it no longer ran on my iMac.  Now I can't get it to work on my MacBook Pro.  Please help.

Posts 21928
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Apr 18 2018 3:39 PM

Hi Joseph - and welcome to the forums

Sorry to hear you are having problems.

Looking at the log you posted I see the following:

2018-04-18 17:32:20.5483 | INFO | 9 | StartupUtility | (Timed) Startup step: SubmitCredentials
2018-04-18 17:32:21.2405 | WARN | 9 | UserManager | Couldn't protect user's string Data protection failed.
2018-04-18 17:32:21.2405 | WARN | 9 | UserManager | Inner Exception is: Access to the path "/Users/josephcoenen/.config/.mono/keypairs/[1][98f3a7e3-0d6e-f432-8a18-e1144b53633f][-1].xml" is denied.
2018-04-18 17:32:21.2514 | WARN | 9 | UserManager | Couldn't protect user's string Data protection failed.
2018-04-18 17:32:21.2514 | WARN | 9 | UserManager | Inner Exception is: Access to the path "/Users/josephcoenen/.config/.mono/keypairs/[1][98f3a7e3-0d6e-f432-8a18-e1144b53633f][-1].xml" is denied.
2018-04-18 17:32:21.2529 | INFO | 9 | StartupUtility | (705ms) Startup step: SubmitCredentials
2018-04-18 17:32:21.2533 | INFO | 9 | StartupViewModel | Removing status 'LoggingIn'.
2018-04-18 17:32:21.2533 | INFO | 9 | StartupUtility | (8681ms) Startup step: LogIn
2018-04-18 17:32:21.2533 | INFO | 9 | StartupManager | Has valid credentials = True
2018-04-18 17:32:21.2533 | INFO | 9 | StartupManager | Should work online = True
2018-04-18 17:32:21.2543 | INFO | 9 | StartupUtility | (Timed) Startup step: GetIsApplicationVersionValid
2018-04-18 17:32:21.2612 | ERROR | 9 | LogosApplication | Can't update registry key 'Software\Logos4\Users\z1wgco09.ltt\Version' with assembly version: Access to the path "/Users/josephcoenen/.mono/registry/CurrentUser/software/logos4/users/z1wgco09.ltt/version/values.xml" is denied.
2018-04-18 17:32:21.2612 | INFO | 9 | StartupUtility | (7ms) Startup step: GetIsApplicationVersionValid
2018-04-18 17:32:21.2711 | ERROR | 9 | ApplicationUtility | Unhandled exception in async work System.AggregateException: One or more errors occurred. ---> System.UnauthorizedAccessException: Access to the path "/Users/josephcoenen/.mono/registry/CurrentUser/software/logos4/users/z1wgco09.ltt/version/values.xml" is denied.

I'm not a Mac user - although there are many users on this forum who are - but it looks like some OS-level file / folder access issue. Is that something you can check while waiting for someone familiar with the Mac environment to comment further?

Although I note from your comments above that you have checked folder permissions - so may need the Mac expert!

Graham

Posts 3153
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Apr 18 2018 4:19 PM

Joseph C. Coenen:
After transferring my information from my old iMa

Can you elaborate on this? Does this include the Logos4 folder from ~/Library/Application Support/Logos4?

Thanks!

 

Posts 17964
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Apr 18 2018 9:52 PM

Joseph C. Coenen:
I recently bought a new 2018 MacBook Pro running macOS High Sierra version 10.13.4.  After transferring my information from my old iMac, I then downloaded the Logos 7 software from logos.com.

Welcome Big Smile

Please elaborate about information transfer from old iMac. Suspect new MacBook Pro has same name account with different user id number, which is one cause for access issues to hidden folders:

  • /Users/josephcoenen/.config
  • /Users/josephcoenen/.mono

Please open Terminal application (inside Utilities folder within Applications) to run these commands:

  • id
  • ls -ldn ~/.*

Please copy the output from these commands and paste into forum reply. The first command, id , shows the User Id Number(Name) and Group Id Number(Name) for current user. The second command, ls -ldn ~/.* lists (ls) directory names beginning with a period (hidden) for current user with long format that includes user number and group number.

Faithlife support page for Mac Troubleshooting => https://www.logos.com/support/logos6/mac/crash lacks directory permission checking for two hidden folders used by Logos.

FYI: have transferred my information between several Mac models, which has sometimes needed redo due to surprise user id number change (that had adverse effects in many programs).

Keep Smiling Smile

Posts 6
Joseph C. Coenen | Forum Activity | Replied: Thu, Apr 19 2018 8:36 AM

Here is the output from the two commands:

JOSEPHs-MacBook-Pro:~ josephcoenen$ id

uid=502(josephcoenen) gid=20(staff) groups=20(staff),12(everyone),61(localaccounts),79(_appserverusr),80(admin),81(_appserveradm),98(_lpadmin),701(1),33(_appstore),100(_lpoperator),204(_developer),250(_analyticsusers),395(com.apple.access_ftp),398(com.apple.access_screensharing),399(com.apple.access_ssh)

JOSEPHs-MacBook-Pro:~ josephcoenen$ ls -ldn ~/.*

drwxr-xr-x@ 28 502  20    896 Apr 18 17:25 /Users/josephcoenen/.

drwxr-xr-x   6 0    80    192 Apr 19 09:33 /Users/josephcoenen/..

-r--------   1 502  20      7 Apr 18 15:43 /Users/josephcoenen/.CFUserTextEncoding

-rw-r--r--@  1 502  20  14340 Apr 19 08:35 /Users/josephcoenen/.DS_Store

drwxr-xr-x@  3 502  20     96 Feb 15  2010 /Users/josephcoenen/.DownloadManager

drwx------  10 502  20    320 Apr 19 11:05 /Users/josephcoenen/.Trash

-rw-------   1 502  20      0 May  6  2009 /Users/josephcoenen/.Xauthority

-rw-------   1 502  20    333 Apr 18 17:25 /Users/josephcoenen/.bash_history

drwx------   8 502  20    256 Apr 19 11:31 /Users/josephcoenen/.bash_sessions

drwxr-xr-x   3 502  20     96 Jan  7  2012 /Users/josephcoenen/.config

drwx------@  3 502  20     96 Jan 29  2010 /Users/josephcoenen/.cups

drwxr-xr-x  10 502  20    320 Apr 20  2011 /Users/josephcoenen/.dropbox

drwxr-xr-x  27 502  20    864 May  6  2009 /Users/josephcoenen/.fontconfig

-rw-------   1 502  20     35 Apr 19  2009 /Users/josephcoenen/.lesshst

drwxr-xr-x   3 502  20     96 Jan  7  2012 /Users/josephcoenen/.mono

drwxr-xr-x   3 502  20     96 Aug 26  2015 /Users/josephcoenen/.oracle_jre_usage

drwxr-xr-x   2 502  20     64 Apr 18 16:45 /Users/josephcoenen/.wapi

I confess I am ignorant in this area, please analyze and advise.  Thank you.

Posts 6
Joseph C. Coenen | Forum Activity | Replied: Thu, Apr 19 2018 8:37 AM

I did follow the suggestions from logos.com to check permissions.  Beyond that, I am ignorant in this area.  Thank you.

Posts 6
Joseph C. Coenen | Forum Activity | Replied: Thu, Apr 19 2018 8:40 AM

Sorry to say I don't know.  I was following the suggestions for trouble shooting from the Logos.com website.  I transferred my data using the Migration Application native to the new MacBook Pro and my source was a Time Machine backup.  Everything else was automatic, I did not pick and choose files.

Posts 17964
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Apr 19 2018 9:14 AM

Joseph C. Coenen:
Here is the output from the two commands:

The output showed ~/.config and ~/.mono folders have appropriate ownership and permissions: rwx = r(ead) w(rite) (e)x(ecute) that match my working Logos 7 on macOS 10.13.4 (for owner, group, and everyone). Hence, have not found cause for Access Denied errors.

Please open Terminal application (inside Utilities folder within Applications) to run these commands:

  • ls -lnRa ~/.config
  • ls -lnRa ~/.mono

Please copy the output from these commands and paste into forum reply. These two list (ls) commands show file and folder contents of ~/.config and ~/.mono folders. The command options are: -l (long) n (number for user & group) R (recursive folder listing with all files) a (include hidden folders)

Joseph C. Coenen:
I transferred my data using the Migration Application native to the new MacBook Pro and my source was a Time Machine backup.  Everything else was automatic, I did not pick and choose files.

Was the same user name chosen for Migration ?

FYI: Logos wiki => Quick Installation onto Multiple Macs includes a Time Machine caveat:

Caveat: if want to change user name, then Time Machine Duplication does not work because Time Machine cannot change the fully qualified path (includes user name) to Logos resource files, which is inside database file(s) used by Logos.

Keep Smiling Smile

Posts 17964
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Apr 19 2018 9:28 AM

Joseph C. Coenen:

I did follow the suggestions from logos.com to check permissions.  Beyond that, I am ignorant in this area.  Thank you.

Appreciate ignorance along with computers proving my ignorance many times. Hence my tendency for should work instead of will work.

My ignorance showed in this thread since my initial thought for Access Denied error was parent hidden folders. Thankful for God helping me remember troubleshooting technical details that have not been used for many months.

Keep Smiling Smile

Posts 6
Joseph C. Coenen | Forum Activity | Replied: Thu, Apr 19 2018 10:35 AM

After 40 minutes on the phone with Logos IT and over an hour with Apple IT, it turns out my permissions were incorrect (probably from the Time Machine import).  Ended up resetting user permissions from the Terminal window.  This solved the main problem of Logos app not running, it does run now, praise God!  It also solved some other issues of files I could not delete, etc.  Thank you everyone.

Posts 17964
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Apr 19 2018 11:26 AM

Joseph C. Coenen:
Ended up resetting user permissions from the Terminal window.  This solved the main problem of Logos app not running, it does run now, praise God!  It also solved some other issues of files I could not delete, etc.

+1 Yes Smiling Big Smile

Keep Smiling Smile

Posts 3153
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Apr 19 2018 3:59 PM

TimeMachine is not always a flawless process. I'm sorry you experienced that. Thanks for updating us on your progress though, Joseph.

 

Page 1 of 1 (12 items) | RSS