RefTagger no longer working on WP site

Page 1 of 1 (5 items)
This post has 4 Replies | 2 Followers

Posts 10
Lindsay Kennedy | Forum Activity | Posted: Thu, Jun 21 2018 3:58 PM

Hello, I've run into a dead end trying to fix RefTagger my friend's WP blog. It no longer works on any page/post. I'm hoping someone could point me in the right direction?

http://www.biblestudywithrandy.com/2018/03/3141/

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Thu, Jun 21 2018 4:19 PM

The reftagger script is never getting loaded. That's because the HTML generated by WordPress is corrupted (probably due to a bug in a plugin or theme).

More specifically, an <iframe> tag is opened and never closed (there's a closing </div> instead of an </iframe>). It's the iframe immediately after an Amazon Prime heading, which is a widget. You'll notice it's not just RefTagger that's not working, all the other widgets under this heading aren't working either (Recent Posts, GoodReads, etc.).

If you disable or correct the widget that's causing this, you should find everything back to normal.

Posts 10
Lindsay Kennedy | Forum Activity | Replied: Thu, Jun 21 2018 4:37 PM

Thank you! That's definitely fixed it. Thanks. I was stuck looking at plugins when I should have realized the widgets had some problems.

Posts 31
Matt Gubala | Forum Activity | Replied: Tue, Jun 26 2018 6:05 AM

being completely new to Wordpress, is this specific fix somthing to be applied repeatedly, or  has it been resolved?

https://blog.jn146.org/equality-with-god/ I am unable to notice what is "normal. TIA

Posts 21920
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Jun 26 2018 7:07 AM

Hi Matt

Everything looks fine on the site you mentioned - the issue on this thread was related to a particular Wordpress widget.

Are you experiencing any problems? If so, please start a new thread in this forum

Graham

Page 1 of 1 (5 items) | RSS