Can't install Logos 7 on Windows 10 - administrator priviledges error

Page 1 of 1 (5 items)
This post has 4 Replies | 0 Followers

Posts 2
Philip Rademaker | Forum Activity | Posted: Mon, Aug 20 2018 9:33 PM

Hi everyone,

I'm unable to install Logos 7 on my Windows 10 machine. Whenever I double click the installer I get the following error:

"The Selected user does not have sufficient priviledges to complete the setup. Please choose Administrator from the Run As... dialog.

I've tried trying to run the installer as Administrator and I get the same error.

Any ideas?



Posts 21918
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Aug 20 2018 10:49 PM

Hi Phil - and welcome to the forums

Sorry to hear you are having problems.

This error typically relates to an account permission or file permission problem - and it isnt recommended trying to run as Administrator to fix it.

See for a discussion of a similar sounding problem.

Not at all suggesting that the cause for the problem you are seeing is the same but as an indication of the sort of things to look for.

Some questions:

  • Is this a work machine or a personal one? Trying to explore whether there are any particular constraints on it
  • Have you successfully installed Logos on this before?
  • Have you recently added any third-party software that might affect file / folder / account setup?

And please try enabling diagnostic logging - use step four in and then post logs in a reply to this thread after trying the install


Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Tue, Aug 21 2018 3:14 AM

This support document may help:

But for more specific advice, please post your install logs, as Graham explains.

Posts 2
Philip Rademaker | Forum Activity | Replied: Sun, Aug 26 2018 5:00 PM

Hi Graham,

Thanks for your help.

I followed the suggestion to enable logging and was having trouble finding the Logos Log Files folder when I discovered that the shortcut to my "Documents" folder was pointing to a drive that was no longer installed in the system.

After fixing the shortcut I'm now able to install.


Posts 21918
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Aug 26 2018 10:35 PM

Hi Phil

Glad you have it working.

Thanks for posting back.


Page 1 of 1 (5 items) | RSS