Logos Security Update to Impact Logos 6, Logos 5, and Logos 4 Users

Page 1 of 3 (45 items) 1 2 3 Next >
This post has 44 Replies | 5 Followers

Posts 272
LogosEmployee
Glenn Airoldi (Faithlife) | Forum Activity | Posted: Mon, Oct 22 2018 12:10 PM

On November 7, 2018, we will deploy a security update to our servers to ensure compliance with current industry standards. This will impact users who are not running Logos version 7.

If you are running Logos 4, 5, or 6, update to Logos 7 for free now to ensure uninterrupted access to your software.

What  happens if I choose not to update to Logos 7?

If you are a Logos 7 user, you will not be impacted by this security update. If you are a Logos 4, 5, or 6 user and choose not to update, your software will continue to work, but in an unsupported, offline mode. Offline, you are not able to:

  • Log in to the application after you sign out

  • Download new content (free or purchased) to your software

  • Sync your software with other devices

  • Use features that require being online, like community highlights

  • View content pushed to your Home Page from Logos

If you are currently running Logos 4, 5, or 6, please update to Logos 7 by adding Logos 7 Basic to your account. If you are currently running Logos 7, no action is needed.

How to update:

  1. Add Logos 7 Basic to your account

  2. Restart your Logos software

Why are we making this update?

Faithlife takes the security of your data seriously. We continually improve security by following industry best practices and regulatory guidance. Behind the scenes, we deploy security updates through regular automatic updates to your Logos software. Because this security update may affect your Logos experience, we want to  ensure you take the opportunity to update to Logos 7.

Posts 272
LogosEmployee
Glenn Airoldi (Faithlife) | Forum Activity | Replied: Mon, Oct 22 2018 12:10 PM

More information about this update is posted here: https://www.logos.com/logos-7-update

Posts 2922
Forum MVP
Jacob Hantla | Forum Activity | Replied: Mon, Oct 22 2018 3:53 PM

As long as your system can support it, and almost all can, there is nothing to be lost with a free upgrade to a supported and more secure free version of Logos 7: https://www.logos.com/logos-7-update

Jacob Hantla
Pastor/Elder, Grace Bible Church
gbcaz.org

Posts 1106
Sean | Forum Activity | Replied: Mon, Oct 22 2018 4:53 PM

Dave Hooton:
The time frame is very limited given that the vendors you cite are not enforcing the update until early 2020, and that there are no "significant vulnerabilites" with the older TLS 1.0/1.1 i.e. you are forcing some users to upgrade their computers within 2 weeks!

Logos 7 is close enough to 6 (too close, to be honest) that there's no point in not upgrading from 6 to 7. I would imagine, however, that there are people stuck on older computers running 4 or 5 who might be distressed by this sudden change.

Posts 10178
Denise | Forum Activity | Replied: Mon, Oct 22 2018 5:54 PM

Gee ... Libby-ites got 2 extra years, after staff tried to kill her. I tried to show her all the passages on forgiveness.


Posts 8015
LogosEmployee

Sean:
I would imagine, however, that there are people stuck on older computers running 4 or 5 who might be distressed by this sudden change.

I imagine this is true.

However, Logos 4 and 5 have been unsupported for years (https://community.logos.com/forums/t/80475.aspxhttps://community.logos.com/forums/t/113509.aspx) and our software support lifecycle article (https://www.logos.com/support/free-support) has clearly warned that “Web services that are only used by Unsupported versions may be discontinued without notice.” 

In addition, Windows XP and Vista have been unsupported by Microsoft for 2+ years, which means no security updates. Running any kind of software that connects to the Internet on an unpatched computer is dangerous and I would strongly recommend against it.   

Posts 3054
SineNomine | Forum Activity | Replied: Sun, Oct 28 2018 7:59 AM

Affected users of pre-7 versions of Verbum should get their free update here.

Posts 1
Merle Warnsholz | Forum Activity | Replied: Wed, Nov 7 2018 8:05 AM

I am a Logos 6 user, and while attempting to install the free update to Logos 7 I received a message asking me to see if I had access to the following file - C:\Users\Owner\AppData\Local\Logos\Pending\nl\Libronix.DigitalLibrary.resources.dll.

I cannot find this file on my machine, and after cancelling out of the update, I can no longer get into my Logos product.  Can I receive some assistance to resolve this issue?

Thanks - Pastor Merle Warnsholz

Posts 4645
Forum MVP
Mike Binks | Forum Activity | Replied: Wed, Nov 7 2018 9:07 AM

Greetings Merle

Welcome to the forum. I hope we can help you out. Logos has moved on a good deal since version 6.

You may find there is a bit of a learning curve when you install the latest version but you are always welcome here and welcome to ask any questions about how it is best used.

Why not try clicking on this link to the lates version and downloading the file afresh - it doesn't take long and should give you new start.

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Wed, Nov 7 2018 9:10 AM

Merle Warnsholz:
I am a Logos 6 user, and while attempting to install the free update to Logos 7 I received a message asking me to see if I had access to the following file - C:\Users\Owner\AppData\Local\Logos\Pending\nl\Libronix.DigitalLibrary.resources.dll.

Hi Merle,

You have two options:

  1. You could uninstall Logos and re-install it — but you'd have to download and re-index all your resources again.
  2. Or you could:

The link to download Logos 7 is here: https://www.logos.com/install-logos-7 

Posts 1
Gary Devlin | Forum Activity | Replied: Wed, Nov 7 2018 2:01 PM

I have version 7.13. The warning refers to 7.18. I've tried to update. restart. check version. still the same at 7.13. Will my hundreds of dollars  worth of software be unusable? or not updatable? I hope you have not gone over to the QuickBooks camp of requiring money every 3 years.

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Nov 7 2018 2:09 PM

Gary Devlin:

I have version 7.13. The warning refers to 7.18. I've tried to update. restart. check version. still the same at 7.13. Will my hundreds of dollars  worth of software be unusable? or not updatable? I hope you have not gone over to the QuickBooks camp of requiring money every 3 years.

Gary,

What OS and what version of the OS are you running?

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Wed, Nov 7 2018 2:09 PM

Gary Devlin:

I have version 7.13. The warning refers to 7.18. I've tried to update. restart. check version. still the same at 7.13. Will my hundreds of dollars  worth of software be unusable? or not updatable? I hope you have not gone over to the QuickBooks camp of requiring money every 3 years.

You’ll need to manually download the update (for free): https://www.logos.com/install-logos-7

Posts 2635
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Nov 7 2018 2:24 PM

Philana R. Crouch:

Gary Devlin:

I have version 7.13. The warning refers to 7.18. I've tried to update. restart. check version. still the same at 7.13. Will my hundreds of dollars  worth of software be unusable? or not updatable? I hope you have not gone over to the QuickBooks camp of requiring money every 3 years.

Gary,

What OS and what version of the OS are you running?

Gary,

Can you also let us know what your hardware is like? This will let us know if your system is able to update the OS if needed.

Posts 2
LSS Office | Forum Activity | Replied: Tue, Dec 11 2018 8:20 PM

This all sounds easy enough, but both of my Macbook Pros are running OS X 10.9 (Mavericks) because one is older and the other had issues upgrading to 10.10 and 10.11 (battery life completely tanked).  Logos 7 does not run in Mavericks.  What am I supposed to do to continue being able to use the software that we paid close to $1000 (for the package) to use?

Thank you,

James

Posts 9090
Forum MVP
Mark Smith | Forum Activity | Replied: Tue, Dec 11 2018 9:15 PM

LSS Office:
What am I supposed to do to continue being able to use the software that we paid close to $1000 (for the package) to use?

Here is the option you have:

My computer does not meet the requirements to run Logos 7, what should I do?

You will need to upgrade your computer to Windows 7 SP1 or Mac OS 10.11. Or, you can access Logos through your browser by using the web app and mobile apps.

The other option is:

What will happen if I don’t update?

If you are still using Logos 4, 5, or 6 on December 10, 2018, your software will have limited functionality and will only work in an unsupported, offline mode. In offline mode, you are not able to:

  • Log in to the application after you sign out
  • Download new content (free or purchased) to your software
  • Sync your documents and settings with other devices, such as your tablet or smartphone
  • Use features that require being online, like Community Notes and Popular Highlights.
  • View content pushed to your Home Page from Logos

(You can find this here.)

The new security protocols (which Faithlife didn't invent and is only responding to) are what is driving this. Perhaps they could have delayed implementing this for a few more months, but eventually they were going to have to make this change and you (and others) were going to be stuck with hardware that won't work with L7.

The web app is pretty good. I don't know if you've tried it, but you might, and see how much functionality you can retain.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 17963
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Dec 12 2018 12:03 AM

LSS Office:
Logos 7 does not run in Mavericks.  What am I supposed to do to continue being able to use the software that we paid close to $1000 (for the package) to use?

Welcome Big Smile

Suggest changing Logos 6 Program Setting for Use Internet to No (avoid network timeout errors) so can continue using Logos 6 offline with substantial capabilities (albeit cannot sync between devices). Logos Wiki => Logos Release History shows Logos 6.14 SR-5 was released on 5 Jun 2017, which was the last supported release for OS X 10.9 Mavericks. Noticed last Apple security update for OS X 10.9 Mavericks was 18 July 2016 while initial public release was 22 Oct 2013 so has been superseded by five newer operating system releases from Apple (free on supported hardware)

Currently OS X 10.11 El Capitan is the minimum Mac operating system that can securely connect to Faithlife servers using Logos 7.18 or newer.

Faithlife is currently supporting four Mac operating system releases: OS X 10.11 El Capitan. macOS 10.12 Sierra, macOS 10.13 High Sierra, and macOS 10.14 Mojave so uninformed user speculation is an announcement about minimum supported Mac operating system changing next year (along with Apple releasing macOS 10.15 next fall). Noticed last Apple security update for OS X 10.11 El Capitan was 9 July 2018. Newer macOS 10.12 Sierra and macOS 10.13 High Sierra had security updates on 5 Dec 2018 while macOS 10.14 Mojave had a security update on 10 Dec 2018. Concur with thread => ANNOUNCE: Faithlife ending Logos 6.14 support on June 12, 2017 suggestion for free macOS 10.12 Sierra upgrade (or newer if have supported hardware), especially when connecting Mac to internet.

Apple offers refurbished Mac models => https://www.apple.com/shop/refurbished/mac

Keep Smiling Smile

Posts 6410
DAL | Forum Activity | Replied: Wed, Dec 12 2018 7:45 AM

You mean people still use Logos 4? 😂😜 Sorry I had to get it out of my system 👍😁👌 You would think they would at least upgrade to the free version of the latest software.

Like Libronix, it sounds like an old technotronic band from the 80’s 😂

DAL

Posts 10178
Denise | Forum Activity | Replied: Wed, Dec 12 2018 8:05 AM

DAL:

You mean people still use Logos 4? 😂😜 Sorry I had to get it out of my system 👍😁👌 You would think they would at least upgrade to the free version of the latest software.

Like Libronix, it sounds like an old technotronic band from the 80’s 😂

DAL

Wash your mouth out, Mr DAL!  Libby may never forgive you. (Software can't be Christian, so they don't have to count up to 7 x 7.)

But actually you illustrate the minus of digital books. Not only do you have to refresh your computer constantly (older computers can't run newer Logos's), but you also must put up with the really neato ideas your software company dreams up and fails to implement. (Well, gee, it they wrote good software, they'd never ship!! .... That was Libby.)

I laughed when Bradley warned ... you MUST update sometime. We won't support you in a few more months!!  It sounded like a mob warning. Pay up mister, or suffer the consequences!

Two interesting factoids arrived in the news in the last few days. One is that people are holding on to their cars longer, and longer. And people are holding onto Apple products longer and longer. 

Neato is for the news people and Logos forumites.


Posts 650
Kiyah | Forum Activity | Replied: Wed, Dec 12 2018 8:28 AM

Denise:

(Software can't be Christian, so they don't have to count up to 7 x 7.)

Wait...you mean my Logos Bible Software isn't Christian??? I feel duped. Sad

Page 1 of 3 (45 items) 1 2 3 Next > | RSS