Problem copying Greek text into Wordperfect

Page 1 of 1 (12 items)
This post has 11 Replies | 2 Followers

Posts 27
M Luper | Forum Activity | Posted: Fri, May 21 2010 7:56 AM

I use WordPerfect (ver. X4), and am unable to copy and paste Greek text into a document. I am able to paste Greek text fine into MS Word, but when I try to paste into WP nothing happens. I have also tried using the ctrl+alt+B command which has an option to copy for WordPerfect. While this did copy the Greek text, it did so with no spaces between words and the font size is not uniform in the document. I would appreciate any help I could get in resolving this problem.

Thanks.

MLuper

Posts 28
Bayard Bastedo | Forum Activity | Replied: Fri, May 21 2010 8:28 AM

I wonder if your problem is that WordPerfect can't handle Unicode. If you can use a non-Unicode font, perhaps it'll copy.

Bayard Bastedo

Posts 27
M Luper | Forum Activity | Replied: Fri, May 21 2010 9:15 AM

WorPerfect can handle Unicode. In fact, one of the options WP gives for pasting is Unicode. I have tried to paste using the Unicode option but this still doesn't work.

Posts 582
Gary O'Neal | Forum Activity | Replied: Fri, May 21 2010 3:41 PM

Could it have anything to do with Logos trying to carry over the citation? I have WP X3 and it copies short sections of text fine. However, when I try to copy larger sections it doesn't work. Logos doesn't include the citation reference when you only copy a small amount of text --

That's what it was -- I just did a quick check. When you turn off the copy citation option, it went through fine.

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 27
M Luper | Forum Activity | Replied: Fri, May 21 2010 6:57 PM

I tried turning off the citation option and it copies some of the verse but still leaves off some letters. For example,  in Heb. 12:21, the fourth word (impf of eimi), when I copy it to WP the first letter, eta, is replaced with a question mark. Here is what I get:  ?ν

Posts 3765
Floyd Johnson | Forum Activity | Replied: Fri, May 21 2010 7:54 PM

After pasting the text, highlight all of the text and change it to Gentium.  I have to do this in MS OneNote - it may work similarly in WP.

Blessings,
Floyd

Pastor-Patrick.blogspot.com

Posts 27
M Luper | Forum Activity | Replied: Fri, May 21 2010 8:09 PM

Tried it, but all it does is remove the character with the question mark altogether.

Posts 3765
Floyd Johnson | Forum Activity | Replied: Fri, May 21 2010 8:14 PM

M Luper:
Tried it, but all it does is remove the character with the question mark altogether.

Sorry - in MS OneNote all the accents, etc., are converted.  Thought it was worth a try.  You might try some of the other available Greek fonts to see if any of them translate the odd characters.

Blessings,
Floyd

Pastor-Patrick.blogspot.com

Posts 27
M Luper | Forum Activity | Replied: Fri, May 21 2010 8:21 PM

I appreciate the suggestions.

Thanks!!!

Posts 141
Ken Guenther | Forum Activity | Replied: Fri, May 21 2010 9:06 PM

I have the same problems with copying and pasting Greek text into WordPerfect X3, but I found that if you use the "copy verses to HTML editor", the Greek text appears in WP with spaces between words.

edit: Sorry, I spoke too soon.   Characters are still missing even when you use the HTML editor option.

Posts 582
Gary O'Neal | Forum Activity | Replied: Sat, May 22 2010 5:11 AM

I believe that is a Unicode problem in WP. WP has just started adding Unicode support and it still does not work like it should. There are some characters with accents that I haven't been able to get it to display. As great a word processor as WP is, I seldom use it any more for that reason.

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 11
John P Richardson | Forum Activity | Replied: Tue, Jul 20 2010 10:36 AM

I have come rather late to this, but can tell you how to copy Greek Text into Wordperfect with Libronix. Having just decided to try out Logos 4, though, the same workaround doesn't seem to apply.

In Libronix, you can view the Greek text in the reader with, eg, Gentium. However in the copy dialogue options you need to create a 'copy' of the format and then change the text to Graecall.

You can then copy and paste using the Copy dialogue box. It still won't work trying a 'cut and paste' from the Libronix reader itself, but this will give you all the characters and the pointing if you copy, and then paste using Control-V (or right click and paste) in the Wordperfect window.

The trouble with Logos 4 is that it doesn't give you an option either for viewing using Graecall or copying using Graecall.

Page 1 of 1 (12 items) | RSS