Bug: Notes tool Add Anchor (selected text) adds wrong selection

Page 1 of 1 (8 items)
This post has 7 Replies | 0 Followers

Posts 3164
Forum MVP
PetahChristian | Forum Activity | Posted: Sat, Nov 3 2018 4:15 PM

I selected text from DOT:P, went to Add Anchor -> selected text, but yet it added an anchor to the LEB, not the text I had just selected.

I had to deselect the DOT:P text, then reselect it, before the correct selection was added as an anchor.

This is not the first time today that the Notes tool has added an anchor from the LEB, rather then the text selection I made in a different reference.

Logos 8.0 (8.0.0.0562) on macOS 10.14.1 (18B75)

Posts 3164
Forum MVP
PetahChristian | Forum Activity | Replied: Sat, Nov 3 2018 4:35 PM

The issue happened again (and is reproducible if I delete the incorrect LEB anchor that it adds).

I had just made a text selection from ABD, but I end up with an anchor to LEB:

It's almost behaving like the Selected text radio button isn't the active button (even though the reference box is blank).

In the interval between the original post and this post, I have not made any selection in the LEB. I'm not sure why the software is choosing to anchor to the LEB, instead of the active resource's just-selected text.

EDIT: Come to think of it, notes not highlighting the recent selection would also occasionally happen in L7, and I'd have to deselect-reselect text before it worked properly.

Posts 21704
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Nov 4 2018 12:14 AM

Just to say I've tried reproducing this - adding an anchor to a portion of text selected in ABD - and it works correctly on Windows.

Posts 24701
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Nov 4 2018 1:55 AM

This is similar to a bug I reported earlier for Windows, and that was fixed. So I'm unable to reproduce your (Mac) problem.

Dave
===

Windows & Android

Posts 3164
Forum MVP
PetahChristian | Forum Activity | Replied: Sun, Nov 4 2018 3:39 AM

Graham Criddle:

Just to say I've tried reproducing this - adding an anchor to a portion of text selected in ABD - and it works correctly on Windows.

What I’ve noticed is that it generally works (at least 95% of the time), but once it misses focus on a text selection, it won’t work until I reselect the text.

I don’t know if it is the same bug from L7, but occasionally I would make a text selection in L7, then press a highlight shortcut key, but no highlight would appear. I would have to reselect the text, before I could highlight it.

Posts 3164
Forum MVP
PetahChristian | Forum Activity | Replied: Mon, Nov 5 2018 9:34 AM

Can we open a case for this, please, if one isn't already open? Thank you!

Posts 408
LogosEmployee
Bryan Smith | Forum Activity | Replied: Wed, Nov 7 2018 9:19 AM

Sorry for the delayed response on this! I have filed a bug and will try to investigate soon.

Posts 3164
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Nov 7 2018 9:25 AM

Thanks, Bryan!

Page 1 of 1 (8 items) | RSS