Bug? Notes different hover behavior from single-word selected text anchors

Page 1 of 1 (8 items)
This post has 7 Replies | 0 Followers

Posts 3174
Forum MVP
PetahChristian | Forum Activity | Posted: Sun, Nov 4 2018 3:43 PM

If I hover over a Notes anchor for multi-word selected text, the popup displays the text from the resource, starting at the selection.

However, if I hover over a Notes anchor for a single word of selected text, I see information about the resource, rather than the text from the resource.

Note that this popup issue also occurs if the selected text is a random word in the middle of a paragraph. So it's not specific to a selection which matches a headword.

Logos 8.0 (8.0.0.0562) on macOS 10.14.1 (18B75)

Posts 9914
Forum MVP
NB.Mick | Forum Activity | Replied: Mon, Nov 5 2018 12:08 AM

PetahChristian:
If I hover over a Notes anchor for multi-word selected text, the popup displays the text from the resource, starting at the selection.

Seems I can't reproduce that (same Logos version but on Windows 10). I always see the resource information - maybe this is for selected text that is too long to fit into the note display itself (but for me, the text goes into the anchor and just scrolls on, even a list of all popes)?

Running Logos 8 latest beta version on Win 10

Posts 3174
Forum MVP
PetahChristian | Forum Activity | Replied: Mon, Nov 5 2018 9:32 AM

NB.Mick:
Seems I can't reproduce that (same Logos version but on Windows 10). I always see the resource information

Hmm, I'm not sure what the devs intended, but I'd like to request that it would be to see the text, please.

  • First, the text is the more significant part of the anchor. We can already see which resource it is from, from the anchor as well as the bottom right of the popup.
  • Second, longer text selections shown in the note tool are often truncated. The popup lets you see much more of the text than the note tool displays.
  • Third, when highlighting lexicons, I sometimes only highlight the root/lemma (instead of the entire entry), but rely on the popup to show me more of the text.

If the popup is only meant to show the resource, it would break existing behavior that we have relied on.

Thanks for your consideration of this request, as you improve the anchor popup.

Posts 3174
Forum MVP
PetahChristian | Forum Activity | Replied: Mon, Nov 12 2018 10:11 AM

Still hoping for some feedback from FL as to how this is meant to work, as well as opening a case to resolve the inconsistent hover details.

Posts 408
LogosEmployee
Bryan Smith | Forum Activity | Replied: Wed, Nov 14 2018 10:34 AM

Thanks, Petah. I'll look into it. I would also expect to see the tooltip always reflecting the selection.

Posts 3174
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Nov 14 2018 11:57 AM

Thank you, Bryan.

Posts 408
LogosEmployee
Bryan Smith | Forum Activity | Replied: Wed, Nov 14 2018 2:12 PM

Does this problem only occur on anchors you've just added, or do you also see it when viewing older anchors/notes? If the latter, would you mind posting your log files?

Posts 3174
Forum MVP
PetahChristian | Forum Activity | Replied: Wed, Nov 14 2018 2:51 PM

Bryan Smiþ:
Does this problem only occur on anchors you've just added, or do you also see it when viewing older anchors/notes?

While running Logos 8.0 SR-1 (8.0.0.0583) on macOS 10.14.1 (18B75), I checked tooltips for ~20 old note (single-word) anchors that had imported, and they all showed the text, as expected.

During that time, the application update had downloaded, so I restarted Logos then went back to look at the previously reported problematic notes. They're now all displaying text instead of resource information. 8.0 SR-2 (8.0.0.0591) seems to have fixed this issue!

Page 1 of 1 (8 items) | RSS