Can't get to upgrade to 8

Page 1 of 1 (6 items)
This post has 5 Replies | 2 Followers

Posts 43
David James | Forum Activity | Posted: Mon, Nov 5 2018 8:09 AM

I'm a subscriber - and successfully purchased it for $0 - but the link in the order gives me a 404 error and I'm not receiving an email with the link.

I'm currently out of the country - could that be the problem?

Thanks,

Dave

Posts 269
LogosEmployee
Celeste Fiorillo | Forum Activity | Replied: Mon, Nov 5 2018 8:18 AM

Everything looks correct on our end, so if you restart the software it should update you to Logos 8. If not, you can manually install it here: https://www.logos.com/install

David James:
the link in the order gives me a 404 error

Can you clarify for me which page you're referring to so I can look into this further? Are you on the order summary page that you see after you place your order?

Posts 1755
Forum MVP
Levi Durfey | Forum Activity | Replied: Mon, Nov 5 2018 8:19 AM

Hi David,

What about trying to download from here: https://www.logos.com/install

Also, you should remove your email address. Spam-bots could pick it up off from the forums.

Posts 2574
Jan Krohn | Forum Activity | Replied: Mon, Nov 5 2018 8:25 AM

The problem seems to be with the manual download.

I've already updated through the software, so it's not an issue for me. Just pointing out where something is wrong:

Past IT Consultant. Past Mission Worker. Entrepreneur. Future Seminary Student.
Why Amazon sucks: Full background story of my legal dispute with the online giant

Posts 43
David James | Forum Activity | Replied: Mon, Nov 5 2018 8:27 AM

Yes - that is where I was - and I didn't receive a confirmation email.

I tried it last night, as well - same problem.

I'm currently in Israel - and sometimes websites with software installations don't like foreign IPs

Posts 43
David James | Forum Activity | Replied: Mon, Nov 5 2018 8:29 AM

I had exited and restarted Logos 7 before and it didn't update - this time it did. Go figure.

Thanks!

Page 1 of 1 (6 items) | RSS