Logos. I give up.

Page 1 of 3 (50 items) 1 2 3 Next >
This post has 49 Replies | 5 Followers

Posts 142
David Medina | Forum Activity | Posted: Fri, Jan 25 2019 8:35 AM

I had high hopes on Logos 8, especially with its bragging about how much faster and better it was. Any task in Logos is painful. Constantly beach ball. Yes, I am fuming. How would you expect to feel after paying thousands of dollars for something you cannot use?

From what I gather from those who defend Logos, it seems like in order to run Logos in any acceptable manner you will need to spend thousands of dollars upgrading to the latest computer every time a new version of Logos comes out. That is just ridiculous, especially after Logos claim the software to be faster without any kind of small print.

If you claim in run faster if only you get the latest and greatest Mac, then say so. Then we can make an educated decision. But do not claim that it just works faster when that is not really true. Let face it, Logos code is poorly written. That is unacceptable.

My computer should be more than capable to run Logos. I edit 4K video all the time and run programs like Photoshop with heaps of layers creating files really large. Yet whenever I try to run Logos it becomes so slow that I just give up. It is NOT the computer but the software. Logos, why can you get it right?

My only regret is that I cannot get any of the thousands of dollars I have spent on Logos so I can get a program that actually works well.

To those considering buying Logos, DO NOT. Unless you need logos to test and train your patience, DO NOT get Logos. Save yourselves time, trouble, and money and get yourself something that actually works. 

Posts 934
John Goodman | Forum Activity | Replied: Fri, Jan 25 2019 8:46 AM

Somethings going on here. I use logos on an old mac with no problem quite often. Try talking it over with support? Alternatively post some screen shots or a short vid and we’re happy to se if we can spot the problem. 

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 9854
Denise | Forum Activity | Replied: Fri, Jan 25 2019 8:48 AM

David, just scanning backwards, you seem like you enjoyed Logos and performance until the last major update? (narrowing down your frustration)

Don't bite me ... I stayed on L7!


Posts 6062
DAL | Forum Activity | Replied: Fri, Jan 25 2019 8:56 AM

My Windows 8, turned Windows 10 with a free upgrade when I bought it about 4 years ago runs L8 just fine. My library is a good size, but it’s still ok. I will definitely buy a new laptop with an SSD to make it faster, but even though it’s old, L8 runs faster than L7 for sure.

You might want to check your hardware or call tech support 👍😁👌

DAL

Posts 142
David Medina | Forum Activity | Replied: Fri, Jan 25 2019 8:59 AM

I would not say enjoy but rather tolerated. Logos has always been a slow and clumsy app but at least in 7 it seems to work a little better for me. I upgraded to Logos * because we were told that the experience it would be much better than in Logos 7.  My experience has been miserable since then. I literally fear and hate to open Logos 8. 

Posts 142
David Medina | Forum Activity | Replied: Fri, Jan 25 2019 9:03 AM

Thanks.

I have check my hardware several times. This is my work computer where I spend countless hours editing photos and videos without any major issues. I am a heavy photoshop users dealing with huge files. 

Thinking that something runs fine is also relative if you don't have a point of reference. Because of Logos slowensess I had to buy Accordance in order to do my Bible study research and I have no issues. Logos is painfully slow compared to Accordance which is literally instantaneous. I just wish I didn't had to buy a additional software to do what I paid to do with Logos.

Posts 142
David Medina | Forum Activity | Replied: Fri, Jan 25 2019 9:03 AM

I will John Goodman.

Posts 1398
Wild Eagle | Forum Activity | Replied: Fri, Jan 25 2019 9:18 AM

I use Win 10, i7 2nd generation with SSD and have no issues with Logos. I remember there were some issues with other people previously with previous versions when they used excessively filters or collections (can't recall exactly which one, or both) and it affected their Logos speed. Anyway, I would call to CS

"No man is greater than his prayer life. The pastor who is not praying is playing; the people who are not praying are straying." Leonard Ravenhill 

Posts 34

No problem here, using a 5 year-old dell notebook, old I5 processor, 8gb ram, and 240GB ssd. And Logos 8 (for me) is significantly faster than logos 7

Posts 79
MWW | Forum Activity | Replied: Fri, Jan 25 2019 10:51 AM

Sorry to hear of your frustration. I have a 6 year old Macbook Pro and find Logos 8 to be very speedy. I just did a search for "progressive dispensationalism" in all my resources (4,561 resources), 361 results in 134 articles came back in under 1 second. I am very happy with that. 

Posts 473
Richard Villanueva | Forum Activity | Replied: Fri, Jan 25 2019 11:09 AM

David Medina:
Logos has always been a slow and clumsy app but at least in 7 it seems to work a little better for me. I upgraded to Logos * because we were told that the experience it would be much better than in Logos 7.  My experience has been miserable since then. I literally fear and hate to open Logos 8. 

If this is your experience, maybe a call to Customer Service would be good for you to get a refund, that way you can go from "miserable" to "tolerable."  Not a best case scenario, but at least asking for a refund would put you back to having not spent the extra cash. Not sure about your 30 days to refund, but worth a try since I believe the FL guys usually try to make things right by their customers (in my experience.) 

FWIW - I am running L8 on a  2012, 13in MacBook Pro, 2.5 i5 with 8GB RAM and a 480GB SSD running Mojave with 7,800 resources in my library (maybe Perseus was not the best choice...) I don't have any challenges with speed on mine (unless I am used to it "running slow" - ha!) I'm don't remember reading your specs and maybe it is irrelevant to the issue at hand. Maybe it presents a helpful comparison?

MBPro'12 / i5 / 8GB // 3.0 Scholars (Purple) / L6 & L7 Platinum, M&E Platinum, Anglican Bronze, P&C Silver / L8 Silver

Posts 1324
Ben | Forum Activity | Replied: Fri, Jan 25 2019 11:10 AM

I run Logos on the latest Mojave build, on a 2013 MB Pro with a 512Gb SSD and 8Gb RAM, connected to an external 4k 32" monitor.

I almost never see beachballs; while I'm extremely competent with my gear and have been with Logos since 2001 (and Bibleworks as well), I'm not a Logos power user.

I suspect there's something in the setup causing a slowdown. Perhaps complex visual filters? 

"The whole modern world has divided itself into Conservatives and Progressives. The business of Progressives is to go on making mistakes. The business of Conservatives is to prevent mistakes from being corrected."- G.K. Chesterton

Posts 43
phrogger | Forum Activity | Replied: Fri, Jan 25 2019 11:13 AM

The first thing that people think of when people talk about how slow Logos is, is searches. When I mean slow, I mean the scrolling stutters, double clicks wait a second to respond, menu button presses lag, right button presses don't respond because it's thinking about something else, annoying pop-ups cover half the screen and won't disappear immediately when they're told to.

Posts 934
John Goodman | Forum Activity | Replied: Fri, Jan 25 2019 11:19 AM

Given the problems you describe I don‘t doubt your computer is ok. After all you are clearly a power user and would recognise an obvious problem. Having used Logos for a long time I discovered that  there are certain brilliant features that can cause awfully slow behaviour e.g. large word lists guides in a link set and others. Even with nothing ’wrong’. 

Other possibilities are a corrupted index etc. 

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 43
phrogger | Forum Activity | Replied: Fri, Jan 25 2019 11:20 AM

David,

DO NOT UPGRADE TO THAT LATEST COMPUTER!

I did just that, spent $2k mostly because I thought a new computer would be fast enough to run Logos — it's not. 2018 MacBook Pro Touchbar Quadcore 16GB is not fast enough to run L8 well.

By "not fast enough," I mean Logos runs slower than any other app on my new MacBook. Painfully slow. Constantly-have-to-switch-over-to-Accordance-running-on-the-side slow.

Check out my version of what you said, here: https://community.logos.com/forums/t/178013.aspx

Posts 934
John Goodman | Forum Activity | Replied: Fri, Jan 25 2019 11:21 AM

Given the problems you describe I don‘t doubt your computer is ok. After all you are clearly a power user and would recognise an obvious problem. Having used Logos for a long time I discovered that  there are certain brilliant features that can cause awfully slow behaviour e.g. large word lists guides in a link set and others. Even with nothing ’wrong’. 

Other possibilities are a corrupted index etc. Logos is much faster now I’m concerned you may miss out because of a solvable issue. 

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 473
Richard Villanueva | Forum Activity | Replied: Fri, Jan 25 2019 11:27 AM

John Goodman:
Other possibilities are a corrupted index etc.

This has solved my problems before - while it is tedious to re-index, I had a corrupted index that caused me trouble. It went away after a lengthy total re-index.  My machine does slow down during indexes as well, so if that is consistently happening due to updates or whatever, that could be a problem, possibly?

MBPro'12 / i5 / 8GB // 3.0 Scholars (Purple) / L6 & L7 Platinum, M&E Platinum, Anglican Bronze, P&C Silver / L8 Silver

Posts 934
John Goodman | Forum Activity | Replied: Fri, Jan 25 2019 11:28 AM

Sorry, I'm not sure how I ended up with a duplicate post... phone issues...

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 241
Jonathan Bradley | Forum Activity | Replied: Fri, Jan 25 2019 11:32 AM

phrogger:

David,

DO NOT UPGRADE TO THAT LATEST COMPUTER!

I did just that, spent $2k mostly because I thought a new computer would be fast enough to run Logos — it's not. 2018 MacBook Pro Touchbar Quadcore 16GB is not fast enough to run L8 well.

By "not fast enough," I mean Logos runs slower than any other app on my new MacBook. Painfully slow. Constantly-have-to-switch-over-to-Accordance-running-on-the-side slow.

Check out my version of what you said, here: https://community.logos.com/forums/t/178013.aspx

Wow, there must be something wrong, like a corrupted index or something. I have a 2015 model MacBook Pro with 8GB ram and a 128GB SSD drive, and Logos 8 runs incredibly fast for me. I'm sure it could run faster, but I've never used it on a better computer, so I wouldn't know. For me, it runs much faster than 7 did, especially with using notes. 

Posts 142
David Medina | Forum Activity | Replied: Fri, Jan 25 2019 1:14 PM

Thanks. I do agree, that is why I have all those features off. I always open to the possibility that there may be something corrupt with the computer itself. 

Let me give you an example. Whenever I think I may want to use Logos 8 I have to launch the program and literally go to lunch to allow enough time for the app to load up and get to a point that can be usable. So I cannot use it as soon as the app start. Another issue is that is that it has to index frequently which I know that it affects the performance.

No other app in the Computer has issues like Logos, that is why I am not incline to consider the computer to be the issue. 

I am running Logos 8 on a iMac 27 inch late 2013 with a i5 3.2 ghz processor with 24 GB of memory. It has the HD that comes with it (no  SSD). That should be more than enough.

But I will try to reach out to support.

Page 1 of 3 (50 items) 1 2 3 Next > | RSS