Android App Crash Requiring Reinstall

Page 1 of 1 (10 items)
This post has 9 Replies | 2 Followers

Posts 5
Richard Hodges | Forum Activity | Posted: Thu, Jan 31 2019 12:24 PM

I posted this as a response to another post but I thought this could merit its own post so apologies for double posting, but this one has more information.

Since the latest release which I installed today (January 31, 2019) I have found that the app is terribly unstable and easily gets into a state where it starts up then crashes before I can do anything.

I've reinstalled a number of times and the same thing happens.

The steps I take that cause this are as follows;

  • Launch a freshly installed Logos for Android and log in
  • Download ESV Bible and ESV Reformation Study Bible
  • Close the sample resource windows  that are open and open an ESV Bible
  • Go to the resource windows, split the window I have open and, in the bottom one, open an ESV Reformation Study Bible
  • I link these resource windows and go back to the page
  • So far so good....
  • I tap on Home, find my Reading Plan and tap Read Ahead
  • The ESV pane of in my reading window goes to Genesis 34, the lower pane shows a spinning circle to suggest it's trying to find the relevant page and boom, crashes out to the Launcher

  • When I try and relaunch the Logos app, it shows two spinning circles for a little while and then crashes out

I'm going to be trying other combinations of events and books to see if they are affected by this but I've tried installations from Google Play and Amazon and both do this.

This also happens when I try and launch the Audio version of the ESV. Crashes out when I start and then it won't start again without a reinstall (or a storage clearance).

Really frustrating. Does anybody have a workaround?

Posts 211
Kevin | Forum Activity | Replied: Thu, Jan 31 2019 12:42 PM

Can replicate opening Unseen Realm Audio....crash out, then on reopening, the app trys to reopen the audio, so crashes again....rinse and repeat.

Disabling wifi and then renaming MainStorage->Android-Data->Com.Logos.AndroidLogos->cache to something, then reopening the app allowed me to close the tab with the audio resource that was causing the problem.  After renaming the cache folder back, and reenabling wifi, all seems ok, no need to redownload all the resources again.

Posts 5
Richard Hodges | Forum Activity | Replied: Thu, Jan 31 2019 12:54 PM

Thanks, that's a good workaround and it helps to know I don't have to keep reinstalling! It might also help the devs work out what's going on and it might be linked with the other issue I'm having with the study Bible.

The option I've taken for my Daily Driver is simply to revert to a previous version of Logos. However, I really like the new UI (kind of - what happened to 'Change Resource'?) so once this is fixed, I'll be all over it again.

Posts 5
Richard Hodges | Forum Activity | Replied: Fri, Feb 1 2019 6:10 AM

If this is of any use, the latest version works fine on my tablet. So some version information to clarify;

Android phone latest version of Logos crashes; Huawei (don't judge me) P10 Android version 8.0.0

Android tablet latest version of Logos works fine; Huawei (don't judge me) MediaPad M3 Lite, Android version 7.0

Posts 211
Kevin | Forum Activity | Replied: Fri, Feb 1 2019 7:42 AM

My crash is on Huawei M5 pad android 8

Posts 10
Roy Dammarell | Forum Activity | Replied: Fri, Feb 1 2019 11:02 AM

We will be shipping a fix for the audio crash today. Thanks for the report!

Posts 5
Richard Hodges | Forum Activity | Replied: Fri, Feb 1 2019 11:23 AM

That's brilliant, thanks very much :) 

Hopefully this will also address the first issue I have as well (since they both manifest similar symptoms I'm hoping they're related).

The response to this issue is very much appreciated Yes


Posts 119
ManilaDave | Forum Activity | Replied: Fri, Feb 1 2019 2:22 PM

My Huawei Media Pad was functioning reasonably well except that multiple book covers were missing (most of them). Also many resources in my library could not be downloaded straight. My workaround was to open the resource online. Once it was opened online I could download it. Then suddenly one day the app crashed and continued to crash on launch. I reinstalled and it seemed the reinstall cured the missing book covers. Now however as I was re-downloading resources the app crashed again. Specifically it crashed when downloading "Encountering John". Incidentally, this is one of the resources that I had to open online before before I could download it.  It just fails to launch now. Completely unusable. It is still working on my Huawei Mate 10 Pro. 

Posts 119
ManilaDave | Forum Activity | Replied: Sat, Feb 2 2019 12:21 AM

I have again reinstalled the app. It crashed again when downloading books but thankfully this time it launched again. However, multiple resources previously downloaded are now missing licences and so can no longer be accessed either online or through download.  

Posts 1
Smith Clarkson | Forum Activity | Replied: Wed, Aug 21 2019 11:23 PM

This is one of the most common problem user faces. I was having the same issue, so in order to resolve it, just follow the mentioned steps (it worked for me)

1. Un-install the app
2. Delete the cache and other files of the apps (do it via file manager)
3. Restart your phone
4. Re install the app

and the issue will be fixed. Do let me know if you are having problem performing the steps which I have mentioned above or if the problem is still there. Would love to help! :)


Page 1 of 1 (10 items) | RSS