an error occurred during synchronization, click to try again

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 12
Freddy Lam | Forum Activity | Posted: Fri, Mar 1 2019 7:18 PM

If you look next to my indexing, there is a synchronization issue and I can't resolve it. My PC installation of Logos 8 at church/work is unable to sync with my Mac installation of Logos 8 on my personal desktop, especially the progress made with the workflow. Please provide troubleshooting.

Blessing,

Freddy 

Posts 21926
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Mar 2 2019 12:58 AM

Please enable logging on your Mac as per https://support.logos.com/hc/en-us/articles/360015776171-Report-a-Problem-in-Logos-Mac 

Then:

  • stop Logos
  • start it again and let it run until you see the sync error indication
  • stop Logos
  • upload logs using the paperclip icon in the forum editor as a reply to this thread

Posts 12
Here are the logs. Hope I am doing it correctly.
Posts 12

0652.LogosLogs.freddylam.20190302-172833.zipHere are the logs. Hope I am doing it correctly.

Posts 21926
Forum MVP
Graham Criddle | Forum Activity | Replied: Sat, Mar 2 2019 11:11 PM

Well done on the logs - and there is certainly an issue with syncing something to do with workflows. The logs have 

2019-03-02 17:27:10.4522 | INFO | 10 | SyncV3Client | Updating 4 sync items: workflow/109039/heading, workflow/109039/heading, workflow/126517/heading, workflow/115629/heading
2019-03-02 17:27:10.4826 | ERROR | 10 | ApplicationUtility | SQLite Error 2067: abort at 29 in [update SyncItems
set SyncDocId = @SyncDocId, RevisionNumber = @RevisionNumber, Epoch = @Epoch
where SyncItemId = @SyncItemId;]: UNIQUE constraint failed: SyncItems.SyncDocId, Sync
...
2019-03-02 17:27:10.5021 | ERROR | 10 | ApplicationUtility | Will mark database as corrupt due to error executing: update SyncItems
set SyncDocId = @SyncDocId, RevisionNumber = @RevisionNumber, Epoch = @Epoch
where SyncItemId = @SyncItemId; ~SQLiteException: Constraint: UNIQUE constraint failed: SyncItems.SyncDocId, SyncItems.Kind
2019-03-02 17:27:10.5362 | INFO | 10 | LocalFileDatabase | Setting '/Users/freddylam/Library/Application Support/Logos4/Documents/4db25rmr.kbg/Workflows/Workflows.db' as corrupt in the registry.

Deleting /Users/freddylam/Library/Application Support/Logos4/Documents/4db25rmr.kbg/Workflows/Workflows.db would cause a new version to be downloaded from Logos servers and should enable you to sync again but it would probably lose your most recent progress.

I would wait to see if someone from Faithlife can comment further.

Posts 314
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Mon, Mar 4 2019 2:20 PM

Graham Criddle:

Deleting /Users/freddylam/Library/Application Support/Logos4/Documents/4db25rmr.kbg/Workflows/Workflows.db would cause a new version to be downloaded from Logos servers and should enable you to sync again but it would probably lose your most recent progress.

I would wait to see if someone from Faithlife can comment further.

Yes, we do recommend deleting /Users/freddylam/Library/Application Support/Logos4/Documents/4db25rmr.kbg/Workflows/Workflows.db.

Yes, this could lead to Freddy losing some of his progress.  But we still recommend this as the best option available.

Posts 12
Freddy Lam | Forum Activity | Replied: Wed, Mar 6 2019 3:01 PM

Hi Joe,

I tried it twice. It still didn't work, and shows an error in synchronization.

Blessing,

Freddy

Posts 21926
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Mar 6 2019 11:00 PM

Freddy Lam:
I tried it twice

Sorry Freddy but what did you try twice?

Posts 12
Freddy Lam | Forum Activity | Replied: Thu, Mar 7 2019 8:09 AM

I tried to delete database.db file. Then reload logos.

Didn't work.

I deleted it again. Ten reload logos.

Still didn't work.

Posts 21926
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Mar 7 2019 8:38 AM

Please capture and upload new logs.

Posts 314
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Thu, Mar 7 2019 8:41 AM

Freddy Lam:

I tried to delete database.db file. Then reload logos.

Didn't work.

Freddy, I am sorry to hear that you are still having difficulty with this.  I have sent you an email about this problem.

Posts 4
Michael Rennie | Forum Activity | Replied: Tue, Jul 9 2019 7:25 PM

Have two laptops and a desktop and this error is happening on all three with the latest build.

Posts 27682
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jul 9 2019 8:35 PM

Michael Rennie:

Have two laptops and a desktop and this error is happening on all three with the latest build.

Please create a new thread and post logs, as described above. 

OSX & iOS | Logs |  Install

Page 1 of 1 (13 items) | RSS