persistent crash on morph search

Page 1 of 1 (10 items)
This post has 9 Replies | 1 Follower

Posts 102
Andrew Malone | Forum Activity | Posted: Tue, Mar 12 2019 6:36 PM

I'm finding a persistent crash when attempting to do morph searches:

  • A standard in-context search works fine. I can find an occurrence of "glorify" or "glory" in an English Bible, and then right-click to morph search for lemma:δοξάζω or lemma:δόξα.
  • But opening a fresh search window, choosing a morph search, and then typing "doxa" or fewer letters (with or without the g: prefix) causes a complete program crash.
  • The horizontal "thinking" cursor (five pulsing square bullets) pauses at this point, suggests my machine is working too hard to come up with a list of viable lemmas to choose from, and then gives up. (I've stumbled upon a crash log that talks of a "database disk image is malformed".)

Some rudimentary debugging doesn't help much:

  • If it's something overloading my system, then it's at a fairly basic Logos level. I've tried closing all other windows and restarting the entire computer before attempting the search.
  • Same problem recurs if I attempt other words that score many hits, such as "logos" or "lego".
  • (Ironically, typing "lemma" – even if just to start a formal lemma search – safely gives me a list of Greek lemmas starting with λέμμα!)
  • No advantage by limiting the search parameters, e.g. to fewer resources (or just one!) or to a smaller search range.
  • Latest Logos release: 8.3.0.0022 running under Windows 10 Pro 64-bit (crashed under 1803 and even after I've fully updated to 1809)

I imagine others may have come across such a problem. I'm happy simply to be redirected to any existing solutions. Thanks.

Posts 21941
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Mar 13 2019 12:17 AM

Hi Andrew 

Please upload the log you referred to in a reply to this thread using the paperclip icon in the forum editor

Graham

Posts 102
Andrew Malone | Forum Activity | Replied: Wed, Mar 13 2019 12:43 AM

Thanks, Graham. Attached (although I've now started discovering yet other logs; holler if you need something different). 

0447.LogosCrash.txt

Posts 21941
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Mar 13 2019 12:47 AM

Hi Andrew

What we really need is the Logos.log file. Please

  • shutdown Logos and start it again
  • run the search that causes the crash
  • upload the latest logos.log file before restarting Logos
Posts 10056
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Mar 13 2019 12:56 AM

Graham Criddle:

Hi Andrew

What we really need is the Logos.log file. Please

  • shutdown Logos and start it again holding down the Ctrl-key
  • run the search that causes the crash
  • upload the latest logos.log file before restarting Logos

Andrew, see the bold text I added in the quote with a very relevant bit of information.

Running Logos 8 latest beta version on Win 10

Posts 102
Andrew Malone | Forum Activity | Replied: Wed, Mar 13 2019 1:21 AM

Thanks, gents. Always good to get a crash course in logging. I think this is what you're after:

2055.Logos.log

Posts 21941
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Mar 13 2019 1:38 AM

Hi Andrew

Thanks for the log

As you noted it does refer to a corrupt database image - and I assume that is the cause for the crash and it will need to be deleted.

However it doesn't easily identify which database is involved. Hopefully someone else will be able to track this down more definitively.

If you don't get a resolution here I would recommend contacting Customer Services.

Graham

Posts 102
Andrew Malone | Forum Activity | Replied: Wed, Mar 13 2019 1:52 AM

Thanks for your speedy detective work, Graham! I'll wait patiently for another day or two to see if anyone else can add further forensic insights. Smile

Posts 2086
LogosEmployee

I believe the corrupted file is C:\Users\Owner\AppData\Local\Logos\Data\2oqo1dmw.jir\ResourceManager\Resources\Lemmas.lbslms

You can delete that file and restart the application. The file will be downloaded again, and hopefully this will get things working.

Posts 102
Andrew Malone | Forum Activity | Replied: Wed, Mar 13 2019 4:15 PM

Perfect advice, thanks Andrew. I can confirm that I watched Logos freshly download the Lemma List Dataset, after which everything operated normally.

Page 1 of 1 (10 items) | RSS