More than disappointed!!! New tools wasted my time again (WORKFLOW)

Page 1 of 2 (23 items) 1 2 Next >
This post has 22 Replies | 2 Followers

Posts 310
Michael Hite | Forum Activity | Posted: Sat, Mar 16 2019 7:34 PM

Once again I have wasted more than a dozen hours trying to use the new Workflow Tool only to have NONE of my revisions saved when I open the tool again to keep working on it. As a seminary teacher I was crafting a very detailed workflow to guide my students through an original language word study. Unable to complete the workflow in one sitting I opened it to edit and spent roughly 7 hours making detailed changes and additions. When I finished I clicked done and close the workflow tool. Later this evening I went to work on it again. In opening the workflow to edit it - NONE of the changes, revisions or additions I had made in the previous 7 hour session were saved! NONE!

I love the promise of the workflow tool. The ability to create specific workflows related to my assignments would be so useful to my students and would help them learn new tools in Logos at the same time. But I am tired of wasting time trying to get it to work. I posted about this weeks ago. I get that it is intermittent and that it is a problem for some and not for others. But considering the amount of time and money that I have invested (both in my own use of the tool and the fact that we require our students to own the tool as well) it is getting discouraging.

If the tools are not ready for users to use them for serious work without the risk of wasting hours of time, they should not be released!

2015 13" MacBook Pro - 2 Ghz Intel i7 - 16 GB RAM - 500GB SSD - 2018 iMac Pro - 3.2GHz 8-core Xeon - both systems running OS 10.14.3 (Mojave)

 

Posts 1828
LogosEmployee
Phil Gons (Faithlife) | Forum Activity | Replied: Sat, Mar 16 2019 7:46 PM

Michael, I’m sorry to hear that you lost work. Let me check with the team to see if we can do anything to recover it.

Just to be clear, were you working through and filling out a Workflow template on a particular word (from the Guides menu) or were you creating a workflow template using the Workflow Editor? Sounds like the latter, but just wanted to be sure.

Any more details you can provide? The name of your template?

Posts 310
Michael Hite | Forum Activity | Replied: Sat, Mar 16 2019 7:50 PM

I was creating a custom workflow. The name of my template in Word Study (BVBII)

2015 13" MacBook Pro - 2 Ghz Intel i7 - 16 GB RAM - 500GB SSD - 2018 iMac Pro - 3.2GHz 8-core Xeon - both systems running OS 10.14.3 (Mojave)

 

Posts 4606
Forum MVP
Fred Chapman | Forum Activity | Replied: Sat, Mar 16 2019 8:37 PM

Hi Michael and Phil,

I don't know if this is the same issue, but similar behavior is being reported here

Note that one of the contributors to that thread indicates that they have already talked with tech support.

Posts 2820
Doc B | Forum Activity | Replied: Sat, Mar 16 2019 8:38 PM

FWIW, I noticed another recent thread about WF not saving changes.  Sounds like the issue isn't isolated.

[EDIT]

Fred and I posted at the same time, and he has a link to the thread I was thinking of (thanks!).

My thanks to the various MVPs. Without them Logos would have died early. They were the only real help available.

Faithlife Corp. owes the MVPs free resources for life.

Posts 26543
Forum MVP
MJ. Smith | Forum Activity | Replied: Sat, Mar 16 2019 8:43 PM

Several people have had this problem but for different reasons. May I asked if you started off with the "new" button on the lower right? If you saved then continued, did you select "edit this workflow" from the Panel Menu (kebab)?

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 310
Michael Hite | Forum Activity | Replied: Sat, Mar 16 2019 8:57 PM

Yes I started with new. At one point I clicked DONE and took a break. I came back later and it had the work I had done to that point so I spent the rest of the afternoon editing, adding, and revising it. I clicked DONE and took another break. Went back an hour later right clicked on the workflow in Custom Workflows list and selected Edit. When it opened a circular graphic appeared at the center and when the text came up it was the originally saved version with no edits retained.

2015 13" MacBook Pro - 2 Ghz Intel i7 - 16 GB RAM - 500GB SSD - 2018 iMac Pro - 3.2GHz 8-core Xeon - both systems running OS 10.14.3 (Mojave)

 

Posts 310
Michael Hite | Forum Activity | Replied: Sat, Mar 16 2019 9:28 PM

Here is a link to the original post in January regarding this issue - https://community.logos.com/forums/p/178075/1029730.aspx#1029730

2015 13" MacBook Pro - 2 Ghz Intel i7 - 16 GB RAM - 500GB SSD - 2018 iMac Pro - 3.2GHz 8-core Xeon - both systems running OS 10.14.3 (Mojave)

 

Posts 2820
Doc B | Forum Activity | Replied: Sat, Mar 16 2019 9:47 PM

Michael Hite:

Here is a link to the original post in January regarding this issue - https://community.logos.com/forums/p/178075/1029730.aspx#1029730

Here's a clickable link-  https://community.logos.com/forums/p/178075/1029730.aspx#1029730

My thanks to the various MVPs. Without them Logos would have died early. They were the only real help available.

Faithlife Corp. owes the MVPs free resources for life.

Posts 884
Kolen Cheung | Forum Activity | Replied: Sun, Mar 17 2019 4:29 AM

This is not going to help you right now but for the future:

When using a new feature, always assumes it doesn't work. Test it first by doing what you might want to do, but just the very beginning, minutes of work only.

The way Logos documents works reminds me the old days when one need to fill in a web form (some of the poorly design site nowadays still has this problem!), you spent an hour filling in a lot of boxes and typed paragraphs and when hitting submit, you have no internet connection for some reason! And when internet recovers, everything is gone. Hit back, just an empty form (sometimes it would still be there.)

The problem in Logos documents is similar in analogy. Traditionally for "documents" one would save a file to a certain place, and knowing that you created a file meaning that it does has been saved (to play safe, close and open from that file again.) But there's no such thing in Logos cloud. It's better than the web form analogy above to have a done button or so, but there's no transparent way to know that it doesn't work.

Personally I would not create any kind of Logos documents especially those requiring substantial work unless absolutely necessary (like a visual filter or highlight) which is also your case (workflow). I'll resort to PBB whenever I can. May be Logos can release a syntax and output type support for workflow? It's the only way the end users can have absolute control and safety net.

Posts 49
LogosEmployee
Matt Preucil | Forum Activity | Replied: Mon, Mar 18 2019 11:26 AM

Michael,

I'm very sorry to hear you're having these issues and have lost time due to these bugs. I haven't been able to find any logged server errors from your account. The last revision of the template in question was made on 3/16, which I'm guessing is a version submitted before all the changes that you lost. Is there a chance you can reproduce the issue with logs, and post them here?

Thank you.

- Matt

Posts 310

OK - I have the log file - I opened the Custom Workflow (partially completed) entitled Word Study (BVBII). I made two minor change (added a major step and minor step at the beginning and deleted a minor step later in the workflow. I chose DONE. (As long as that workflow remains open, if I choose Edit the Workflow my changes are present.. I closed the workflow, reopened it and chose Edit this Workflow and no changes were retained.

Here are the logs - 

2015 13" MacBook Pro - 2 Ghz Intel i7 - 16 GB RAM - 500GB SSD - 2018 iMac Pro - 3.2GHz 8-core Xeon - both systems running OS 10.14.3 (Mojave)

 

Posts 4606
Forum MVP
Fred Chapman | Forum Activity | Replied: Mon, Mar 18 2019 12:46 PM

This wiki page will give you information about how to enable and upload logs

Posts 49
LogosEmployee
Matt Preucil | Forum Activity | Replied: Mon, Mar 18 2019 2:02 PM

Michael,

Thank you for submitting logs. Unfortunately, I wasn't able to find any relevant messages in them. I sent you a message via Faithlife Messages with some steps to send additional information (privately) to continue diagnosing the problem.


Thank you.


- Matt

Posts 7
Mark Cercone | Forum Activity | Replied: Mon, Mar 18 2019 8:59 PM

Michael,

Hopefully you were able to read the logs I sent you with the workflow problem. I submitted it to you as instructed with technical support on my other thread. They were able to reproduce the problem as well, so it does sound like the problem is across multiple platforms.

Hopefully the problem can be fixed soon because the workflow tool is one of the reasons why I purchased Logos 8.

Thanks!!

Mark

Posts 7
Mark Cercone | Forum Activity | Replied: Tue, Mar 19 2019 11:52 AM

6685.LogosLogs.mcercone.20190318-123526.zip

I am working with tech support and the case number is 99359

Thank you!!

Posts 359
LogosEmployee
Adam Borries (Faithlife) | Forum Activity | Replied: Tue, Mar 19 2019 11:54 AM

Michael, 

I'm extremely sorry that we lost your work. This was our fault for missing your bug report in January. "Don't lose user data" is one of the cardinal rules at Faithlife, and I'm mortified that we failed in this case. 

If you care to know, here's a summary of the problem: Your workflow included some steps that were supported only in 8.1 or later; when those steps were removed, it made your workflow compatible with 8.0. The bug caused the application to save the version of your workflow with the most advanced functionality, rather than the version with your latest changes. 

Matt Preucil has found the problem, and we will put out an SR update with the fix in the next day or two. We are also reviewing our process for bug reports in the forums, to help us make sure we don't miss critical bugs like this. Please let me know if there is anything else we can do to make this up to you. 

Adam Borries | Product Manager, Logos desktop application

Message me on Faithlife.com >>

Posts 310
Michael Hite | Forum Activity | Replied: Tue, Mar 19 2019 12:48 PM

Thanks you and Matt and others that helped bring this to a resolution. I am thankful that this may help others not lose work as well. I have been a very long time user and don't plan on stopping anytime soon. I want desperately to be able to use new tools you release with confidence that they will work as described. Thanks for address the issue.

2015 13" MacBook Pro - 2 Ghz Intel i7 - 16 GB RAM - 500GB SSD - 2018 iMac Pro - 3.2GHz 8-core Xeon - both systems running OS 10.14.3 (Mojave)

 

Posts 7
Mark Cercone | Forum Activity | Replied: Tue, Mar 19 2019 12:58 PM

Michael,

Thank you for this information!! I was a user also seeing my workflow not save correctly or update. Do you think this SR update will help resolve what I am dealing with as well?

Appreciate the hard work you guys put in to making this software the best on the market. I enjoy the workflow editor tremendously and am excited to see a fix implemented here in the next few days.

Mark

Posts 26543
Forum MVP
MJ. Smith | Forum Activity | Replied: Tue, Mar 19 2019 2:33 PM

Thank you Adam for the clear communication and rapid response re:SR.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Page 1 of 2 (23 items) 1 2 Next > | RSS