Need an installer for OS X 10.10.5

Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 31
-- | Forum Activity | Posted: Sat, Apr 27 2019 4:26 AM

Hi, everyone,

I just finished moving and am setting up an older Mac Mini that can run no higher than OS X 10.10.5.  Before we moved, the computer happily ran Logos 6, but now that product can no longer log onto Faithlife's servers.  So, I tried to upgrade to Logos 8 with the most recent installer.  That requires OS X 10.11 or later, which this Mac can't run.  Does Faithlife make available an older installer so that I can get Logos running again on this PC?

Posts 4602
Forum MVP
Fred Chapman | Forum Activity | Replied: Sat, Apr 27 2019 11:59 AM

L6 is not longer supported. However you can try this link

https://www.logos.com/product/46767/logos-6-core-engine

Posts 17956
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, Apr 27 2019 11:56 PM

--:
Does Faithlife make available an older installer so that I can get Logos running again on this PC?

No, Logos wiki => Logos Release History includes:

Keep Smiling Smile

Posts 13358
Forum MVP
Mark Barnes | Forum Activity | Replied: Sun, Apr 28 2019 2:01 AM

To explain KS4J's post a bit further, back in November 2018, for security reasons all Logos servers stopped supporting outdated security mechanisms. This had the side effect of preventing versions of Logos prior to 7.18 from connecting to Logos' servers. Those versions can't sync, download, or be installed, although existing installations remain working offline.

This also removed support from Mac OS 10.10 and earlier, and from Windows Vista and earlier.

You can read more here: https://www.logos.com/logos-7-update

So even though I could supply you a link to download Logos 7.14 (the last version that was compatible with Mac OS 10.10), you wouldn't be able to install it or sign in.

Page 1 of 1 (4 items) | RSS