Page 1 of 1 (3 items)
This post has 2 Replies | 0 Followers

Posts 25
Raffaele Paglialunga | Forum Activity | Posted: Sat, May 25 2019 9:33 AM

i have a iPhone that is 10.3  I believe... can't get Logos or Biblia to download cause you need 11

Any ideas

Posts 4635
Forum MVP
Fred Chapman | Forum Activity | Replied: Sat, May 25 2019 10:37 AM

Currently the ios app requires 11.2 or later, I know of nothing you can do other than update you ios if your phone will allow that.

Perhaps there is someone who has an older version of the app, but I do not know if it would be useable, even if you were able to install it.

Posts 335
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Mon, May 27 2019 8:09 AM

An alternative is to use the Logos Web App instead of the App we have available in the App Store.  The Logos Web App is available here

Page 1 of 1 (3 items) | RSS