Not on Any/This Device anomalies

Page 1 of 1 (7 items)
This post has 6 Replies | 0 Followers

Posts 406
Brad | Forum Activity | Posted: Sun, Jun 2 2019 7:22 PM

I'm sorry this is a long post, but I could really use some help regarding some challenges related to Not on Any/This Device and Cloud Resources.

1) L8 (8.5) on My MacBook Pro indicates that 2 of my resources are "not on any device," and the same version of Logos on my Mac indicates that 754 of my resources are not on any device.  The "not on ANY device" and the "not on THIS device" numbers are identical on each computer, so I assume that "not on Any device" is simply not functioning correctly yet?

2) Unfortunately, I didn't realize that since the Cloud Resources feature was implemented, my Mac had no longer been downloading resources automatically.  Even on a weekend I don't have time to manually download each of 754 resources.  I changed the "Download New Resources" setting to "Yes" and I hoped that "update now" or "update resources" would bring them all down from the cloud, but no such luck.  Is there any command I can use to force a download of all 754?  Please? Smile

3) One of the two resources that L8 says my MacBook Pro doesn't have IS on my MacBook.  When I attempt to open it (Praying for Your Prodigal) on my MacBook Pro I get the "This resource is not currently available on this device..." message and the "Download now" and "Open in Web App" buttons.  When I click the "Download" button nothing happens.  I've tried multiple times, exited and relaunched Logos, tried "update now," and "update resources," tried "Download now" a few more times, and nothing gets the book to display in the app.  If I click the "Open in Web App" button, the resource opens just fine in my browser.  Any ideas on how to get this to download and/or open in the regular Logos for Mac application?

4) The other resource that my L8 on my MacBook Pro says I do not have locally is clearly already downloaded and functioning just fine.  (See the screen shot below.)  The "update now" and "update resources" didn't do anything to fix this of course, and I'm going through a painfully slow "rebuild index" right now.  If that doesn't fix it, are there any other things I should try to get this resource to stop appearing as "not on this device" and "not on any device?"

 

Posts 27270
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Jun 2 2019 8:03 PM

Brad:
 I changed the "Download New Resources" setting to "Yes" and I hoped that "update now" or "update resources" would bring them all down from the cloud, but no such luck.

First thing to double check: What hours do you have set for downloads? If you arent within the window of time, it will not work. 

OSX & iOS | Logs |  Install

Posts 406
Brad | Forum Activity | Replied: Sun, Jun 2 2019 8:20 PM

Good point, JT.  The default "midnight to midnight" setting doesn't appear to be the cause of the problem, but at least I can cross that off the list of possible culprits.  Thank you.

Posts 21637
Forum MVP
Graham Criddle | Forum Activity | Replied: Sun, Jun 2 2019 10:48 PM

Brad:

2) Unfortunately, I didn't realize that since the Cloud Resources feature was implemented, my Mac had no longer been downloading resources automatically.  Even on a weekend I don't have time to manually download each of 754 resources.  I changed the "Download New Resources" setting to "Yes" and I hoped that "update now" or "update resources" would bring them all down from the cloud, but no such luck.  Is there any command I can use to force a download of all 754?  Please? Smile

Try opening the Library panel and selecting “Not on this device”. Ensure the Information pane is open

Then select all the resource - Cmd-A - and click the Download button in the Information pane

Posts 24568
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Jun 3 2019 1:28 AM

Brad:

3) One of the two resources that L8 says my MacBook Pro doesn't have IS on my MacBook.  When I attempt to open it (Praying for Your Prodigal) on my MacBook Pro I get the "This resource is not currently available on this device..." message and the "Download now" and "Open in Web App" buttons.  When I click the "Download" button nothing happens. ...

4) The other resource that my L8 on my MacBook Pro says I do not have locally is clearly already downloaded and functioning just fine.  (See the screen shot below.)  The "update now" and "update resources" didn't do anything to fix this of course, and I'm going through a painfully slow "rebuild index" right now. ...

If this is not fixed by following the advice for problem #2, try deleting the folder

                        ~/Library/Application Support/Logos4/Data/{random}/ResourceManager/Downloaded

(see https://www.macworld.com/article/1161156/view-library-folder-in-lion.html to view the ~/Library folder)

Rebuild index won't help!

Dave
===

Windows & Android

Posts 406
Brad | Forum Activity | Replied: Mon, Jun 3 2019 11:23 PM

Graham Criddle:

Brad:

2) Unfortunately, I didn't realize that since the Cloud Resources feature was implemented, my Mac had no longer been downloading resources automatically.  Even on a weekend I don't have time to manually download each of 754 resources.  I changed the "Download New Resources" setting to "Yes" and I hoped that "update now" or "update resources" would bring them all down from the cloud, but no such luck.  Is there any command I can use to force a download of all 754?  Please? Smile

Try opening the Library panel and selecting “Not on this device”. Ensure the Information pane is open

Then select all the resource - Cmd-A - and click the Download button in the Information pane. 

Great tip, Graham!  Thank you.  Challenge #2 resolved, except for seven Themelios journal volumes that are listed as "not on any device" and "not on this device," but are all downloaded and visible, despite the Library panel grouping them as absent.  That's the same problem I'm having on my MacBook Pro for the one rogue resource that is present, but L8's Library panel doesn't agree.  I'll give Dave's tip a try tomorrow, time permitting, and see if that will resolve the downloaded resources being listed as missing.  Thanks again!

Posts 406
Brad | Forum Activity | Replied: Mon, Jun 3 2019 11:26 PM

Dave Hooton:

If this is not fixed by following the advice for problem #2, try deleting the folder

                        ~/Library/Application Support/Logos4/Data/{random}/ResourceManager/Downloaded

Thank you, Dave!  No luck with the advice for problem #2 for this issue, so I'll try deleting the Downloaded folder.  

Page 1 of 1 (7 items) | RSS