Logos 7 cannot connect to server

Page 1 of 1 (6 items)
This post has 5 Replies | 1 Follower

Posts 958
Harry Hahne | Forum Activity | Posted: Thu, Jun 6 2019 5:57 PM

I have an older computer that runs Logos 7. For a variety of reasons, I want to keep this computer running Logos 7.

When I start Logos, it says it cannot connect to the Logos server, even though the computer is connected to the Internet. I assume this is because it is not the most up-to-date version of Logos 7.x.

When I go to the Logos website, it only offers the option of installing Logos 8.

Is there any way to install the final version of Logos 7? I assume to keep it at Logos 7, I must turn off automatic updates. But in my present situation, I either can only work offline or update to Logos 8.

Posts 17823
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, Jun 6 2019 9:05 PM

Harry Hahne:
I have an older computer that runs Logos 7.

Does older operating system support TLS 1.2 ? => https://www.logos.com/logos-7-update

Harry Hahne:
Is there any way to install the final version of Logos 7?

Logos wiki => https://wiki.logos.com/Installation_and_Indexing_Questions currently includes Logos 7 installation links.

Keep Smiling Smile

Posts 13210
Forum MVP
Mark Barnes | Forum Activity | Replied: Fri, Jun 7 2019 2:38 AM

Harry Hahne:
Is there any way to install the final version of Logos 7? I assume to keep it at Logos 7, I must turn off automatic updates. But in my present situation, I either can only work offline or update to Logos 8.

You should be able to manually install Logos 7.19 SR-1 from https://downloads.logoscdn.com/LBS7/Installer/7.19.0.0037/LogosSetup.exe 

Posts 24563
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Jun 7 2019 5:03 PM

Harry Hahne:
I assume to keep it at Logos 7, I must turn off automatic updates.

Use the command set update channel to Manual to avoid software updates. That way, automatic updates will only download resources.

Dave
===

Windows & Android

Posts 1595
Ken McGuire | Forum Activity | Replied: Fri, Jun 7 2019 8:04 PM

A few days ago I attempted to install using the old Logos 7 installer since I had it already on a network drive of various install files on a new computer. It was unable to connect to the Logos servers to log into my account. When I DLed the Logos 8 installer, it worked fine though.

So I can't say exactly what the problem is, I strongly suspect there is some kind of problem going on.

The Gospel is not ... a "new law," on the contrary, ... a "new life." - William Julius Mann

Posts 7922
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Mon, Jun 10 2019 10:41 AM

Ken McGuire:
So I can't say exactly what the problem is, I strongly suspect there is some kind of problem going on.

Many Logos 7 versions prior to 7.18 SR-1 cannot connect to Logos servers due to security updates we made: https://community.logos.com/forums/t/173644.aspx

This is most likely why older versions cannot install or update.

Logos 7 is now unsupported and we urge all users to update to Logos 8: https://support.logos.com/hc/en-us/articles/360007391412-About-Free-Support 

Page 1 of 1 (6 items) | RSS