Page 1 of 1 (9 items)
This post has 8 Replies | 1 Follower

Posts 97
Paul Unger | Forum Activity | Posted: Sun, Sep 15 2019 8:20 AM

I tried to do a search on my Android device (v. 9 "Pie"). Search has always been a slooooow, laborious process, but I was desperate... Anyway, this time Logos crashed and ever since I have not been able to restart the app without Logos crashing. Android helpfully tells me "Logos Bible keeps stopping", and now I'm getting a warning from "Device Care" that Logos is using lots of battery and that I should put it to "Sleep". All of this is very frustrating. :-( If anyone has a clue of how to fix this, I'd be grateful.

Posts 27773
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Sep 15 2019 3:47 PM

I am not an Android user, but while we wait for someone with more knowledge: 

Which specific app? How much free space on the device? How many resources did you have downloaded? Have you tried starting up offline? What kind of search were you performing? 

OSX & iOS | Logs |  Install

Posts 8
Glenn H | Forum Activity | Replied: Sun, Sep 15 2019 4:24 PM

Android apps can sometimes get in this buggy state. You can do 1 of 2 things:

  1. Go to the app info screen do a force stop and clear the cache (don't select Clear Data - you will have to re-download all your resources)
  2. Shut the device off and re-start it.
Posts 97
Paul Unger | Forum Activity | Replied: Sun, Sep 15 2019 4:34 PM

JT (alabama24):

I am not an Android user, but while we wait for someone with more knowledge: 

Which specific app? How much free space on the device? How many resources did you have downloaded? Have you tried starting up offline? What kind of search were you performing? 

App: Logos 8

Free space: 6.8 GB

Resources downloaded: less than 10?

Starting offline: I rarely start /online/, so, yes, I have tried starting offline

Kind of search: Bible keyword

Posts 97
Paul Unger | Forum Activity | Replied: Sun, Sep 15 2019 4:37 PM

Glenn H:

Android apps can sometimes get in this buggy state. You can do 1 of 2 things:

  1. Go to the app info screen do a force stop and clear the cache (don't select Clear Data - you will have to re-download all your resources)
  2. Shut the device off and re-start it.

Thanks for the suggestions, Glenn H. I had already done both things--force stop + clear cache, and restart device (I should have mentioned that in my first post). Neither has fixed the crash loop, despite trying each thing a few times...

Posts 333
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Mon, Sep 16 2019 10:50 AM

I am sorry to hear about the trouble that you have been having, Paul.

Please uninstall and the re-install the app, then let us know if you need further help.

Posts 97
Paul Unger | Forum Activity | Replied: Mon, Sep 16 2019 11:21 AM

Joe McCune (Faithlife):

I am sorry to hear about the trouble that you have been having, Paul.

Please uninstall and the re-install the app, then let us know if you need further help.

That seems pretty drastic, Joe McCune... Is that really my only option? That would be pretty much a game ender if this happens when I'm working overseas (limited, slow, and expensive internet). Is there a bug report I can file for this, so that a better (i.e., real) fix can be developed?

Posts 333
LogosEmployee
Joe McCune (Faithlife) | Forum Activity | Replied: Mon, Sep 16 2019 1:39 PM

Hi Paul,

Please go to the Play Store to see if there are any updates available for the app.

If this difficulty persists after all available updates have been installed, go to the main Android search bar (not the browser) and enter:  logos.com/mobile/layout/default

Select the Logos app when prompted.

Let us know if you need further help.

Posts 97
Paul Unger | Forum Activity | Replied: Mon, Sep 16 2019 2:14 PM

Joe McCune (Faithlife):

Hi Paul,

Please go to the Play Store to see if there are any updates available for the app.

If this difficulty persists after all available updates have been installed, go to the main Android search bar (not the browser) and enter:  logos.com/mobile/layout/default

Select the Logos app when prompted.

Let us know if you need further help.

There were no updates for Logos at the Play Store, so I went to "the main Android search bar" (pulled down notification bar and clicked the magnifying glass), typed in the address you provided, and clicked the Logos app icon. Logos opened, and the search completed! Now, I don't know if it was because I followed your instruction set or because I was still online (from checking for updates at the Play Store), but I'm back in business--and I didn't have to delete the app and reinstall it.

Thanks for your help.

Page 1 of 1 (9 items) | RSS