CRASH: Logos running in the background

Page 1 of 1 (5 items)
This post has 4 Replies | 0 Followers

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Posted: Wed, Nov 6 2019 5:41 AM

Logos 8.9 RC-1 Mac OS 10.15.0

Upgraded to 8.9 RC-1, clicked toolbar icon for my Devotional layout. Switched to Safari to read the Logos Forums. After a few minutes, the Apple Crash dialog appeared and Logos was gone.

6837.Apple Crash.rtf

6862.LogosLogs.jackcav.20191106-083643.zip

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Nov 6 2019 1:39 PM

AND AGAIN Left the room with Logos running in the foreground. Returned in 5 minutes to find Logos replaced by the Apple Crash dialog.

8883.Apple Crash 2.rtf

The forum software again refuses to accept the Logos logs—only 5.5 MB

Posts 370
LogosEmployee
Adam Borries (Faithlife) | Forum Activity | Replied: Thu, Nov 7 2019 10:35 AM

Thanks, Jack. We're looking into it. 

Adam Borries | Product Manager, Logos desktop application

Message me on Faithlife.com >>

Posts 52
LogosEmployee
Matt Preucil | Forum Activity | Replied: Thu, Nov 7 2019 1:16 PM

Jack,

This looks like it might be a corrupted database/index issue. We should try to rule that out, first. Do you mind renaming the directory at `/Users/jackcav/Library/Application Support/Logos4/Documents/fwu3dehb.5cn/Documents` to `Documents~backup` (or, similar) and reporting back?

If this does fix the issue, it might be interesting to see what the corrupted database looks like. Thank you!

- Matt

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Nov 8 2019 7:02 AM

Matt Preucil:
Do you mind renaming the directory at `/Users/jackcav/Library/Application Support/Logos4/Documents/fwu3dehb.5cn/Documents` to `Documents~backup` (or, similar) and reporting back?

Made the change. However, please note that the crash was intermittent, so it will difficult to know if this changed the situation. Would you like a copy of the documents folder?

Page 1 of 1 (5 items) | RSS