Page 1 of 1 (20 items)
This post has 19 Replies | 2 Followers

Posts 812
Armin | Forum Activity | Posted: Fri, Jan 31 2020 3:18 AM

I have the following resource:

Barclay, W. (Ed.). (1975). The Gospel of John (Vol. 1). Philadelphia, PA: The Westminster John Knox Press.

This resource contains the following sentence:

"The strict Rabbis forbade a Rabbi to greet a woman in public"

However, when I highlight this sentence in the resource and search for it, no results are found. Am I doing here something wrong?

Here is a screenshot with the resource and the search:

Posts 4745
Forum MVP
Fred Chapman | Forum Activity | Replied: Fri, Jan 31 2020 3:41 AM

I do not have that resource to test, however I suspect it may be an indexing issue.

I would suggest running a rebuild index command, but I think there is a way to rebuild the index for a single resource. Let me try to find the correct syntax for rebuilding a single resource index before you go to the trouble of rebuilding the entire library index.

Posts 3504
Forum MVP
PetahChristian | Forum Activity | Replied: Fri, Jan 31 2020 3:47 AM

I also don't have that particular resource. Is it an older edition of the (New) Daily Study Bible?

For me, that exact string is found in The Gospel of John, Volume 1 | NDSB Jn1

LLS:NDSB64JNV01
2011-07-13T21:55:53Z
NDSB64JNV01.logos4

My top three Logos 9 Wishlist items: Carta, Dark mode, and Hebrew audio bible, please.

Posts 4745
Forum MVP
Fred Chapman | Forum Activity | Replied: Fri, Jan 31 2020 4:10 AM

Fred Chapman:
Let me try to find the correct syntax for rebuilding a single resource index before you go to the trouble of rebuilding the entire library index.

Try this command

Reindex {Abbreviated Title | Resource Id} - re-indexes a single resource e.g. reindex ESVreindex LLS:1.0.710

You can find the required resource information in the Info pane

Posts 812
Armin | Forum Activity | Replied: Fri, Jan 31 2020 10:03 AM

Many thanks for all your recommendations. I tried reindexing just the resource but it did not help. Then I rebuilt the entire index and still, I don't get any search results. Both of the following resources contain this sentence:

LLS:NDSB64JNV01
2011-07-13T21:55:53Z
NDSB64JNV01.logos4

LLS:29.48.7
2006-03-23T20:58:49Z
bcomjhn1.lbxlls

Posts 2946
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Fri, Jan 31 2020 11:04 AM

Armin:

Many thanks for all your recommendations. I tried reindexing just the resource but it did not help. Then I rebuilt the entire index and still, I don't get any search results. Both of the following resources contain this sentence:

LLS:NDSB64JNV01
2011-07-13T21:55:53Z
NDSB64JNV01.logos4

LLS:29.48.7
2006-03-23T20:58:49Z
bcomjhn1.lbxlls

Armin,

I cannot reproduce this, can you post your logs?

Posts 1227
Myke Harbuck | Forum Activity | Replied: Fri, Jan 31 2020 8:47 PM

I can reproduce. Same results as OP. I tried every way possible to search the term, including shortening the phrase, inline search, NEAR, etc. No hits.

I have same resource versions as OP.

LLS:NDSB64JNV01
2011-07-13T21:55:53Z
NDSB64JNV01.logos4

LLS:29.48.7
2006-03-23T20:58:49Z
bcomjhn1.lbxlls

I am on Mac 8.11.0.0013, although I think this is a resource issue, not an issue with Logos.

Philana, just a hunch. Do you have BOTH DSBS and NDSB? I ask because for the resources where I own BOTH the original DSBS and the corresponding NDSB, I only get hits for any search in the NDSB. However, for the resources where I ONLY have the original DSBS (which is the OT volumes), I get hits as expected (tested 5 or 6 searches in multiple resources).

So, having BOTH the new version and the old version in my library seems to cause Logos to only return results for the new resource.

Myke Harbuck
Lead Pastor, www.ByronCity.Church
Adjunct Professor, Georgia Military College

Posts 812
Armin | Forum Activity | Replied: Fri, Jan 31 2020 11:54 PM

Hi Myke,

Many thanks for checking. I am glad that I am not the only one who has this issue.

Armin

Posts 8148
LogosEmployee

This reminds me of this bug (which was fixed in 8.8): https://community.logos.com/forums/t/184655.aspx

For people who can reproduce the problem, does shortening the phrase to "The strict Rabbis forbade a" return results, but extending it to include the second "Rabbi" fail?

Posts 812
Armin | Forum Activity | Replied: Sun, Feb 2 2020 8:02 AM

Hi Bradley,

Thanks for looking into this. Shortening the phrase did not help in my case. Even searching for "The strict Rabbis" does not lead to hits in these two resources.

Posts 8148
LogosEmployee

Hmm, that's strange. If you have the resources open so that quote is visible, and start a new Basic Search in Open Resources for

The OR strict OR Rabbis OR forbade OR a OR to OR greet OR woman OR in OR public

are any of the words in that phrase in the open resource highlighted (as search results)?

Posts 1227
Myke Harbuck | Forum Activity | Replied: Tue, Feb 4 2020 11:40 AM

Bradley Grainger (Faithlife):

This reminds me of this bug (which was fixed in 8.8): https://community.logos.com/forums/t/184655.aspx

For people who can reproduce the problem, does shortening the phrase to "The strict Rabbis forbade a" return results, but extending it to include the second "Rabbi" fail?

Shortening the phrase does not help. No search parameters of any kind work.

Bradley Grainger (Faithlife):

Hmm, that's strange. If you have the resources open so that quote is visible, and start a new Basic Search in Open Resources for

The OR strict OR Rabbis OR forbade OR a OR to OR greet OR woman OR in OR public

are any of the words in that phrase in the open resource highlighted (as search results)?

Active search highlighting does not work either. Again, this appears to be tied to a conflict between the updated resource and the original resource. For any resource where one has both the old and new resource downloaded, the old resource will not return results for searches of any kind.

For resources where I own only the old resource (IE OT volumes) searches perform as expected.

Myke Harbuck
Lead Pastor, www.ByronCity.Church
Adjunct Professor, Georgia Military College

Posts 812
Armin | Forum Activity | Replied: Thu, Feb 6 2020 2:27 AM

Bradley Grainger (Faithlife):

If you have the resources open so that quote is visible, and start a new Basic Search in Open Resources for

The OR strict OR Rabbis OR forbade OR a OR to OR greet OR woman OR in OR public

are any of the words in that phrase in the open resource highlighted (as search results)?

I just tried this search. No, none of the two resources has any of the search terms highlighted.

Posts 812
Armin | Forum Activity | Replied: Thu, Feb 6 2020 2:29 AM

Myke Harbuck:

For any resource where one has both the old and new resource downloaded, the old resource will not return results for searches of any kind.

Does this imply that you get the search results in the new resource? I have both resources and neither resource shows the search results.

Posts 1227
Myke Harbuck | Forum Activity | Replied: Thu, Feb 6 2020 5:35 AM

Armin:

Myke Harbuck:

For any resource where one has both the old and new resource downloaded, the old resource will not return results for searches of any kind.

Does this imply that you get the search results in the new resource? I have both resources and neither resource shows the search results.

Correct. I consistently get results for the newer resource.

Myke Harbuck
Lead Pastor, www.ByronCity.Church
Adjunct Professor, Georgia Military College

Posts 8148
LogosEmployee

Armin:
Then I rebuilt the entire index and still, I don't get any search results.

Did you use the "rebuild index" command to do this?

If you have the time, there's a more extreme approach we could take to ensure that absolutely all index files are cleared out. Delete the following two folders and restart Logos (it should start indexing again, which may take a few hours):

  • /Users/eberlein/Library/Application Support/Logos4/Data/d5641vkc.6jn/BibleIndex
  • /Users/eberlein/Library/Application Support/Logos4/Data/d5641vkc.6jn/LibraryIndex
Posts 812
Armin | Forum Activity | Replied: Thu, Feb 6 2020 9:59 AM

Bradley Grainger (Faithlife):

Did you use the "rebuild index" command to do this?

Yes, I used this command.

Bradley Grainger (Faithlife):

If you have the time, there's a more extreme approach we could take to ensure that absolutely all index files are cleared out. Delete the following two folders and restart Logos (it should start indexing again, which may take a few hours):

  • /Users/eberlein/Library/Application Support/Logos4/Data/d5641vkc.6jn/BibleIndex
  • /Users/eberlein/Library/Application Support/Logos4/Data/d5641vkc.6jn/LibraryIndex

I just followed these instructions. Will let you know of the outcome once the indexing finished. Since I am traveling in the next few days, it will take a bit to try out the search after the indexing finished.

Posts 812
Armin | Forum Activity | Replied: Thu, Feb 6 2020 11:08 AM

Myke Harbuck:

Armin:

Myke Harbuck:

For any resource where one has both the old and new resource downloaded, the old resource will not return results for searches of any kind.

Does this imply that you get the search results in the new resource? I have both resources and neither resource shows the search results.

Correct. I consistently get results for the newer resource.

This makes it even more interesting. Let's see what the outcome is of the step that Bradley recommended.

Posts 812
Armin | Forum Activity | Replied: Thu, Feb 6 2020 5:15 PM

Hi Bradley,

Deleting these two folders and re-indexing fixed the problem. Many thanks.

Armin

Page 1 of 1 (20 items) | RSS