At the end all went well and now I'm tasting sweet nougat.

Page 1 of 1 (2 items)
This post has 1 Reply | 0 Followers

Posts 196
Edil | Forum Activity | Posted: Mon, Apr 27 2020 3:05 PM

At church I basically use the Logos APP with my phone so I can read better, due to my age I don't see well and the APP allows me to put my favorite bible and my preferred hymnbook with large letters.

Several days ago, I had no space on my phone and wanted to try a new APP temporarily. In the past, on multiple occasions, Logos being one of the APPs that takes up the most space (my church doesn’t have Wi-Fi and I have the books that I use the most downloaded into the phone), I uninstalled it to try this or that new app and when finished I installed Logos back. But this time to my surprise, Google Play didn’t allow me to reinstall. To make everything clear, before uninstalling the Logos app it worked perfectly fine. I called Logos and they told me that the app could not be used again because the version of android on my phone was very old. Indeed, the first and only "smartphone" I have bought is the one I have now, I bought it for $ 100 in 2014, an LG L90 running Android 5 (Lollipop). Perhaps that will take you by surprise in this day and age when people often buy phones from hundreds to $1,000, which in my own and entirely personal opinion I find totally absurd. When I started back in the early 80’s with computers until these days, thinking that one would change a laptop or desktop computer buying a new unit of $ 600, $ 700, $ 800, $ 1,000 every year was and is a bit crazy. But it seems that the rest of the world does not think so with smartphones. The point is that I have no need to change my unit and for my unique and personal case acquiring another unit is unnecessary and a lack of good stewardship.

That companies decide not to provide support with their programs with a certain operating system is something, unfortunately "normal". Microsoft will no longer provide support with its Office365 app to older versions of Android 7 (Nougat). But what I do not see as correct is that Logos did not report on this. I do not know of any notice from Logos indicating that future versions of the APP would not be compatible with my unit, much less that they would not allow using the version that until recently worked without problems. It is beyond my understanding that under my responsibility they do not allow me to use an earlier version. I asked support if they could send me the version 7 APK file to install it manually but they said they didn't save previous versions. Seeing that my options with support were ... zilch ... I decided to take action on my own:

First, I took note of not trusting Google Play / Logos update system.

Second, once I managed to make some version of the app work: backup backup backup, I took the smartphone functionality by granted and equal to computers they are vulnerable to 3rd party decisions.

Third search for a repository where I can find previous versions of the Logos APK. Those I found here:

and to my surprise Amazon App store

Well, I was ready to install when I decided (not necessarily to directly please Logos, but because it was something I had been thinking about doing for a long time), # 1 to put my unit in "root" mode, which would give me more control over the unit and make thing easier to create not a data backup but a full image backup, # 2 update the android version on my phone. Well, you may wonder why I didn't do that from the beginning. The problem was that LG decided not to provide an official update beyond version 5.0.2 for my unit. So, I had to find a compatible open source distribution of android for my unit and to my surprise, even when I have a 6-year-old unit, I found that the 7th version of Android (Nougat) was available. I thought the process was going to be complicated but, in the end, it turned out to be reasonably easy to do:

Download an app to make the unit initialize in recovery mode. The one I found is called TWRP and is available from the google store.

Put the unit in "Root" mode. Which was very easy to do by following these instructions:

Download the customized version 7 of android for my unit which I found here: -lg-l90-t3594560

Download the open source versions of Google applications which are available here:

Then use TWRP to install both.

Ready with Android version 7 running on my unit I was able to download the new version of the Logos app and it is running.

Now, that doesn’t invalidate what I said above. The latest version of android is Q or number 10, so it is not that Android version 7 is up to date, on the contrary is getting obsolete fast. I don’t see feasible to update to Android 10. First because with the "hardware" my unit has I don't know how well will it run and second because it simply does not exist, nobody has created a customized version of Android Q / 10 for my unit. So, in the future it will happen again and Logos will decide not to support (or allow), that people use the Logos app with version 7 of android. But when that moment comes, I will be ready and prepared with my full image backup. I hope to continue using Logos with my unit while it continues working.

Ok but why do I write all this? For you to know that if the same thing happens, there are options and that if you decide to do so let me know to see how I can help you. I’m not an expert but at least this process gave me some knowledge.

P.D.: I don’t use/advocate for, “fancy” appliance gadgets (Apple-iPhone), so sorry but with those I can’t help you.

Posts 28695
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Apr 27 2020 3:54 PM

Glad you got it working. For what it’s worth: Apple currently has the fastest processor and has included it on this new iPhone SE which starts at $399. iPhones have much greater longevity because Apple supports their phones for at least 5 years. Based on past history, a new model iPhone purchased today should be compatible for about seven years. 

OSX & iOS | Logs |  Install

Page 1 of 1 (2 items) | RSS