Could not download required file on Win 10

Page 1 of 1 (3 items)
This post has 2 Replies | 1 Follower

Posts 1
Eric Newcomb | Forum Activity | Posted: Sun, Sep 13 2020 10:35 AM

When I try to install Logos on my new laptop, installation fails with a message that "Setup was unable to download a required file." I've found several references to this online, but none of the recommended solutions have worked for me. I followed the instructions in both sections of https://support.logos.com/hc/en-us/articles/360008567331, deleted the Logos folder in AppData/Local. A few other things I tried:

  • Disabled Windows Firewall
  • Turned off Windows Updates
  • Disabled MalwareBytes & CCleaner
  • DIsabled Windows Defender

After each step I tried the installation in both user and administrator modes.

Can someone help me figure this out please?

Also, when I tried this forum's search to find an answer I was redirected to a "Something went wrong" page.

Posts 3784
SineNomine | Forum Activity | Replied: Sun, Sep 13 2020 10:56 AM

Eric Newcomb:
Also, when I tried this forum's search to find an answer I was redirected to a "Something went wrong" page.

You'll want to search the forums using Google.

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Sep 14 2020 2:23 PM

Welcome Eric,

Eric Newcomb:
I followed the instructions in both sections of https://support.logos.com/hc/en-us/articles/360008567331, deleted the Logos folder in AppData/Local. A few other things I tried:

As a new installation is failing I recommend you  contact Customer Service.

Dave
===

Windows 10 & Android 8

Page 1 of 1 (3 items) | RSS