Is anyone else suddenly experiencing battery drain?

Page 1 of 1 (13 items)
This post has 12 Replies | 2 Followers

Posts 8
Andy Fuqua | Forum Activity | Posted: Wed, Feb 17 2021 8:50 AM

I have a 2020 MacBook Pro 16". Latest OS, latest update to Logos. I noticed a few weeks ago that suddenly Logos 9 is eating huge amounts of power. Even just having the program open without actively using it, it consumes about 6X the power of any other applications.

I've had Logos 9 for a while and not experienced this issue before. In fact, I was kind of impressed at how battery-efficient Logos 9 seemed to be... until a few weeks ago when it became an insatiable power hog.

I run other heavy-duty programs like Photoshop, InDesign, Premiere for things like graphic design and video-editing, and don't experience nearly the battery drain as I do when using Logos 9.

I'm wondering if anyone else is experiencing this issue?

Posts 1056
Armin | Forum Activity | Replied: Wed, Feb 17 2021 9:25 AM

I don't have any issues with my 2017 MacBook Pro 15". But indexing or larger libraries consume more power.

Posts 8
Andy Fuqua | Forum Activity | Replied: Wed, Feb 17 2021 10:04 AM

Thanks. It's not related to indexing, since it doesn't index very often but it drains the battery like crazy every single time I use it. I haven't upgraded my library or done anything else to change Logos, other than install new updates as they're pushed out. But for the past few weeks it will completely drain my MacBook Pro's battery (from 100% charged to low power warning) in about two hours--even if I'm doing nothing with Logos other than opening the application.

That battery drain issue is new and started a few weeks ago, although I have had Logos 9 for a long time and have not change my usage of the app.

Posts 19038
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Feb 17 2021 3:17 PM

Andy Fuqua:
But for the past few weeks it will completely drain my MacBook Pro's battery (from 100% charged to low power warning) in about two hours--even if I'm doing nothing with Logos other than opening the application.

Curious if changing Use Internet from Yes to No has affect on battery drain ? (wondering if network sync is affecting battery drain)

Keep Smiling Smile

Posts 1056
Armin | Forum Activity | Replied: Wed, Feb 17 2021 8:15 PM

Have you checked the Energy usage and CPU usage of Logos in the MacOS Activity Monitor?

Posts 5173
Forum MVP
Mike Binks | Forum Activity | Replied: Thu, Feb 18 2021 12:46 AM

Hi Andy

I just checked my Activity Monitor and Logos is well down the scale of power users. ;-)

tootle pip

Mike

How to get logs and post them. (now tagging post-apocalyptic fiction as current affairs)

Posts 8
Andy Fuqua | Forum Activity | Replied: Thu, Feb 18 2021 4:30 AM

@Keep Smiling 4 Jesus, I will give that a try and see if it makes a difference. Thanks for the idea!

Posts 8
Andy Fuqua | Forum Activity | Replied: Thu, Feb 18 2021 4:32 AM

@Armin, Yes, I have checked those. That's where I got the 6x energy consumption number. Logos's energy consumption is consistently about 5 or 6 times other apps, even when I'm not using Logos actively but simply have it open in the background.

Posts 663
Kevin | Forum Activity | Replied: Thu, Feb 18 2021 8:08 AM

Andy could you post your logs for folks to look at here - there is a link in Mike Binks signature of how to do it, perhaps that will give some info.

Maybe leave it running half an hour before collecting them so we can see if there is something repeating over and over draining the battery.

Posts 8
Andy Fuqua | Forum Activity | Replied: Fri, Feb 19 2021 8:02 AM

Kevin, I'm not sure how to post my logs...

Posts 8
Andy Fuqua | Forum Activity | Replied: Fri, Feb 19 2021 8:02 AM

Duh. I'll check the link from Mike's signature. Sorry!

Posts 8
Andy Fuqua | Forum Activity | Replied: Wed, Feb 24 2021 8:02 AM

Kevin:

Andy could you post your logs for folks to look at here - there is a link in Mike Binks signature of how to do it, perhaps that will give some info.

Maybe leave it running half an hour before collecting them so we can see if there is something repeating over and over draining the battery.

Sorry for my delay. Logs are attached. Still experiencing severe battery drain when running Logos. Thanks!

6266.LogosLogs.andyfuqua.20210219-135708.zip

Posts 663
Kevin | Forum Activity | Replied: Thu, Feb 25 2021 11:15 PM

Hi Andy,

The Logos.log is only showing from 13:56:40 to 13:57:20, however there is an error occurring several times a second at the end, which may be, if continuing, what is causing the battery drain, if is doing a dump each time.

I cannot determine why this is happening, perhaps someone else can, you could also contact support.

First point I would suggest is it is possible that re-installation will resolve the issue, if there is a corrupt file or something.
I don't know myself how to do that on a mac without having to download and re-index, but you might be able to follow https://wiki.logos.com/Quick_Installation_onto_Multiple_Macs and workout from that the best method.

Perhaps before contacting support collect the logs for a bit longer to see if the error at the bottom of Logos.log keeps going.....

Uncaught (in promise) TypeError: undefined is not a function", source: assembly://faithlife.sermonwriterhost/dist/    index.html (0)

It maybe that error is normal on a mac or not the problem, I have not seen it before on Windows.

Hopefully someone from Faithlife will see this thread, but if not, support will be able to help.

Page 1 of 1 (13 items) | RSS