Logos Closes when trying to open visual filter

Page 1 of 1 (6 items)
This post has 5 Replies | 1 Follower

Posts 51
Bob | Forum Activity | Posted: Wed, Apr 7 2021 8:15 PM

I cannot open any previously created visual filter.  Logos terminates the app.  This just started today.

I can create new visual filters and then come back and edit them, but any existing visual filter, I cannot edit.  Logos terminates.

I'm on 9.3.0.0052.  

Is this happening to anyone else?

Bob

Posts 51
Bob | Forum Activity | Replied: Wed, Apr 7 2021 8:21 PM

Well, it seems to be an issue with my existing hebrew visual filters.  Other older visual filters are ok.  All my Hebrew visual filters crash the app on trying to edit them.

Bob

Posts 51
Bob | Forum Activity | Replied: Wed, Apr 7 2021 8:39 PM

Attaching log if anyone can help.  I will be talking to support tomorrow.

Logos.zip

Bob

Posts 24504
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Apr 7 2021 10:48 PM

Hi Bob - and thanks for posting the logfiles

It is flagging an issue with one of your visual filters:

2021-04-07 22:30:13.9680 INFO 1 PanelViewModel | Navigating panel to: Id=Document:VisualFilter:adaed53ee39047399746130f2e3b916b
2021-04-07 22:30:13.9837 INFO 1 PanelViewModel | Applying panel settings for Bookmark: Id=Document:VisualFilter:adaed53ee39047399746130f2e3b916b
2021-04-07 22:30:14.0843 ERROR 1 OurApp | Unhandled exception: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

But I'm afraid I don't know how to link this visual filter ID to a specific visual filter.

How much work is it to delete your Hebrew visual filters and recreate them?

Posts 51
Bob | Forum Activity | Replied: Thu, Apr 8 2021 6:05 AM

Thanks.  I'm working on re-creating them now.  

I think after I deleted them, I figured out what possibly happened.  All the Hebrew filters where using myTag and I changed the myTag to something else.  That caused the issue.   

So, now I am recreating my original myTag and going to trash bin and undeleting the visual filters.  They are working again!

Be careful about changing your tags that are used in visual filters!

Bob

Posts 24504
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Apr 8 2021 6:19 AM

Bob:
I think after I deleted them, I figured out what possibly happened.  All the Hebrew filters where using myTag and I changed the myTag to something else.  That caused the issue.   

Interesting!

I can see why I could cause the program to get confused - but it shouldn't really cause a crash!

Bob:
So, now I am recreating my original myTag and going to trash bin and undeleting the visual filters.  They are working again!

That's good to hear.

Page 1 of 1 (6 items) | RSS