Unhidden resources are not being downloaded and reinstalled

Page 1 of 1 (9 items)
This post has 8 Replies | 1 Follower

Posts 23
John Retallick | Forum Activity | Posted: Fri, Oct 1 2010 8:29 PM

Evening All,

I had hidden some of the books/resources in Logos 4. I have just unhidden a couple of them and expected them to show up again once I had restarted Logos.

Several restarts later, they are still nowhere to be seen.

Any ideas people?

 

Thanks,

John Retallick

Posts 18917
Rosie Perera | Forum Activity | Replied: Fri, Oct 1 2010 8:40 PM

Are they still listed in under Hidden Resources or have they disappeared from there?

Try typing "update resources" in the command box and see if that causes them to download. You might need to restart Logos again after doing that.

Posts 23
John Retallick | Forum Activity | Replied: Fri, Oct 1 2010 8:56 PM

You're brilliant!

 

Thanks!

Posts 5615
Todd Phillips | Forum Activity | Replied: Fri, Oct 1 2010 8:57 PM

I always experience this.  I think it is a bug.  "update resources" is always required to get back unhidden resources for me.  (And Logos will ask for a restart after it downloads them, just like any other resource download.)

Wiki Links: Enabling Logging / Detailed Search Help - MacBook Pro (2014), ThinkPad E570

Posts 18917
Rosie Perera | Forum Activity | Replied: Fri, Oct 1 2010 9:05 PM

I agree. It sounds like a bug to me.

Posts 23
John Retallick | Forum Activity | Replied: Fri, Oct 1 2010 9:07 PM

BTW, they had disappeared from the hidden resources area.

 

Thanks again,

 

Ciao.

Posts 4077
Melissa Snyder | Forum Activity | Replied: Wed, Oct 6 2010 9:39 AM

I tested this with a .logos4 resource, and after removing it from the Hidden Resource list and restarting Logos, the resource download began a few seconds later. I tried a second .logos4 resource, and again it automatically downloaded the book within 10 seconds of restarting the program. This is in version 4.1. (In Mac 4.0, once I restarted a second time, even though I didn't notice a download, the resource was again available in my Library.)

I also tried it with an .lbxlls (Libronix) resource. It didn't automatically download and 'update resources' didn't find any updates. However, the book was back in my library again because L4 had rediscovered the book in my \Libronix DLS\Resources folder.

Perhaps a few more details will help us troubleshoot why it's not working the same on your system:

1. Is 'Automatically Download Updates' set to 'Yes' in Program Settings?
2. Was Logos 4 indexing at the time?
3. Which resource was unhidden?

Thanks,
Melissa

Posts 23
John Retallick | Forum Activity | Replied: Thu, Oct 7 2010 3:49 PM

Automatically download updates is set to yes.

I'm pretty sure Logos was not indexing at the time.

The resource was "The Gospel according to Luke" by Bob Utley.

 

Thanks,

John

Posts 4077
Melissa Snyder | Forum Activity | Replied: Fri, Oct 8 2010 7:35 AM

Thanks John. I'll try it again with that specific resource.

Update:  I tried hiding/unhiding this resource and it was also downloaded automatically. I did find this previous post from Todd in March, however: http://community.logos.com/forums/t/13075.aspx, and checked the status of the bug report that was filed at that time. The case is still active, and it indicates that if the indexer is running both Hide and Unhide do not work until the indexing finishes and you restart the app.

I will add a link to this thread to the case so developers are aware that it may not always be related to the indexer running.

Page 1 of 1 (9 items) | RSS