Poor Logos 4 performance during certain mouse operations

Page 1 of 1 (7 items)
This post has 6 Replies | 2 Followers

Posts 12
Joe Kaczmarek | Forum Activity | Posted: Mon, Feb 28 2011 6:56 PM

Hello,

I am currently running Logos 4.2 SR-2 (4.20.4.8828) on a quad-core i5 with 3GB of RAM. Overall the performance ranges from acceptable to very good. However, whenever I click on one of the 'top' menus (i.e. Files, Guides, Tools, Layouts, Help), the mouse pointer alternates between frozen and moveable, is very 'jittery' and CPU consumption for the executing core goes to 100% whenever the mouse pointed is inside the menu proper. As soon as I move the mouse pointer out of the menu area, performance returns to normal. I do NOT have this problem with any other application that I use on this PC.

Can someone from technical support please investigate and provide a solution? Earlier versions of Logos 4 did not behave in this manner.

Thanks!

 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Mon, Feb 28 2011 7:10 PM

Welcome Big Smile

Logos 4.2a Release Candidate (RC) 1 is available => http://community.logos.com/forums/t/30222.aspx - wonder if mouse issue repeats ?

Observation: if no major issues, anticipating 4.2a release soon becoming "Gold" - hence lack of urgency to investigate 4.2 SR-2 issue.

Keep Smiling Smile

 

Posts 9097
Forum MVP
Mark Smith | Forum Activity | Replied: Mon, Feb 28 2011 7:10 PM

Joe,

Thanks for posting this on the Forums. I think you'll find this isn't a broad-based problem associated with the version of Logos 4 you are using, as I think you are the first to report it. I have a much less capable computer than you and am not having, in fact have never had, the behavior you are referring to. My mouse doesn't behave like yours and my CPU jumps to maybe 60% briefly. Logos 4 is built on the Microsoft .NET framework and WPF (Windows Presentation Foundation). It is the only program I am aware of on my computer based on this foundation. If this is true with you, we could see things here we don't see in other programs.

Hang in. Maybe someone will have a suggestion or Logos can look into the cause.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 6487
DAL | Forum Activity | Replied: Mon, Feb 28 2011 7:15 PM

The only mouse problem I have is when I use my laptop.  For some reason I can't get the mouse pad to work when I'm trying to go up and down on the pages of my Bibles, commentaries, etc.  I have to use my up and down arrows.

Posts 8601
TCBlack | Forum Activity | Replied: Mon, Feb 28 2011 7:16 PM

Joe, 

It may seem trivial but can you tell me (us) what kind of video card is in your computer?  

That is to say, is it onboard video, a separate card, and if you can add which chip and how much video ram that would be handy.  

 

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 12
Joe Kaczmarek | Forum Activity | Replied: Mon, Feb 28 2011 9:46 PM

It's on a ThinkPad T410 laptop. Display adapter is NVIDIA NVS 3100M with 512MB memory. Thanks for your help.

Posts 13368
Forum MVP
Mark Barnes | Forum Activity | Replied: Tue, Mar 1 2011 1:56 AM

Joe Kaczmarek:
Can someone from technical support please investigate and provide a solution? Earlier versions of Logos 4 did not behave in this manner.

Hi Joe,

This isn't the place to get Tech Support direct from Logos (you'll need to telephone or email them direct for that). This is a forum of Logos users.

Having said that, here's one post that may help. It's from someone with a Dell, but the same graphics card as you, and what seems to me like a very similar problem. He sorted it by download the driver suggested by Windows Update: http://en.community.dell.com/support-forums/laptop/f/3518/p/19332047/19695693.aspx

Here's a similar thread: http://www.lostfocus.net/2010/05/03/dell-latitude-e6410-stuttering-system/

That suggests at least the possibility of driver problems. It might be worth trying the drivers from Microsoft, Lenovo and nVidia to see if you can find which one gives least trouble.

Page 1 of 1 (7 items) | RSS